FORUMS

Other than XDA (of Course), What’s Your Favorite Site That Covers Android?

There is a number of other great sites that cover … more

Introducing Voices of XDA: Have Your Ideas Heard

By far the greatest assets we have at XDA-Developers are you, the developers, the eager … more

Unofficial Xposed For Lollipop Touchwiz With Flashable Zip

XDA Recognized Developer arter97 has released an unofficial build … more

YotaPhone 2 Pre-Order, Xperia Z1 Price Cut – XDA TV

Android Wear 5.1.1 OTA downloads are now available. That and much more news is … more
Post Reply Subscribe to Thread Email Thread

[Q] unable to flash anyrom after kitkat port

29th May 2014, 06:03 AM |#1  
OP Junior Member
Flag Londrina
Thanks Meter: 1
 
Donate to Me
More
Hi there,

I flashed a KitKat port to test it. However, I decided to go back to Cyanogenmod since it didn't work very well.

However, any ROM that I try to flash appears this error:

format() expects 5 args, got 3
E: Error in /storage/sdcard0/cm-7.2.0-p500.zip
(Status 7)
Installation aborted

what can I do to fix this? thanks
 
 
29th May 2014, 11:23 AM |#2  
Senior Member
Thanks Meter: 1,066
 
More
Quote:
Originally Posted by Athosbr99

Hi there,

I flashed a KitKat port to test it. However, I decided to go back to Cyanogenmod since it didn't work very well.

However, any ROM that I try to flash appears this error:

format() expects 5 args, got 3
E: Error in /storage/sdcard0/cm-7.2.0-p500.zip
(Status 7)
Installation aborted

what can I do to fix this? thanks

To flash that KitKat, you had to place a newer CWM or TWRP recovery version.
To flash cm-7.2, you need to go back to the older recovery!
The Following User Says Thank You to Dovidhalevi For This Useful Post: [ View ]
29th May 2014, 08:05 PM |#3  
shinobisoft's Avatar
Recognized Contributor
Flag Knoxville, TN
Thanks Meter: 3,087
 
Donate to Me
More
For KitKat ROMs a recovery equivalent to 6.0.4.5 or newer is required to flash. The newer recoveries are capable of flashing CM 10.2 to CM11. All older Android versions will require the use of an older recovery, pre 6.0.4.5, such as CWM 5.0.2.7 Touch by vivekkalady.
The Following User Says Thank You to shinobisoft For This Useful Post: [ View ]
31st May 2014, 11:21 PM |#4  
OP Junior Member
Flag Londrina
Thanks Meter: 1
 
Donate to Me
More
Quote:
Originally Posted by Dovidhalevi

To flash that KitKat, you had to place a newer CWM or TWRP recovery version.
To flash cm-7.2, you need to go back to the older recovery!

Quote:
Originally Posted by shinobisoft

For KitKat ROMs a recovery equivalent to 6.0.4.5 or newer is required to flash. The newer recoveries are capable of flashing CM 10.2 to CM11. All older Android versions will require the use of an older recovery, pre 6.0.4.5, such as CWM 5.0.2.7 Touch by vivekkalady.

nice to know that. I will try later

In other subject, I tried other kitkat roms and they gave me that same error. the only one that worked was Omega. is there any reason to that?
1st June 2014, 06:08 PM |#5  
shinobisoft's Avatar
Recognized Contributor
Flag Knoxville, TN
Thanks Meter: 3,087
 
Donate to Me
More
Quote:
Originally Posted by Athosbr99

nice to know that. I will try later

In other subject, I tried other kitkat roms and they gave me that same error. the only one that worked was Omega. is there any reason to that?

Sorry, I honestly can't say. I no longer use this device so I've been out of the loop for some time now.
8th October 2014, 08:24 PM |#6  
Junior Member
Thanks Meter: 0
 
More
Also having same problem
Can't Flash anyother rom after kitkat port.

plz help me.
Thanks
7th November 2014, 08:42 AM |#7  
Junior Member
Flag Hyderabad
Thanks Meter: 1
 
More
Quote:
Originally Posted by DevG

Can't Flash anyother rom after kitkat port.

plz help me.
Thanks

Have you installed any custom kernel?
I am also faced this problem and solved by flashing stock rom with KDZ
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes