Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[ROM][UNOFFICIAL] CyanogenMod 11 [Android 4.4.4]

OP WinSuk

29th October 2014, 09:57 AM   |  #81  
OP Senior Member
Thanks Meter: 858
 
503 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by xd0

Here is a new and completely unexpected challenge. I Installed cm-11-20141025-NIGHTLY-liberty.zip from the scratch. And of course, the first thing to do is to install an app. In order to do so I run its File Manager, tap on .apk file and got the response - "There is no app registered to handle the type of file selected" ... And there seems to be no way to set that file association. Full stop now

Reboot... The package installer probably didn't compile
The Following User Says Thank You to WinSuk For This Useful Post: [ View ]
29th October 2014, 10:03 PM   |  #82  
Junior Member
Thanks Meter: 0
 
28 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by WinSuk

Reboot... The package installer probably didn't compile

Thank you, @WinSuk. It worked. Actually I made backup of that new install yesterday and after restoring today File Manager recognized .apk extension. First thing to install is Link2SD v3.5.2. Then all new apps go (are linked) to ext2 partition...

The reason I tried to install new CM11 ROM from the scratch was - suddenly I've noticed, that Superuser app has disappeared from my access. It's similar to what I've mentioned earlier - apps may disappeared, but after reboot they may come back. But in this case I made several reboots and still not see it... Permissions were kept correctly (apps, that were granted root access before still have it), but I can't grant root access to new apps anymore or see log of root access requests.

Then I tried to install SuperUser-3.1.3.apk (1,468,798; MD5: E0BC7B7284B68C9539B6EC6B306310E0) directly. It installs without errors, but it becomes somehow "irrelevant"... It doesn't show list of apps anymore, doesn't get system requests to provide (or not) permissions, etc. Installing it (Superuser-3.1.3-arm-signed.zip, B3C89F46F014C9DF7D23B94D37386B8A) from Recovery did not help either. That forced me to make new CM11 install form the scratch.

@WinSuk, do you have any advice on how to deal with it in case if Superuser app (UI to su) is suddenly gone? Reinstalling whole ROM from the scratch, while is refreshing, is time consuming process that I'd like to avoid.
30th October 2014, 12:27 AM   |  #83  
OP Senior Member
Thanks Meter: 858
 
503 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by xd0

Thank you, @WinSuk. It worked. Actually I made backup of that new install yesterday and after restoring today File Manager recognized .apk extension. First thing to install is Link2SD v3.5.2. Then all new apps go (are linked) to ext2 partition...

The reason I tried to install new CM11 ROM from the scratch was - suddenly I've noticed, that Superuser app has disappeared from my access. It's similar to what I've mentioned earlier - apps may disappeared, but after reboot they may come back. But in this case I made several reboots and still not see it... Permissions were kept correctly (apps, that were granted root access before still have it), but I can't grant root access to new apps anymore or see log of root access requests.

Then I tried to install SuperUser-3.1.3.apk (1,468,798; MD5: E0BC7B7284B68C9539B6EC6B306310E0) directly. It installs without errors, but it becomes somehow "irrelevant"... It doesn't show list of apps anymore, doesn't get system requests to provide (or not) permissions, etc. Installing it (Superuser-3.1.3-arm-signed.zip, B3C89F46F014C9DF7D23B94D37386B8A) from Recovery did not help either. That forced me to make new CM11 install form the scratch.

@WinSuk, do you have any advice on how to deal with it in case if Superuser app (UI to su) is suddenly gone? Reinstalling whole ROM from the scratch, while is refreshing, is time consuming process that I'd like to avoid.

I have no idea what to do - CM11 is just really buggy on this device.
30th October 2014, 04:59 AM   |  #84  
Junior Member
Thanks Meter: 0
 
28 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by WinSuk

I have no idea what to do - CM11 is just really buggy on this device.

I've got yet another problem. Now it's with File Managers I need to use.

1. Native File Manager v1.0.2 refuses to copy APK files form /data/app folder. It was setup to do so: "Settings | General settings | ADVABCED | Access mode" is set to "Root Access mode". FM shows content of /data/app folder correctly, but when I try to copy an .APK file from that place to SD card, it indicates "The operation failed"...

2. ES File Explorer v1.6.2.5. I can install it just fine, but I can't copy .APK files from /data/app folder to SD card too. It shows, that folder is empty (a typical permission problem). I can see files in /system/app folder though.. ESFE has permission from Superuser to have access to root. But when I try to set its option "Root Explorer" it always fails its own test (message "Sorry, test failed. This feature cant run on your phone."). At the same time Superuser indicates twice, that it grants root access to it...

3. ES File Explorer v3.2.1.2 can't even be installed now. Installation simply ends with message "App not installed". Logcat indicates error: -103. Is this error related to some certificate problems? I had it installed in previous version of CM11 (built 20140715)... I remember that I did tried to install GApps at that time, but they were uninstalled long time ago. May be they added new certificates to sec. store and left them there and that allowed to install ESFE v3.2.1.2, allowing to install it... I don't know.

It';s hard to work with new ROM, if I can't use basic File Manager programs to copy .APK files in case I need it
31st October 2014, 10:05 AM   |  #85  
Junior Member
Thanks Meter: 0
 
28 posts
Join Date:Joined: Dec 2010
ES File Explorer v3.1.8 can be installed with CM11 and works well.
11th November 2014, 03:26 PM   |  #86  
Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Mar 2007
Mounts2SD use with CM11 on Liberty
Winsuk, Thanks for your and everyone else work on the Liberty, I really enjoy using this phone with your builds. I'm interested in your opinion on using Mounts2SD with your build of CM11. I've been using it for a while and it seems to work well though it does slow the device down a bit. The tradeoff is I get unlimited space to install anything I like on the very small device. Have you tried this and if so would you recommend it or why if you would not?
12th November 2014, 01:15 PM   |  #87  
OP Senior Member
Thanks Meter: 858
 
503 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by WildDogRob

Winsuk, Thanks for your and everyone else work on the Liberty, I really enjoy using this phone with your builds. I'm interested in your opinion on using Mounts2SD with your build of CM11. I've been using it for a while and it seems to work well though it does slow the device down a bit. The tradeoff is I get unlimited space to install anything I like on the very small device. Have you tried this and if so would you recommend it or why if you would not?

I haven't used Mounts2SD specifically (that I remember), but I have used similar stuff... It's pretty much required on CM11 if you're going to use it for more than just "Ooo cool, KitKat"
12th November 2014, 10:16 PM   |  #88  
Junior Member
Thanks Meter: 0
 
28 posts
Join Date:Joined: Dec 2010
@WildDogRob
I haven't use Mounts2SD too, but I always use Link2SD for that purpose. I use it withn all ROM's I tried and I haven't noticed any slow down. You may want to try it too. It's very reliable IMHO.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes