Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

LTE issues (T Mobile / Metro PCS)

OP mexigga

15th May 2014, 01:17 AM   |  #11  
Coug76's Avatar
Senior Member
Flag East of Seattle
Thanks Meter: 767
 
2,012 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by mexigga

Went to MPCS store and verified that they are not locking out non-metro branded phones from LTE. Also SIM cards do not restrict GSM phones from LTE only the device itself, if it is not LTE capable.

You might check out the linked info.

http://forum.xda-developers.com/show...php?p=52587979


Hastily spouted for your befuddlement
2nd July 2014, 07:19 AM   |  #12  
Changed Sim card and shows band 4 or 17 LTE but service state shows limited. Called MPCS had them refresh network to no avail...

Not sure what else to do at this point.
18th July 2014, 01:20 AM   |  #13  
Update...LTE running fine now. Called (again) had them (again) refresh my network. Turned phone back on after operator stated it was refreshed and LTE finally connected.

20th October 2014, 12:46 AM   |  #15  
montecristo1's Avatar
Senior Member
Thanks Meter: 33
 
327 posts
Join Date:Joined: Oct 2008
My APN experience:
fast.metropcs.com- data ok/4g/lte but unable to receive mms
fast.t-mobile.com- everything works
16th November 2014, 01:44 AM   |  #16  
montecristo1's Avatar
Senior Member
Thanks Meter: 33
 
327 posts
Join Date:Joined: Oct 2008
Did the same, Mexigga. Gave my i317 to my wife and bought a t889 best decision. I noticed LTE is stable and faster.
The Following User Says Thank You to montecristo1 For This Useful Post: [ View ]
16th November 2014, 10:04 PM   |  #17  
Sure is more stable....thanks @montecristo1

Sent from my SGH-T889 using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes