AOSP 5.1 ROM Compiled for the Moto E

It’s been a few weeks since the release of Android 5.1 and XDA Senior Member percy_g2 has … more

CutCalc: A Calculator for Mechanical Engineers

Mechanical and mechatronics engineers may want a handy app to calculate data for … more

Google Play Music Customizations – XDA Xposed Tuesday

If Cyanogen Inc. has its way, you won’t be forced into the Google … more

Sony Xperia Z3 Lollipop Framework Ported to CM12

Android 5.0 for Xperia has a unique look and feel. You don’t have to get a Sony … more
Post Reply Subscribe to Thread Email Thread

Motorola Moto G Xt1032 - how to recover IMEI?

20th September 2014, 10:55 PM |#21  
k.aibutsu's Avatar
Member
Flag Berlin
Thanks Meter: 94
 
72 posts
Join Date:Joined: Oct 2013
Donate to Me
More
Got the same problem, I have poor reception, imei 0 on rom, correct imei in fastboot. Cell reception is bad and often interrupts. Trying a new provider now, seems to work a bit better...

Quote:
Originally Posted by robin0800

You could all try this new method claimed to be working but as I have not lost my IMEI I can't say, please report back if it works for you?

http://forum.xda-developers.com/moto...imei0-t2860481

Doesn't seem do work...maybe reflashing stock without sim inserted works at some point, i tried it once but it didn't maybe, if you do it repeatedly...I read twice that it would. Just don't have the time to flash my phone over and over again.
In the meantime, i found "/proc/config/imei/", a folder in wich my imei is actually stored correctly. I also found reports of a file "/data/property/persist.radio.imei". I tried to set it by "cat [imei] > ..." but it didn't work.
Does this help any of you?
 
 
13th November 2014, 04:03 PM |#22  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2014
venkat
Sir I'm also facing that problem..... So many times installed custom ROM official version of my moto e.... But no use. Unfortunately my efs is lost .... Plz help me to solve this prob plz sir thank u.....
14th November 2014, 05:38 AM |#23  
Senior Member
Thanks Meter: 92
 
422 posts
Join Date:Joined: Sep 2014
More
Do this completely at your own risk. (Mods if this is violating the rules, sorry, and feel free to remove it. I am just trying to help a user) You the owner agree to take full responsibility by using this method.

First go to bootloader mode. Type fastboot getvar all. Look for your imei. If your imei is listed in the command window: try reflashing stock firmware. Boot and your problem may be solved.

If your imei is 0 or if its blank or anything else, there is a command to manually set it. I can't post in this forum though because its against the rules.
Last edited by skyguy126; 14th November 2014 at 06:21 PM.
14th November 2014, 11:19 PM |#24  
Junior Member
Thanks Meter: 2
 
15 posts
Join Date:Joined: Aug 2014
More
command to set imei
Quote:
Originally Posted by skyguy126

If your imei is 0 or if its blank or anything else, there is a command to manually set it. I can't post in this forum though because its against the rules.

Would you be so kind to post this command in a personal message? I have Moto G XT1033.
14th November 2014, 11:36 PM |#25  
Senior Member
Thanks Meter: 92
 
422 posts
Join Date:Joined: Sep 2014
More
Quote:
Originally Posted by ol_st

Would you be so kind to post this command in a personal message? I have Moto G XT1033.

It's not about kindness, it's the fact its illegal to manually set your imei, but if you really need to....

Do this completely at your own risk: (This is an indirect way I can show you the command)
http://forum.xda-developers.com/show....php?t=2300654

Look through the list until you see it. (It is pretty obvious)
15th November 2014, 05:42 PM |#26  
Senior Member
Thanks Meter: 92
 
422 posts
Join Date:Joined: Sep 2014
More
Did it work for anyone?
16th November 2014, 09:13 AM |#27  
Junior Member
Thanks Meter: 2
 
15 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by skyguy126

Did it work for anyone?

writeimei definitely not working, I tried that 3 months ago.
17th November 2014, 05:05 AM |#28  
Senior Member
Thanks Meter: 92
 
422 posts
Join Date:Joined: Sep 2014
More
What was the error
18th November 2014, 12:12 AM |#29  
robin0800's Avatar
Senior Member
Thanks Meter: 94
 
282 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by skyguy126

What was the error

The moto g fastboot oem has very few commands and writeimei is not one of them
to see commands
Quote:

fastboot oem help

18th November 2014, 12:28 AM |#30  
lost101's Avatar
Senior Member
Thanks Meter: 2,520
 
2,906 posts
Join Date:Joined: May 2008
Donate to Me
Please refer to this thread: http://forum.xda-developers.com/moto...imei0-t2925970
If you have done: fastboot erase all - you are screwed.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes