Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Stuck in download mode, FlashTool fails with missing model information (BRICKED?)

OP SamerAdra

27th March 2014, 11:51 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Mar 2014
My LG G2 D800 (AT&T) 32 GB is stuck in download mode and I cannot flash the stock ROM to it.
I can't get out of download mode no matter how I try to press keys at boot, etc. -- just a black screen with the LG logo.

adb devices returns no devices found.

Shows in Windows Device Manager as "LGE AndroidNet USB Serial Port (COM4)."
Flash Tool finds my device, but when I try to flash (using dll C:\Users\SAdra\Downloads\LGD800_20130904_LGFLASHv1 60.dll and S/W LGD800AT-01-V10O-310-410-OCT-19-2013+0.tot), it fails immediately and says "Model Information Check Fail!"

It shows "IMEI : " and "Model : ". That's really scary if that information has truly disappeared (not sure how that could have happened though). I at least have the IMEI on a sticker on the back.

I used ioroot to successfully enter root mode, so I should have an EFS backup, but I don't know how to recover it since I'm in download mode and the only tool I have to work with is the LG FlashTool, which isn't happy with me right now. I've tried key combinations but I can't seem to enter recovery mode or fastboot or anything from here.

Previously I was stuck in a fastboot loop but then I re-flashed most of the stock partitions from (downloads.codefi.re 10d_partitions directory under D800 Stock_Firmware) -- I remember doing this for aboot, boot, dbi, laf, modem, recovery, and abl1 -- I was following some dumb forum post in which someone recommended doing that -- duhh...

I would be happy at this point if I could get back into my fastboot loop -- at least I could flash stuff from there.

What got me into the fastboot loop in the first place was flashing the BeanStalk ROM (it was a two-part thing where you were supposed to first flash the main ROM and then flash a device-specific patch -- well, the initial ROM flash got me into the fastboot loop).

Any recommendations? If I were to use Linux, would I have any other options -- I've seen people mention flashing partitions using dd?

At this point I'm about ready to take it in to AT&T (still under warranty / in contract) and beg for help, although I know I've obviously voided my warranty by rooting it.

I've seen a few older threads where people are stuck in download mode and have the same "model information" error in FlashTool, and it seems nobody ever replies to those threads, so I think I'm out of luck. If anybody has gone through this or has any idea what I can do, I would really appreciate the help.

Thanks,
19th November 2014, 01:18 AM   |  #2  
Member
Thanks Meter: 1
 
35 posts
Join Date:Joined: Sep 2007
I have the same problem with my G2. I am stuck at the LG logo. No recovery and download mode stuck at the dots. Phone is recognized (while its showing the LG logo) on the control panel as LGE AndroidNet USB Serial port (41) and LGE AndroidNet USB modem. I have tried all tutorials (hard resets, linux etc) I found but nothing worked. Anyone with suggestions???
thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes