Shoot Troubles, Not Users w/ Alex Boag-Munroe – XDA:DevCon 2014

In presenting the various sessions from XDA:DevCon 2014, weve mainly … more

Oppo Releases ColorOS for the Find 5… Poorly

Almost every OEM has taken the liberty of creating its own incarnation of the Android OS. … more

XDA LG Development Challenge Winners

Almost 3months ago, we set out with LGto findtwo amazing apps that developers could put together … more

Wearable Apps w/ Andreas Göransson – XDA:DevCon 2014

XDA:DevCon 2014 in Manchester, UK featured quite a few interesting topics as … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] "Allow USB Debugging?" Keeps Popping Up!

OP pnuker

25th January 2014, 04:26 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Jan 2014
After upgrading to 4.3 on my i535 GS3, I'm now faced with a very annoying new problem. I use easytether pro to tether to my macbook, and now when I plug in the usb it pops up with "Allow USB Debugging?" followed by my computer's RSA key fingerprint, and then a checkbox for "Always allow from this computer".

It doesn't matter if I check the "always allow" because the next time I plug it in, it pops up with the same message again. For some reason it's not recognizing my computer, even though the RSA key fingerprint is exactly the same every time. Even worse, I have to go through this process twice every single time I plug in my usb - once for the usb connected as an installer, and twice when it switches from installer to media device.

I use tethering quite a bit, so this is kind of grinding my gears! Does anybody know what might be going on here? Is it possibly just a mac thing? Perhaps something wrong with my settings?
Last edited by pnuker; 25th January 2014 at 05:54 PM.
25th January 2014, 06:38 PM   |  #2  
buhohitr's Avatar
Senior Member
Thanks Meter: 1,628
 
5,449 posts
Join Date:Joined: Nov 2011
Try this, In developer options ->root access - allow apps and adb also USB debugging notify is unchecked.

Sent from my Galaxy Nexus using xda premium
25th January 2014, 08:30 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by buhohitr

Try this, In developer options ->root access - allow apps and adb also USB debugging notify is unchecked.

Sent from my Galaxy Nexus using xda premium

I don't seem to have any "root access" options in my developer options. Is it hidden or something?
25th January 2014, 08:42 PM   |  #4  
buhohitr's Avatar
Senior Member
Thanks Meter: 1,628
 
5,449 posts
Join Date:Joined: Nov 2011
Sorry I must be half sleeping and thinking about custom ROM. You don't have that option, anyway do you still have the messag after untick the notify option?

Sent from my Galaxy Nexus using Tapatalk
26th January 2014, 02:14 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by buhohitr

Sorry I must be half sleeping and thinking about custom ROM. You don't have that option, anyway do you still have the messag after untick the notify option?

Sent from my Galaxy Nexus using Tapatalk

You mean leave the "Always allow from this computer" unticked? I've tried both ways...it always comes back. It wouldn't be a big deal if it wasn't for the face that the connection is blocked until I hit the ok button, twice around.
6th February 2014, 04:15 AM   |  #6  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Jan 2014
Still having the issue. It's starting to grind my gears...

I nobody else having this issue?
14th May 2014, 08:36 PM   |  #7  
bmg002's Avatar
Senior Member
Thanks Meter: 192
 
466 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by pnuker

Still having the issue. It's starting to grind my gears...

I nobody else having this issue?

I just started having this issue and am investigating it. If I had to guess, I'd say the rsa key store is corrupt, but I'm just guessing. It was working fine this morning, and this afternoon it started yelling at me repeatedly.

I'm going to grab a logcat then will post back if/how I fixed it.

EDIT: turns out my issue was a bad USB cable. well, a bad USB cable connection. unplugged and reseated the cable and it seems to be working now.
19th November 2014, 02:21 PM   |  #8  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jan 2011
More
I am also having this issue with two devices out of three I tried.

Samsung Note 10.1 (SM-P600) running Android 4.3 and ASUS K011 (ME181CX) running Android 4.4.2 always asks for permission. I tried everything including using different cables, different usb slots, different adb.exe. Even tried rooting K011, but no luck.

However, I am not having this issue with Sony Ericsson Xperia Arc (LT15i) running 4.0.4.

Edit: I came here from Google and now noticed that this is Galaxy S III section, but I think the reason to this issue and the solution will be the same. I will post the solution to here if I can do it.

---------- Post added at 03:21 PM ---------- Previous post was at 02:21 PM ----------

Yeah, solved it. I first killed adb.exe then simply deleted the folder C:\Users\Username\.android. After that I plugged my device in and typed "adb devices". This changed the RSA key etc. It asked for the permission again and "Always allow" option worked this time.

This method worked on both ASUS and Samsung. Hope this works for you too.

Note: I recommend you backup that folder before deleting it. Or just move it into another folder.
Last edited by nailgg; 19th November 2014 at 01:25 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes