Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[MOD]Write to extsd (root required)

OP evilbeef54

17th August 2014, 11:19 PM   |  #11  
tydiamond11's Avatar
Senior Member
Flag Arizona
Thanks Meter: 197
 
1,110 posts
Join Date:Joined: Feb 2013
Donate to Me
More
One thing I have to say about this is when I did it i had issues with the camera app saving to extsd. So I changed it back after a lot of work on it.
20th September 2014, 07:24 AM   |  #12  
Hiro14's Avatar
Member
Flag Orem, Utah
Thanks Meter: 8
 
46 posts
Join Date:Joined: Oct 2010
More
Confirmed working. Thanks for the mod advice. Just make sure to make the edits exactly as shown in the image.

I tried the SDfix apk and it worked only on the root of the SD card. Any file structure past the root did not have rw access.

Now that I can write to my sd, I am noticing very poor speeds. We are talking like less that 1MB/s. I tested it with both large iso files and a bunch of small 30-300 kb files. Both tests are very slow. Any ideas on where to look to fix that?

Sent from my SM-G900V using XDA Premium HD app
23rd November 2014, 06:34 PM   |  #13  
Senior Member
Thanks Meter: 39
 
185 posts
Join Date:Joined: Jun 2011
Quote:
Originally Posted by evilbeef54

OK so as you have noticed kit kat does NOT allow third party apps to write to the SD card, this is stupid, but lucky for us we have a fix IF you are rooted


we have 2 solutions

1) using root explorer or something similar go to

Quote:
/system/etc/permissions/platform.xml
and enter the permission that i have circled in red below (see attached) then it will work. Enter it so it looks EXACTALLY like it does below


2) the other option that MAY work is to go to the play store and download SDFix, that does the same thing (however myself and a few others are reporting that it isnt working as it is written)

big thanks to Mr Sam Epic for showing the fix, which came from Unknown Force in a SGS4 forum


****edit 4/19

had a few reports of SDFix not working, it didnt for me, i thought it was just a random error, what i did to fix it was to go into platform.xml and manually edit the permission so it looks exactally like the image below, i put in the extra return after the permission, there is not a logical reason why this fixed it, but it did

original thread here:

http://forum.xda-developers.com/show...php?p=51861458

So I tried this and my ability to use the TextSecure app broke. I reverted back to the auto-created backup (thank you Root Explorer) of my platform.xml file, and it restored TextSecure functionality after a reboot. However, I have been unable to turn Bluetooth on since doing this. The only other change was updating to the latest release of Busybox this morning, which apparently was just released. Could this platform.xml file triggered some other actions upon rebooting that would cause Bluetooth problems?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes