Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Moto G 4g LTE - Sandisk ultra 32gb microsd card won't mount

OP Arthemedus

27th September 2014, 04:59 AM   |  #151  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Sep 2014
Quote:
Originally Posted by Gooofyden

I bought my son a Motorola moto g LTE (XT 1039) works fine out the box, but i just can't seem to get a 32GB sd card to work. I bought 3 as a meal deal from an online shop and i've tried all 3 and all i get is 'SD card has unexpectedly been removed'.

The SD cards i bought were:

Transcend microSDHC UHS-I Premium 300x 32GB Class 10

I've Googled the issue but all i can find is people with the same problem but no solution. Is there a reason why they are not working? is there a software update that will fix the issue?

Regards
Den

FINALLY I'VE FOUND A WORKARROUND for this problem. Simply turn on your moto g without any sd, then when it is fully loaded and unlocked insert your class 10 sd. You wont be suffering that issue until next reboot. Give it a try! CHEERS!
29th September 2014, 01:32 PM   |  #152  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jan 2013
I received another OTA update over the weekend (4.4.4 appeared a ittle while back - this is another one), which claimed to improve the SD card problem and improve reception. I've just tried my Sandisk U1 card that wouldn't work before and the phone didn't even recognise there was a card present. So it's back to a class 4 Samsung instead - that's working fine. Oh well.
29th September 2014, 02:21 PM   |  #153  
Junior Member
Flag Ljubljana
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2011
More
Update .56 (System version 21.11.56) fix the class 10 SD card problems. At least it did for me.
2nd October 2014, 10:26 AM   |  #154  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2014
Class 10 32gb micro sd
Unfortunately I'm still having problems with my sdcard even after the update to .56. I've tried taking it out and formatting it. It works until I restart the device and then nada! BOOO!
9th October 2014, 04:30 AM   |  #155  
Allan_Hun's Avatar
Senior Member
Flag Gl.Rye
Thanks Meter: 92
 
247 posts
Join Date:Joined: Mar 2014
After the update to .56. my SanDisk Ultra U1 32GB SDCard only work every second restart
It works perfectly fine in my old Galaxy S3 mini.
16th October 2014, 02:47 PM   |  #156  
Junior Member
Thanks Meter: 2
 
4 posts
Join Date:Joined: Oct 2014
Thumbs up
Necrorising this thread a bit.
I have 2x Moto G LTE. Both are with the latest .56 update. I have Samsung Class 10 micro sd card. First time putting this in the first Moto G - "Unexpected bla bla..." error.
What I did?
1. Popped the micro sd in the adapter and then in my laptop
2. Formated (not quick) 32 bytes, FAT 32.
3.Plugged in the card, no problems so far, from both micro sd cards and both phones.
25th October 2014, 05:39 PM   |  #157  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2014
(Alright, after having been a long passive user of the xda forums I finally made an account to contribute).

Having read all the posts in this thread I wanted to add this:

I am also having trouble with 32GB Sandisk Ultra UHS-1 in my Moto G XT1039 running 4.4.4. I got the "Blank SD card or has unsupported filesystem" error twice. First time after I purchased the phone it worked fine for a week and then it gave me the error on the card (which works on the S3 btw). The I reformatted it but got the error again a couple of days later after rebooting the phone.

I was speaking to the Motorola support on the live chat and he asked me to check whether the card still wouldnt work if I popped out my sim. And, strangely, the sd card DID work when my sim card was not in the phone. Subsequently, I put the sim back in and the SD card works. (This is no solution though since Spotify wont recognize the downloaded files anymore - so I'll still have to download those GBs again...)

All in all, it does seem to be a hardware issue (esp since it does work when the SIM is not in the phone ???).

Now, the Motorola supported suggested I'd send my phone in, but I'm hesitant 'cause I can't do without the phone really.
So does anyone have had this issue with a class 6 sd card? If not I'll buy one of those and leave it at that.

Thanks,

M
24th November 2014, 04:48 PM   |  #158  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Nov 2014
How I fixed my issues
So I don't guarantee this to work with anyone else but it just might. I have a kingston 32GB class 10 uhs1 sdhc card and used a mac's built-in disk utility to create two 'partitions'. One regular fat partition and one empty partition as small as it let me. The fat partition is now usable.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes