Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Tool]Advanced ApkTool v4.0.0[Windows][13/11/2014]

OP BDFreak

19th November 2014, 05:13 PM   |  #221  
CoolJoseph96's Avatar
Senior Member
Thanks Meter: 134
 
127 posts
Join Date:Joined: Jul 2012
I have the same problem, but i have all SDK Platform Installed!

Code:
(ARSCDecoder.java:100)
        at brut.androlib.res.decoder.ARSCDecoder.readTable(A
RSCDecoder.java:78)
        at brut.androlib.res.decoder.ARSCDecoder.decode(ARSC
Decoder.java:47)
        at brut.androlib.res.decoder.ARSCDecoder.decode(ARSC
Decoder.java:39)
        at brut.androlib.res.AndrolibResources.installFramew
ork(AndrolibResources.java:657)
        at brut.androlib.Androlib.installFramework(Androlib.
java:649)
        at brut.apktool.Main.cmdInstallFramework(Main.java:2
56)
        at brut.apktool.Main.main(Main.java:92)
Can anyone help us?
19th November 2014, 05:20 PM   |  #222  
Vivek_Neel's Avatar
Recognized Contributor / Themer
Flag chennai
Thanks Meter: 20,213
 
7,874 posts
Join Date:Joined: Dec 2012
Donate to Me
More
Quote:
Originally Posted by CoolJoseph96

I have the same problem, but i have all SDK Platform Installed!

Code:
(ARSCDecoder.java:100)
        at brut.androlib.res.decoder.ARSCDecoder.readTable(A
RSCDecoder.java:78)
        at brut.androlib.res.decoder.ARSCDecoder.decode(ARSC
Decoder.java:47)
        at brut.androlib.res.decoder.ARSCDecoder.decode(ARSC
Decoder.java:39)
        at brut.androlib.res.AndrolibResources.installFramew
ork(AndrolibResources.java:657)
        at brut.androlib.Androlib.installFramework(Androlib.
java:649)
        at brut.apktool.Main.cmdInstallFramework(Main.java:2
56)
        at brut.apktool.Main.main(Main.java:92)
Can anyone help us?

Did u install framework?

Sent from my Nexus 5 using XDA Free mobile app
19th November 2014, 05:21 PM   |  #223  
CoolJoseph96's Avatar
Senior Member
Thanks Meter: 134
 
127 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by Vivek_Neel

Did u install framework?

Sent from my Nexus 5 using XDA Free mobile app

That is what i got in framework installation :/
19th November 2014, 05:54 PM   |  #224  
The Sickness's Avatar
Recognized Contributor
Flag Somewhere in Texas
Thanks Meter: 11,523
 
5,327 posts
Join Date:Joined: Oct 2012
Donate to Me
More
You need to delete all the api's that you don't need. If you're just running 5.0 there is no need for others.

Plus, make sure you have the latest platform_tools.
The Following User Says Thank You to The Sickness For This Useful Post: [ View ]
19th November 2014, 06:18 PM   |  #225  
CoolJoseph96's Avatar
Senior Member
Thanks Meter: 134
 
127 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by The Sickness

You need to delete all the api's that you don't need. If you're just running 5.0 there is no need for others.

Plus, make sure you have the latest platform_tools.



Thank you, so I'll use
android sdk tools
Android sdk platform tools
Sdk platform (api 20)

I'm gonna to try it!!!

Edit:

I get the same error :/


Edit 2:

Fixed
Last edited by CoolJoseph96; 19th November 2014 at 06:28 PM.
19th November 2014, 07:34 PM   |  #226  
xdagee's Avatar
Senior Member
Flag Accra
Thanks Meter: 551
 
842 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by sizzlingtycoon

I tried installing the framework-res.apk and got these errors



Attached the framework-res.apk
Plz help

Edit: Had to mention i tried to install the same Lollipop version like that of xdagee BUT have the SDK updated to API 21

Oh so you had the same problem as i did even though you had updated sdk + platform tools?
20th November 2014, 07:07 AM   |  #227  
eyesfortech's Avatar
Junior Member
Flag Quezon City
Thanks Meter: 12
 
29 posts
Join Date:Joined: Nov 2011
More
Thumbs up Thanks!
Thanks OP, I will try this updated version and provide feedback
Today, 10:13 AM   |  #228  
gandolf007's Avatar
Member
Thanks Meter: 6
 
91 posts
Join Date:Joined: Feb 2011
tanx for your tools
but i problem with recompile settings.apk

i install framework-res.apk then decompile settings.apk and when i recompile it show this below Error :

Code:
Log For : Settings.apk 

 Log Type : Recompiling 

 Log Recorded At : Tue 25-11-2014 12:42:05.19 

 Log Recorded By : Advanced ApkTool v4.0.0 By BDFreak 

------------------------------------------------------ 

warning: string 'AGPS_CAUSE_BAD_PUSH_CONTENT' has no default translation.
warning: string 'AGPS_CAUSE_NETWORK_CREATE_FAIL' has no default translation.
warning: string 'AGPS_CAUSE_NETWORK_DISCONN' has no default translation.
warning: string 'AGPS_CAUSE_NOT_SUPPORTED' has no default translation.
warning: string 'AGPS_CAUSE_NO_POSITION' has no default translation.
warning: string 'AGPS_CAUSE_NO_RESOURCE' has no default translation.
warning: string 'AGPS_CAUSE_REMOTE_ABORT' has no default translation.
warning: string 'AGPS_CAUSE_REMOTE_MSG_ERROR' has no default translation.
warning: string 'AGPS_CAUSE_REQ_NOT_ACCEPTED' has no default translation.
warning: string 'AGPS_CAUSE_TIMER_EXPIRY' has no default translation.
warning: string 'AGPS_CAUSE_TLS_AUTH_FAIL' has no default translation.
warning: string 'AGPS_CAUSE_USER_AGREE' has no default translation.
warning: string 'AGPS_CAUSE_USER_DENY' has no default translation.
warning: string 'AGPS_EM_POS_FIXED' has no default translation.
warning: string 'AGPS_EM_RECV_SI_REQ' has no default translation.
warning: string 'AgpsHelp_Category' has no default translation.
warning: string 'EM_NotifyDialog_title' has no default translation.
warning: string 'MobileNetwork_Category' has no default translation.
warning: string 'MobileNetwork_DataConn_off' has no default translation.
warning: string 'MobileNetwork_SIM_Active' has no default translation.
warning: string 'MobileNetwork_off_Summary' has no default translation.
warning: string 'MobileNetwork_on_Summary' has no default translation.
warning: string 'Network_Initiate' has no default translation.
warning: string 'Network_Initiate_Summary_off' has no default translation.
warning: string 'Network_Initiate_Summary_on' has no default translation.
warning: string 'Network_Local_and_Roaming_Summary' has no default translation.
warning: string 'Network_Only_Local_Summary' has no default translation.
warning: string 'Network_Roaming_dialog_content' has no default translation.
warning: string 'Network_Roaming_dialog_title' has no default translation.
warning: string 'Network_Used' has no default translation.
warning: string 'USER_RESPONSE_TIMEOUT' has no default translation.
warning: string 'WiFiNetwork_on_title' has no default translation.
warning: string 'about_agps_message' has no default translation.
warning: string 'about_agps_title' has no default translation.
warning: string 'agps_disable_on_reboot' has no default translation.
warning: string 'agps_disable_on_reboot_summary' has no default translation.
warning: string 'agps_enable_confirm' has no default translation.
warning: string 'agps_enable_confirm_allow' has no default translation.
warning: string 'agps_enable_confirm_deny' has no default translation.
warning: string 'agps_enable_confirm_title' has no default translation.
warning: string 'agps_profile_SLP_address_editbox_title' has no default translation.
warning: string 'agps_profile_select' has no default translation.
warning: string 'agps_settings_enable' has no default translation.
warning: string 'agps_settings_enable_off' has no default translation.
warning: string 'agps_settings_enable_on' has no default translation.
warning: string 'agps_settings_eng_enable' has no default translation.
warning: string 'agps_settings_eng_summary' has no default translation.
warning: string 'agps_settings_title' has no default translation.
warning: string 'agps_str_error' has no default translation.
warning: string 'all_settings_title' has no default translation.
warning: string 'audio_profile_bes_loudness_summary' has no default translation.
warning: string 'audio_profile_bes_loudness_title' has no default translation.
warning: string 'cell_broadcast_settings_summary' has no default translation.
warning: string 'close' has no default translation.
warning: string 'common_settings_title' has no default translation.
warning: string 'confirm_title' has no default translation.
warning: string 'dtmf_tone_enable_title_summery' has no default translation.
warning: string 'epo_about_message' has no default translation.
warning: string 'epo_about_title' has no default translation.
warning: string 'epo_auto_download_summary' has no default translation.
warning: string 'epo_auto_download_title' has no default translation.
warning: string 'epo_cancel_download' has no default translation.
warning: string 'epo_download' has no default translation.
warning: string 'epo_download_time_summary' has no default translation.
warning: string 'epo_download_time_title' has no default translation.
warning: string 'epo_enable_confirm_allow' has no default translation.
warning: string 'epo_enable_confirm_deny' has no default translation.
warning: string 'epo_enable_confirm_message' has no default translation.
warning: string 'epo_enable_confirm_title' has no default translation.
warning: string 'epo_enable_summary' has no default translation.
warning: string 'epo_enable_title' has no default translation.
warning: string 'epo_entrance_summary' has no default translation.
warning: string 'epo_entrance_title' has no default translation.
warning: string 'epo_err_update_failed' has no default translation.
warning: string 'epo_error_dialog_title' has no default translation.
warning: string 'epo_error_no_activite_network' has no default translation.
warning: string 'epo_expire_time_summary' has no default translation.
warning: string 'epo_expire_time_title' has no default translation.
warning: string 'epo_info_title' has no default translation.
warning: string 'epo_ok_btn' has no default translation.
warning: string 'epo_start_time_summary' has no default translation.
warning: string 'epo_start_time_title' has no default translation.
warning: string 'epo_status_starting' has no default translation.
warning: string 'epo_status_stopping' has no default translation.
warning: string 'epo_warning_dialog_message' has no default translation.
warning: string 'epo_warning_dialog_title' has no default translation.
warning: string 'eth_conf_perf_title' has no default translation.
warning: string 'experimental_webview' has no default translation.
warning: string 'experimental_webview_summary' has no default translation.
warning: string 'haptic_feedback_enable_title_summery' has no default translation.
warning: string 'hq_audio_profile_settings' has no default translation.
warning: string 'hq_customize_profile_settings' has no default translation.
warning: string 'lenovo_legal_info' has no default translation.
warning: string 'lock_sounds_enable_title_summery' has no default translation.
warning: string 'next_not_remind' has no default translation.
warning: string 'nfc_payment_ask' has no default translation.
warning: string 'open' has no default translation.
warning: string 'open_data_confirm_title' has no default translation.
warning: string 'open_data_conn_confirm_msg' has no default translation.
warning: string 'openairplane' has no default translation.
warning: string 'port_title' has no default translation.
warning: string 'print_services_title' has no default translation.
warning: string 'sound_effects_enable_title_summery' has no default translation.
warning: string 'summary_font_state_default' has no default translation.
warning: string 'title_font_style' has no default translation.
warning: string 'tls_summary_off' has no default translation.
warning: string 'tls_summary_on' has no default translation.
warning: string 'turn_wifi_to_wlan' has no default translation.
warning: string 'wifi_display_available_devices' has no default translation.
warning: string 'wifi_display_disconnect_text' has no default translation.
warning: string 'wifi_display_disconnect_title' has no default translation.
warning: string 'wifi_display_paired_devices' has no default translation.
warning: string 'wifi_display_search_for_devices' has no default translation.
warning: string 'wifi_display_searching_for_devices' has no default translation.
warning: string 'wifi_display_settings_empty_list_wifi_display_disabled' has no default translation.
warning: string 'wifi_display_settings_empty_list_wifi_display_off' has no default translation.
warning: string 'wifi_display_status_available' has no default translation.
warning: string 'wifi_display_summary_disabled' has no default translation.
warning: string 'wifi_display_summary_off' has no default translation.
warning: string 'wifi_display_summary_on' has no default translation.
warning: string 'wimax_settings_summary' has no default translation.
C:\apktool\3-Out\Settings.apk\res\layout\preference_header_switch_item.xml:11: error: Error: No resource found that matches the given name (at 'style' with value '@com.mediatek:style/ImageSwitch').

C:\apktool\3-Out\Settings.apk\res\layout\preference_nfc.xml:11: error: Error: No resource found that matches the given name (at 'style' with value '@com.mediatek:style/ImageSwitch').

C:\apktool\3-Out\Settings.apk\res\layout\preference_sim_info.xml:13: error: Error: No resource found that matches the given name (at 'style' with value '@com.mediatek:style/ImageSwitch').

C:\apktool\3-Out\Settings.apk\res\layout\preference_sim_info_enabler.xml:15: error: Error: No resource found that matches the given name (at 'style' with value '@com.mediatek:style/ImageSwitch').

C:\apktool\3-Out\Settings.apk\res\layout\sim_widget_view.xml:5: error: Error: No resource found that matches the given name (at 'style' with value '@com.mediatek:style/ImageSwitch').

C:\apktool\3-Out\Settings.apk\res\layout\wifi_switch_for_oobe.xml:7: error: Error: No resource found that matches the given name (at 'style' with value '@com.mediatek:style/ImageSwitch').

Exception in thread "main" brut.androlib.AndrolibException: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [C:\Users\Afshinpc\AppData\Local\Temp\brut_util_Jar_4330201186682399472.tmp, p, --forced-package-id, 127, --min-sdk-version, 19, --target-sdk-version, 19, --version-code, 19, --version-name, 4.4.2, -F, C:\Users\Afshinpc\AppData\Local\Temp\APKTOOL5283198301354780821.tmp, -0, arsc, -I, C:\apktool\1-BDFreak\Frameworks\1.apk, -S, C:\apktool\3-Out\Settings.apk\res, -M, C:\apktool\3-Out\Settings.apk\AndroidManifest.xml]
	at brut.androlib.Androlib.buildResourcesFull(Androlib.java:449)
	at brut.androlib.Androlib.buildResources(Androlib.java:383)
	at brut.androlib.Androlib.build(Androlib.java:286)
	at brut.androlib.Androlib.build(Androlib.java:258)
	at brut.apktool.Main.cmdBuild(Main.java:240)
	at brut.apktool.Main.main(Main.java:89)
Caused by: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [C:\Users\Afshinpc\AppData\Local\Temp\brut_util_Jar_4330201186682399472.tmp, p, --forced-package-id, 127, --min-sdk-version, 19, --target-sdk-version, 19, --version-code, 19, --version-name, 4.4.2, -F, C:\Users\Afshinpc\AppData\Local\Temp\APKTOOL5283198301354780821.tmp, -0, arsc, -I, C:\apktool\1-BDFreak\Frameworks\1.apk, -S, C:\apktool\3-Out\Settings.apk\res, -M, C:\apktool\3-Out\Settings.apk\AndroidManifest.xml]
	at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:487)
	at brut.androlib.Androlib.buildResourcesFull(Androlib.java:434)
	... 5 more
Caused by: brut.common.BrutException: could not exec command: [C:\Users\Afshinpc\AppData\Local\Temp\brut_util_Jar_4330201186682399472.tmp, p, --forced-package-id, 127, --min-sdk-version, 19, --target-sdk-version, 19, --version-code, 19, --version-name, 4.4.2, -F, C:\Users\Afshinpc\AppData\Local\Temp\APKTOOL5283198301354780821.tmp, -0, arsc, -I, C:\apktool\1-BDFreak\Frameworks\1.apk, -S, C:\apktool\3-Out\Settings.apk\res, -M, C:\apktool\3-Out\Settings.apk\AndroidManifest.xml]
	at brut.util.OS.exec(OS.java:89)
	at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:481)
	... 6 more

------------------------------------------------------
whats problem ?
Today, 04:01 PM   |  #229  
Senior Member
Flag Toulouse
Thanks Meter: 94
 
257 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by CoolJoseph96

Thank you, so I'll use
android sdk tools
Android sdk platform tools
Sdk platform (api 20)

I'm gonna to try it!!!

Edit:

I get the same error :/


Edit 2:

Fixed

How did you manage to fix your error?
I use the latest api (21), sdk tools and platform tools and I still have this error (while tring to install a Lollipop framework)

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes