Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[APP][2.3+] KinScreen - Automatic screen timeout

OP Flyview

20th October 2014, 10:58 PM   |  #31  
muiriddin's Avatar
Senior Member
Flag Mid-Atlantic
Thanks Meter: 103
 
324 posts
Join Date:Joined: Feb 2013
More
Okay here is what I just tried...

I toggled the kinscreen off and then on and then covered the proximity sensor (so the word proximity went and stayed red) and slowly counted to 20. The screen stayed fully lit.
Then I rebooted the phone and tried again with the same result. Then I toggled kinscreen off and on and tried it again. Proximity goes red, but the screen stays on is what I am seeing in all three scenarios. The app worked great on my Galaxy S3. However on my LGG3 (model VS985) the word proximity goes red but the screen does not go out. This is with the settings for timing as I stated above 30s, 5s and 10s.

Okay, I cleared defaults uninstalled the app. Then I downloaded a new copy from the playstore and set the settings as follows 60s, 10s, 10s check on ignore no check on charging or stay bright. Held the phone made sure not to touch the screen and covered the proximity sensor without touching the screen then counted to 20 slowly... still no luck toggled and tried again same result.
Last edited by muiriddin; 20th October 2014 at 11:07 PM. Reason: added last paragraph
20th October 2014, 11:00 PM   |  #32  
OP Senior Member
Flag Toronto/Waterloo
Thanks Meter: 551
 
1,207 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by muiriddin

Okay here is what I just tried...

I toggled the kinscreen off and then on and then covered the proximity sensor (so the word proximity went and stayed red) and slowly counted to 20. The screen stayed fully lit.
Then I rebooted the phone and tried again with the same result. Then I toggled kinscreen off and on and tried it again. Proximity goes red, but the screen stays on is what I am seeing in all three scenarios. The app worked great on my Galaxy S3. However on my LGG3 (model VS985) the word proximity goes red but the screen does not go out. This is with the settings for timing as I stated above 30s, 5s and 10s.

I assume you aren't charging with with the option to keep on while charging. That's pretty strange. Does the no-motion work?
20th October 2014, 11:12 PM   |  #33  
muiriddin's Avatar
Senior Member
Flag Mid-Atlantic
Thanks Meter: 103
 
324 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by Flyview

I assume you aren't charging with with the option to keep on while charging. That's pretty strange. Does the no-motion work?

Your assumption is correct the phone is not plugged in or on a wireless charger at the time of my testing. The motion part works well, too well is now my problem, if I forget to turn the screen off and put it in my pocket and am moving it keeps the screen on now since proximity does not seem to shut it off...

Okay to see if no motion timeout works I changed it to 20s and unchecked ignore motion while flat up laid it on my desk. It goes dim at a count of 15 seconds and turns off at 20 seconds. So that part seems to work well...
Last edited by muiriddin; 20th October 2014 at 11:18 PM. Reason: added the last paragraph
20th October 2014, 11:37 PM   |  #34  
OP Senior Member
Flag Toronto/Waterloo
Thanks Meter: 551
 
1,207 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by muiriddin

Your assumption is correct the phone is not plugged in or on a wireless charger at the time of my testing. The motion part works well, too well is now my problem, if I forget to turn the screen off and put it in my pocket and am moving it keeps the screen on now since proximity does not seem to shut it off...

I'll look into it and see what could be going on. Could you email teqtic@gmail.com? I will send you a debugging version and we can try and figure out what's going on.

P.S. no need to uncheck ignore if flat up.
21st October 2014, 09:49 PM   |  #35  
muiriddin's Avatar
Senior Member
Flag Mid-Atlantic
Thanks Meter: 103
 
324 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by Flyview

I'll look into it and see what could be going on. Could you email teqtic@gmail.com? I will send you a debugging version and we can try and figure out what's going on.

P.S. no need to uncheck ignore if flat up.

Email sent
28th October 2014, 04:55 PM   |  #36  
Member
Thanks Meter: 10
 
90 posts
Join Date:Joined: Aug 2012
Could you please add an option like in LeanDroid to disable the notification?
28th October 2014, 05:15 PM   |  #37  
OP Senior Member
Flag Toronto/Waterloo
Thanks Meter: 551
 
1,207 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by tmacher

Could you please add an option like in LeanDroid to disable the notification?

No can do, it's needed so that the system doesn't kill the service. If it did kill the service (which happens normally with non-foreground services), your screen would just shut off when you'd expect it to stay on by motion for example.

You can however, manually hide the notification by going to Settings -> Apps -> KinScreen and uncheck "show notifications". This is stated in the app description but it looks like most people don't read that far :P
28th October 2014, 05:42 PM   |  #38  
Member
Thanks Meter: 10
 
90 posts
Join Date:Joined: Aug 2012
Thx for answer, lately I'm a busy man and when the notification style change to that known from LeanDroid I thought this will be possible.
26th November 2014, 06:27 AM   |  #39  
OP Senior Member
Flag Toronto/Waterloo
Thanks Meter: 551
 
1,207 posts
Join Date:Joined: May 2010
More
I just published an update and it should be available on the market soon!

1.5.0
-Lolliop theme for Lollipop!
-Removed icon from status bar
-Improved purchase caching
-Calibrate dialog
-Made premium features more obvious

The Following User Says Thank You to Flyview For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes