Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[ROM][AOSP] - Android 5.0 - V4 RC0

OP BPaul

Yesterday, 07:36 PM   |  #181  
Kusay_1's Avatar
Member
Flag Moscow
Thanks Meter: 3
 
45 posts
Join Date:Joined: Feb 2014
More
OC is set by default 1.9 GHz, i lowered it to 1.62, will see how that goes
Yesterday, 09:54 PM   |  #182  
Junior Member
Thanks Meter: 5
 
16 posts
Join Date:Joined: Feb 2010
More
3G do not work
@BPaul wonderfull ROM... you right 3G still not working!
Today, 01:36 AM   |  #183  
Mahmoud Halem's Avatar
Senior Member
Flag Egypt
Thanks Meter: 22
 
240 posts
Join Date:Joined: Nov 2013
More
3G
plz in ur free time .. let the 3G fix is the first goal on the next update .. i'm really need to install this rom again but i need mobile Data ... anyway thx for ur hard work <3
Today, 01:48 AM   |  #184  
perkabalo's Avatar
Member
Thanks Meter: 29
 
69 posts
Join Date:Joined: Apr 2006
Info 2 3G Data Workaround | Temporary fix
Quote:
Originally Posted by andrehch

@BPaul wonderfull ROM... you right 3G still not working!

@BPaul
@jolinnard
@percy_g2
@sykopompos
@benpye

So I've checked the logcat regarding our 3G data connectivity issue and did some research regarding the java exception code:

Code:
11-27 23:46:10.041 E/ConnectivityService(620): Exception in addRoute for gateway: java.lang.IllegalStateException: command '110 network route add 103 rmnet0 0.0.0.0/0 10.140.13.114' failed with '400 110 addRoute() failed (No such process)'
and found this thread: http://forum.xda-developers.com/nexu...-beta-t2807446
Had the same 3G connectivity issue earlier but it seems they've fixed it.

First the xda user jolinnard came up with a workaround .sh script.:
http://forum.xda-developers.com/show...ostcount=17207

His fix later got integrated to the ramdisk by percy_g2
https://github.com/Android-L-Porting...aa78b7652c0e97

And then later on seems to fully been fixed by benpye
https://github.com/Android-L-Porting...89945494b53225

BPaul, maybe we can get help from percy_g2/sykopompos/benpye - the users mentioned above to fully fix this.

As for the workaround I've just changed jolinnard script a bit to reflect our hikari.. rmnet0 instead of rmnet_usb0.

https://drive.google.com/file/d/0B3H...ew?usp=sharing

1. Download the data_on.sh from the google drive link above and place anywhere on your sdcard.
2. Install any terminal of your choice. e.g. https://play.google.com/store/apps/d...nnectbot&hl=en
3. Open the terminal app previously downloaded.
4. Run the following commands:

Code:
su
- Wait for superuser prompt and allow
Code:
cd /sdcard
cd to where you've placed data_on.sh
Code:
sh data_on.sh
3G Data connectivty should now work until reboot, to get it working again after a reboot just repeat step 4.

Time to pass out in the bed...
The Following 3 Users Say Thank You to perkabalo For This Useful Post: [ View ]
Today, 01:57 AM   |  #185  
sykopompos's Avatar
Senior Member
Flag flithydelphia
Thanks Meter: 19,571
 
11,666 posts
Join Date:Joined: Jun 2008
Donate to Me
More
Quote:
Originally Posted by perkabalo

@BPaul
@jolinnard
@percy_g2
@sykopompos
@benpye

So I've checked the logcat regarding our 3G data connectivity issue and did some research regarding the java exception code:

Code:
11-27 23:46:10.041 E/ConnectivityService(620): Exception in addRoute for gateway: java.lang.IllegalStateException: command '110 network route add 103 rmnet0 0.0.0.0/0 10.140.13.114' failed with '400 110 addRoute() failed (No such process)'
and found this thread: http://forum.xda-developers.com/nexu...-beta-t2807446
Had the same 3G connectivity issue earlier but it seems they've fixed it.

First the xda user jolinnard came up with a workaround .sh script.:
http://forum.xda-developers.com/show...ostcount=17207

His fix later got integrated to the ramdisk by percy_g2
https://github.com/Android-L-Porting...aa78b7652c0e97

And then later on seems to fully been fixed by benpye
https://github.com/Android-L-Porting...89945494b53225

BPaul, maybe we can get help from percy_g2/sykopompos/benpye - the users mentioned above to fully fix this.

As for the workaround I've just changed jolinnard script a bit to reflect our hikari.. rmnet0 instead of rmnet_usb0.

https://drive.google.com/file/d/0B3H...ew?usp=sharing

1. Download the data_on.sh from the google drive link above and place anywhere on your sdcard.
2. Install any terminal of your choice. e.g. https://play.google.com/store/apps/d...nnectbot&hl=en
3. Open the terminal app previously downloaded.
4. Run the following commands:

Code:
su
- Wait for superuser prompt and allow
Code:
cd /sdcard
cd to where you've placed data_on.sh
Code:
sh data_on.sh
3G Data connectivty should now work until reboot, to get it working again after a reboot just repeat step 4.

Time to pass out in the bed...

It was kernel issues, we had to wait for the updated kernel sources from google for it to work properly

https://github.com/Android-L-Porting...e61568e147a9fa
https://github.com/Android-L-Porting...b0da1791cd1e3b

there was other kernel commits though for packet based routing
The Following 2 Users Say Thank You to sykopompos For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes