Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

XT890 Stuck on Red Logo. Probably damaged partitions.

OP Chamelleon

17th June 2014, 02:30 PM   |  #21  
Chamelleon's Avatar
OP Senior Member
Flag Kraków
Thanks Meter: 135
 
302 posts
Join Date:Joined: May 2010
Donate to Me
More
So it looks this model has problem with emmc like it was with Galaxy S and Galaxy S+. Only difference is that i9000/i9001 has script to reformat emmc and we don't have anything like this and even if we have it couldn't be used by locked bootloader.
The Following User Says Thank You to Chamelleon For This Useful Post: [ View ]
17th June 2014, 04:57 PM   |  #22  
Hazou's Avatar
Senior Member
Thanks Meter: 1,018
 
743 posts
Join Date:Joined: Feb 2012
Donate to Me
More
Yep, seems like it. But with the galaxy line it can be avoided by upgrading the kernel. So maybe the stock kernel has somewhere a fault in it. Haven't researched this enough to know what it could be, but ITF has something to do with secure erase. Maybe with android 4.4 those issues will not rise again. And as far as I know it only happens on JB. Or I missed something.

I searched the internet (obviously) and came across this. http://forum.xda-developers.com/show....php?t=2581166 A bootable CWM recovery from external sdcard. Can it work u think? With the command switching devices in fastboot. I thought i read somewhere that the command in fastboot switching devices switches the boot points from internal to external. Maybe we can try something like that?

Verstuurd van mijn GT-P5110
Last edited by Hazou; 18th June 2014 at 11:29 AM.
The Following User Says Thank You to Hazou For This Useful Post: [ View ]
22nd June 2014, 05:53 PM   |  #23  
SalJR's Avatar
Junior Member
Flag Piracicaba
Thanks Meter: 3
 
25 posts
Join Date:Joined: Oct 2010
More
Gentlemen,

My girlfriend's phone had exactly the same problem, the same error and the same messages on screen.
I spent hours on blogs and, when I was almost giving up, I found out a solution.

To tell you the truth, guys, I used the same procedure on my dead moto quench (cliq xt) five years ago... it seems stupid, but I've almost killed myself trying to do something to recover the fastboot which i thought was the reason... I was wrong...

So, here's what I did to solve it:

1 - First, have the motorola drivers and rsd lite 6.1.4 (or a higher version) installed;

2 - Download the version you need - sbf.droid-developers.org/phone.php?device=13 - sorry I cannot include the address here 'cause I didnt reach 10 messages on xda = P

3 - Unzip the file and edit the .xml file with notepad. It is the only .xml file on the folder;

4 - Remove the whole line which contain "getvar" word. (It must be the fourth or fifth line);

5 - Save and close the file;

6 - Now you can flash normally with rsd. IT WILL NOT STOP ON 8/12 STEP ANYMORE;


Please try it and post your comments;

Regards,
Last edited by SalJR; 22nd June 2014 at 05:57 PM.
The Following User Says Thank You to SalJR For This Useful Post: [ View ]
22nd June 2014, 06:06 PM   |  #24  
Chamelleon's Avatar
OP Senior Member
Flag Kraków
Thanks Meter: 135
 
302 posts
Join Date:Joined: May 2010
Donate to Me
More
Already tried but there is no getvar in xml at all.
The Following User Says Thank You to Chamelleon For This Useful Post: [ View ]
23rd June 2014, 01:53 PM   |  #25  
SalJR's Avatar
Junior Member
Flag Piracicaba
Thanks Meter: 3
 
25 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by Chamelleon

Already tried but there is no getvar in xml at all.

I think you should try a different version. On the same blog I found this solution, some people say that they tried since from 4.04 version (the first retail) to the last 4.1.2). Some of them managed to fix on the third rom.

PS: don't forget to delete the "getvar" line.
7th December 2014, 01:24 AM   |  #26  
Junior Member
Thanks Meter: 1
 
3 posts
Join Date:Joined: Mar 2012
Quote:
Originally Posted by SalJR

Gentlemen,

My girlfriend's phone had exactly the same problem, the same error and the same messages on screen.
I spent hours on blogs and, when I was almost giving up, I found out a solution.

To tell you the truth, guys, I used the same procedure on my dead moto quench (cliq xt) five years ago... it seems stupid, but I've almost killed myself trying to do something to recover the fastboot which i thought was the reason... I was wrong...

So, here's what I did to solve it:

1 - First, have the motorola drivers and rsd lite 6.1.4 (or a higher version) installed;

2 - Download the version you need - sbf.droid-developers.org/phone.php?device=13 - sorry I cannot include the address here 'cause I didnt reach 10 messages on xda = P

3 - Unzip the file and edit the .xml file with notepad. It is the only .xml file on the folder;

4 - Remove the whole line which contain "getvar" word. (It must be the fourth or fifth line);

5 - Save and close the file;

6 - Now you can flash normally with rsd. IT WILL NOT STOP ON 8/12 STEP ANYMORE;


Please try it and post your comments;

Regards,

It's works! Thanks a lot!
The Following User Says Thank You to Piperro78 For This Useful Post: [ View ]
8th December 2014, 04:07 PM   |  #27  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2014
Exclamation prueba unbrick comand
Quote:
Originally Posted by Chamelleon

Hi, yesterday I received XT890 from another user. Phone stuck on red Motorola logo, can enter fastboot and has locked bootloader.
Fastboot actions:

1. Normal Powerup - Freeze on Fastboot
2. Recovery - Freeze on Red Logo
3. Factory - Freeze on Red Logo
4. BP Tools - Freeze on Fastboot
5. Switch Console - Working
6. Power Off - Freeze on Fastboot

So first of all I tried to flash it by RSD with CFC_9.8.2I-50_SMI-26_S7_USASMIJBRTEU but on 4/12 it can't reboot phone so I did it manually and it goes to 8/12 and phone shows E:failed to erase partition system.
I also tried to skip system by deleting it from xml but on every other step it can't do anything with partitions (data, cache, cdrom).

I tried fastboot to erase partitions manually but no luck with locked bootloader. So I tried to unlock it but it can't be done cause data can't be erased.
I even tried unbrick script for modified and it passed but no changes.

So what I tried:

1. Format Data/Cache - Can't enter Recovery
2. Flash RSD - Can't flash system partition
3. Unlock Bootloader - Can't format data partition
4. Unbrick - No changes after that
5. Fastboot flash CWM - only stock recovery can be flashed on locked bootloader
6. Fastboot erase data / system/ cache partitions - error

After that I'm assuming that emmc is damaged. If it's software damage it should be way to resurrect it.
Any help is welcome.
Sorry for my nasty English.



hice una pruebas y me tira esto ver foto con el comando --osimage motoboot -- verbose
Attached Thumbnails
Click image for larger version

Name:	prueba unbrick comand.jpg
Views:	34
Size:	203.8 KB
ID:	3053975   Click image for larger version

Name:	prueba unbrick comand 2.jpg
Views:	28
Size:	183.3 KB
ID:	3053976  
Last edited by smartcell1984; 8th December 2014 at 04:09 PM. Reason: pics

Post Reply Subscribe to Thread

Tags
brick, emmc, razr i, red logo, xt890
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes