Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] How to disable Auto-Orientation-ON on magnetic charging cable

OP Wurstwarenfachverkäuferin

18th May 2014, 08:07 PM   |  #1  
OP Member
Thanks Meter: 8
 
69 posts
Join Date:Joined: Dec 2011
Sorry if that has already been answered but I didn't find an answer.

When I connect a magnetic charging cable to my z1c, the phone ignores the orientation setting and always auto-rotates the screen. Is there a way to disable that and have the phone strictly stick to the settings (in my case, fixed portrait mode most of the time)?

Thanks for your time. Best regards.
18th May 2014, 10:23 PM   |  #2  
einfachgaer's Avatar
Senior Member
Thanks Meter: 41
 
125 posts
Join Date:Joined: Apr 2013
More
If you are rooted, use the xposed module Disable Desk Dock.
The Following 3 Users Say Thank You to einfachgaer For This Useful Post: [ View ]
21st May 2014, 11:56 PM   |  #3  
Member
Thanks Meter: 5
 
54 posts
Join Date:Joined: Mar 2007
Check ur smart connect settings maybe it is changing orientation when it detects ur magnetic charger.

Sent from my D5503 using Tapatalk
23rd May 2014, 09:33 PM   |  #4  
OP Member
Thanks Meter: 8
 
69 posts
Join Date:Joined: Dec 2011
Thx for the suggestions. I might try to install Xposed in the nearer future, I guess. In Smart Connect, there no active events.

Can anybody confirm my device acts the same as all do (or not)?
On connecting the magnetic charger, the screen will auto-rotate depending on the orientation of the phone, even with orientation fixed in settings.
7th December 2014, 04:57 PM   |  #5  
Junior Member
Thanks Meter: 3
 
17 posts
Join Date:Joined: Jan 2011
Thumbs up Thank you for the solution.
Quote:
Originally Posted by Wurstwarenfachverkäuferin

Can anybody confirm my device acts the same as all do (or not)?
On connecting the magnetic charger, the screen will auto-rotate depending on the orientation of the phone, even with orientation fixed in settings.

I had the same problem - at first I thought there was something broken in Carbon Rom for the Xperia Z1 Compact which caused this crazy auto-rotation behaviour. Whenever I had connected the magnetic charging cable all my rotation-settings were overwritten and full 360° rotation was happening on every screen - even on the lockscreen. Very annoying.

Quote:
Originally Posted by einfachgaer

If you are rooted, use the xposed module Disable Desk Dock.

This fixed it. Thank you very much.

I guess this was originally thought as a feature not a bug. It makes sense if you use the phone in the magnetic dock and its position is thus fixed. But it's definitely a bug when using a magnetic charging cable and trying to unlock a freely rotating lockscreen.
Last edited by loewenherz; 7th December 2014 at 05:00 PM.
13th December 2014, 11:07 AM   |  #6  
eresac's Avatar
Senior Member
Thanks Meter: 14
 
133 posts
Join Date:Joined: Jan 2009
I confirm Disable Desk dock module works well on this, but...
May I ask you (the ones who have this module on Z1C) if you found any side effect?
For me is: if I have magnetic charged, when I switch off I get in a "boot" loop (sony on display coming and going).
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes