Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Straight Talk apn settings for att g flex help

OP geekyhelm

30th March 2014, 05:21 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Mar 2014
Ok i have a g flexand have been trying for days now to get mms going on this device. I have tried alot of diffrent combs of settings with no luck. Im not a total noob i was succesful at jailbreak and getting mms working on iphone and getting my wifes note 3 set up for straight talk. Any help would sure be appricated. No root on it it just how it was when it came out of the box
17th April 2014, 12:53 AM   |  #2  
oscar786's Avatar
Senior Member
Flag Great Lakes
Thanks Meter: 12
 
112 posts
Join Date:Joined: Feb 2008
More
I am in the same boat, apn type is grayed out where I put apn setting..If you figure this out, please help me too. Thanks
17th April 2014, 06:48 PM   |  #3  
Junior Member
Thanks Meter: 0
 
20 posts
Join Date:Joined: Dec 2007
Had the same issue. This worked for me. Need to be rooted!

http://forum.xda-developers.com/show...php?p=51323582

Sent from my LG-D950 using xda app-developers app
21st April 2014, 05:16 AM   |  #4  
asj2583's Avatar
Senior Member
Flag San Antonio, Texas
Thanks Meter: 56
 
628 posts
Join Date:Joined: Jul 2010
Donate to Me
More
I'm using these on my T-Mobile G Flex and both Internet and MMS work on AT&T Straight Talk. Name of APN can be anything you want.

APN: tfdata
MMSC: http://mms-tf.net
MMS PROXY: mms3.tracfone.com
MMS PORT: 80
Last edited by asj2583; 21st April 2014 at 05:19 AM.
21st April 2014, 05:27 PM   |  #5  
sk337sk337's Avatar
Senior Member
Flag Tennessee
Thanks Meter: 211
 
2,492 posts
Join Date:Joined: May 2009
More
Quote:
Originally Posted by asj2583

I'm using these on my T-Mobile G Flex and both Internet and MMS work on AT&T Straight Talk. Name of APN can be anything you want.

APN: tfdata
MMSC: http://mms-tf.net
MMS PROXY: mms3.tracfone.com
MMS PORT: 80

That's the thing though. Yours is T-Mobile and not AT&T.
21st April 2014, 05:36 PM   |  #6  
asj2583's Avatar
Senior Member
Flag San Antonio, Texas
Thanks Meter: 56
 
628 posts
Join Date:Joined: Jul 2010
Donate to Me
More
Quote:
Originally Posted by sk337sk337

That's the thing though. Yours is T-Mobile and not AT&T.

Have you tried https://play.google.com/store/apps/d...d=com.tweakker or https://play.google.com/store/apps/d...NBackupRestore
21st April 2014, 05:51 PM   |  #7  
sk337sk337's Avatar
Senior Member
Flag Tennessee
Thanks Meter: 211
 
2,492 posts
Join Date:Joined: May 2009
More
The issue lies in that AT&T has locked the ability to edit the APN Type field. Where you can normal type in: internet,mms,supl,hipri to get your MMS to work they have disabled the option. Those apps will not work. You need to follow the above mentioned comment and edit the system files with the correct settings.
21st April 2014, 05:54 PM   |  #8  
asj2583's Avatar
Senior Member
Flag San Antonio, Texas
Thanks Meter: 56
 
628 posts
Join Date:Joined: Jul 2010
Donate to Me
More
Quote:
Originally Posted by sk337sk337

The issue lies in that AT&T has locked the ability to edit the APN Type field. Where you can normal type in: internet,mms,supl,hipri to get your MMS to work they have disabled the option. Those apps will not work. You need to follow the above mentioned comment and edit the system files with the correct settings.

Ah i see what you mean.
14th December 2014, 04:13 PM   |  #9  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2014
Solution for APN setting in G Flex
The solution with small application to be downloaded from Google Play Store called APN onoff with no need for rooting
Enjoy
15th December 2014, 07:21 PM   |  #10  
Murshad007's Avatar
Senior Member
Flag Lahore
Thanks Meter: 28
 
308 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by sk337sk337

The issue lies in that AT&T has locked the ability to edit the APN Type field. Where you can normal type in: internet,mms,supl,hipri to get your MMS to work they have disabled the option. Those apps will not work. You need to follow the above mentioned comment and edit the system files with the correct settings.

Check that if 5457#*model# working?
This hidden menu have a "APN Edit" check box.
Check it and after reboot. You can edit settings

Sent from my LG-F340K using XDA Free mobile app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes