Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[HOW TO] Unlock bootloader, Root, Flash Custom ROM, Flash Kernel

OP hasoon2000

24th September 2014, 12:04 PM   |  #351  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Sep 2014
More
how to put nand backup in phone when there is no ROM installed.
Quote:
Originally Posted by hasoon2000

Post 3: How to reverse everything and go back to stock

Now, let's talk about getting back to stock. There are 2 ways to do this.

1. Flash the stock RUU (If available) (Recommended)
2. Restore your Nandroid (backup that I told you to make earlier)

1. I'll talk about flashing the stock RUU first.

Open up my toolkit and press "Factory RUU" from the links sections. I usually have the most updated RUUs that Football releases on my Dev-Host account. Download the correct RUU for your phone.

Now, back up all your data (pictures, contacts, etc) since this will put your phone back to complete stock.

Connect the USB cable to your phone. Press Boot into Bootloader.

It should now say FASTBOOT USB on your screen.

Press Relock bootloader. It may give you a security warning error or it may say failed. Who cares, ignore it. It's normal.

Your phone will boot up normally.

When the phone is fully loaded. Unplug and replug the USB cable back in the phone. Now,run the RUU you downloaded and follow the instructions.

Your phone will be back to stock.

2. Now, we will talk about restoring your nandroid backup.

Connect your phone to the computer. Open up the folder to view the files on your phone.

From your computer, Go to TWRP -> BACKUPS -> (Your hardware Serial Number) -> (Folder you wish to restore to) -> and copy boot.emmc.win to your computer. Rename boot..emmc.win to boot.img

Open my toolkit and press boot into recovery.

Click Wipe. Wipe Cache, Dalvik, Factory Reset and System. NOTHING ELSE! If you click anything else, IT WILL WIPE YOUR SD CARD AND YOU WILL HAVE MORE ISSUES ON YOUR HEAD!

Press back and press Restore. Choose the backup to restore to.

After it finishes, press the back button. Press Reboot and select bootloader.

Open my toolkit and press Flash a Kernel. Locate the boot.img and it will flash it.

You are now back to your stock Nandroid.

I have NAND Backup of Stock ROM but after installing the TWRP in my HOX+ I wiped all the things from Advance Format option.
So I could not put my NAND Backup in my Internal Storage. I tried miniadb_inc tool but it shows "no device found" everytime while fastboot tool can recognize my device. All in One HOX+ kit sometimes recognizes and sometimes not. So please tell me how to restore this NAND Backup in my mobile.
27th September 2014, 12:35 PM   |  #352  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Mar 2014
Correct recovery
Quote:
Originally Posted by shashphysio

MY HTC ONE XPLUS I FLASHED....

but its in at & t... can someone help me to get rid of it.

i live in india and i cannot use this. so please someone tell me how can i install a custom rom and remove this at & t

I assume you have flashed AT&T ROM in your international phone.

You need to first install correct recovery. From the tool kit, first choose TWRP International.

Once you install the correct recovery, rest are as per the outlined procedure. Since you have flashed incorrect ROM, you would be required to do wipe.
16th November 2014, 05:14 AM   |  #353  
Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Aug 2014
Hi im about to install snapshot last rom (m12) is this tutorial the right to do it?? cause i heard twrp is not the good one for this rom, and the toolkit (v 3.0) is outdated
Last edited by RealALCoL; 16th November 2014 at 06:26 AM.
16th November 2014, 01:18 PM   |  #354  
Member
Thanks Meter: 11
 
77 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by RealALCoL

Hi im about to install snapshot last rom (m12) is this tutorial the right to do it?? cause i heard twrp is not the good one for this rom, and the toolkit (v 3.0) is outdated

The AIO toolkit is great, all you need to do is replace a newer version of adb.exe and fastboot.exe. It works perfectly for me.
17th November 2014, 03:01 AM   |  #355  
Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Aug 2014
Ok, thanks, and wich part i make a backup to stock rom and my stuff?
7th December 2014, 04:20 AM   |  #356  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2008
htc desire x has no system
Hallo - first of all I have to sorry, but Iam desprate now - I use a TWRP tool to reverse my Phone from Jelly to ICS and somehow reached a state when its boot, but not load a system (it only shows first screen and rebot repetetively to it). Is it way to fix it to stock Jelly or ICS with yousr toolkit (I have RUU, but it does not work, and I dont know how exactly do the RUU zip)
Thank you very much for answer
7th December 2014, 11:28 PM   |  #357  
Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by markkenzy

The AIO toolkit is great, all you need to do is replace a newer version of adb.exe and fastboot.exe. It works perfectly for me.

How can i do this? cuz when i use this aio tool it tells me adb.exe is out of date, killing
17th December 2014, 08:38 PM   |  #358  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2014
confusing instructions at the end
Quote:
Originally Posted by hasoon2000

Ability to read and follow step-by-step

I did. But by doing so my HTS One M8 turned off when I pushed the SuperSu.zip file and went to a black screen with only an attantion sign and reacted to nothing anymore.
I thought I killed it. Luckily after about 5 minutes it reacted again to the power button and started normaly.
I found another guide with video wich I followed then and found out what the correct procedure with your tool is.
I want to spare this creepy moment for other One M8 users so here is the link: http : // www . idigitaltimes . com / htc-one-m8-android-44-kitkat-how-root-international-att-t-mobile-and-sprint-variants-and-install

Quote:
Originally Posted by hasoon2000

Click 3. Get Token ID. Look at the pop up and it will tell you how to get the Token ID.
Highlight where it says < < < < Identifier Token Start > > > > all the way to < < < < < Identifier Token End > > > > > and right click and it will automatically copy it.
Now, click Submit Token ID. Your web browser should now open a new tab. Scroll down and in the empty box, paste your Token ID. Press submit. HTCDev now emailed you your unlock token.

There was no pop up. The next CMD window which gives you the phone ID opens only when you close the first one. You didn't write that I need to close the first window so I assumed theres nothing happening anymore. I simply followed the instructions from the htcDev-site which told me the command and what to do.
After that I closed the command window and noticed that your tool is now doing what I just did.
When you say that one should follow step by step you should also write when one needs to close the CMD window. I don't simply assume that by closing one window the next step starts automatically.

So far so good, nothing serious happend, I got to this point without any big troubles. But the next step was quite a struggle. And when I had nothing on my screen except a red attention sign I really though I can send in my phone.
Quote:
Originally Posted by hasoon2000

When your phone loads up, go through the set up wizard. Then, on your phone, go to Settings -> Developer Options and Enable USB Debugging.
Under the Extras section, press Perm Root. It will push SuperSU.zip to your phone.
Under commands, press Boot into Bootloader once again.
Now, it is time to flash a recovery.

My phone started up, I went through the wizard, all fine.
Next step: Perm Root. OK. But a pop up appears and sais "YOU MUST HAVE CUSTOM FLASH FIRST"
It's contrary to what you write in your guide. Here the flash of the recovery comes after the perm root. So I follow your instructions and my phone went to the above said state.
After about 5 minutes I could start it again. Then I clicked again Perm Root>Run, i read the pop up carefully and decided to abort so I clicked the X instead of OK. But by clicking X the command is not aborted, it has the same effect as clicking OK.
My suggestion: implement a function to abort a command when X is clicked instead of OK.

So then I followed the video instruction where I found I need to choose the TWRP 2.7.0.2 and then click "Flash Recovery".
For someone who doesn't crack a phone regularly like me this is not very clear and intuitive.
I don't know what a recovery is in this purpose and in which step it is needed.
Next after flashing the recovery I clicked Perm Root>Run. It worked and automatically booted my phone to bootloader.
There is no necessity to click the command "Boot into Bootloader" as you wrote.
Maybe in a old version of your tool it was necessary, but now you did everything sequential and selftriggering. But this was just a little confusing and no big deal.

Then you write something about different TWRP (ATT/Telus and International). Is this still up to date?
In the tool version that I downloaded today were 5 different recoveries: TWRP 2.7.0.2 normal and sprint, ClockWorkMod normal and spring, and "Your own recovery"

After it flashes, remove the USB cable and have HBOOT selected in bootloader. Press the power button and it will reload to another screen. Press the Volume Down button until you get to Recovery. Press the power button to select it.

Quote:
Originally Posted by hasoon2000

Go to Backup and back up your boot and system partition. Always have a back up before you flash or do anything.

True! It's always better to have a backup.
But at this step I couldn't choose to do a backup. First in the TWRP recovery I could choose to do a backup.
I'm not sure if you're talking about this or if something changed in the meantime.

Please, don't get me wrong. I'm realy grateful for your work, your tool and your instructions.
I'm always glad to find something like this where someone made the effort for a simple solution for everyone and even writes a guide.
I just want to give a feedback about what could lead, and in my case it did lead, to problems during the process.
Maybe if you have time and the motivation you want to change the instruction. Or if someone contacts you with the same problems you just refer to this post of me or the video guide.

Thanks again for your time and your effort.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes