Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Teclast X98 3G - 9.7" Retina 22nm Intel x64 Bay Trail Android tablet

OP avich

20th November 2014, 10:44 AM   |  #411  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2009
Hi, I've been silent reader of this thread for about a week, and planning to buy this cute monster.

Just curious, anybody ever try to run Windroy (http slash-slash windroye dot com) on it?
It may provide dual OS temporarily.
22nd November 2014, 08:56 AM   |  #412  
Member
Flag Prague
Thanks Meter: 7
 
80 posts
Join Date:Joined: Aug 2009
Donate to Me
More
Question
Hey guys, is there anyone who will help me? I've bought this, installed Windows, now they crashed, so i had to reinstall them, now nothing works (otg does) I've downloaded some drivers, but they are in .cat format, which i dont know how to install, because i'm mostly mac user.
Can anyone help me? Reinstall it? Is fine to make a bootable usb disk with windows and install it? Is there any modified Windows installator with teclast x98 drivers in it? Thank you!
Last edited by vasa13; 22nd November 2014 at 09:14 AM.
1st December 2014, 11:23 PM   |  #413  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jan 2011
Install gapps
Hi guys,

i have flashed the newest 4.2.2 on my X98 (HKC3), and it worked fine - until the first reboot. After that, the Play Store went missing from my tablet...

Do you know any way to flash gapps, or simply install Google Play?

Thanks!

Edit:found it, for everyone with a problem like me, just google for "google play apk", and download the latest APK from apkmirror.
Last edited by Ezzored; 1st December 2014 at 11:27 PM.
3rd December 2014, 11:37 PM   |  #414  
Junior Member
Thanks Meter: 1
 
15 posts
Join Date:Joined: Sep 2014
I have a teclast model c8j7 what do you need? The bios backup or something? I want help you if i can, sorry by english.
7th December 2014, 01:42 PM   |  #415  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2014
Tablet
Hi guys, I just bought the X98 with windows preinstalled.

It works fine but there's a bug with the network connections. Sometimes, when I click in the right sidebar the network connection, the network connection menu does not open.
I need to restart the tablet to change the connection between Wifi and 3G or simply to change the wifi network.
Do you also have this bug?

I think there's a problem with the 3G module driver...
10th December 2014, 03:36 PM   |  #416  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2014
Quote:
Originally Posted by crazedone

Alright, you said that droidboot still works? Then you might be able to get away with doing it manually.

Remember the log file posted before, type those commands EXACTLY. I forgot to do droidboot.bin but flashed everything else which is why I was recovered.
Download KitKat firmware and extract them
Ensure the tablet is turned on then turn it off
Enter droidboot (press Vol+ and Power, then release power and keep pressing Vol+) when turning on again.
Ensure the device is detected in fastboot on your PC (As BayTrail<serialnum>)

Run the following commands exactly, replacing the path with the path to the folder where the kitkat files are located:

Code:
fastboot oem write_osip_header
fastboot oem start_partitioning
fastboot flash /tmp/partition.tbl "[Drive]:\path\to\kitkat\firmware\partition.tbl"
fastboot oem partition /tmp/partition.tbl
fastboot erase data
fastboot erase system
fastboot erase cache
fastboot erase config
fastboot erase logs
fastboot erase factory
fastboot oem stop_partitioning
fastboot flash fastboot "[Drive]:\path\to\kitkat\firmware\droidboot.img"
fastboot flash recovery "[Drive]:\path\to\kitkat\firmware\recovery.img"
fastboot flash system "[Drive]:\path\to\kitkat\firmware\system.img"
fastboot flash splashscreen "[Drive]:\path\to\kitkat\firmware\bootlogo.bin"
fastboot flash boot "[Drive]:\path\to\kitkat\firmware\boot.img"
fastboot continue
Hopefully you can boot in. Following, flash the IAFW as described before for audio fixes.

you saved me too.after the i brick the recovery with that all came like new and better .thank you very much
11th December 2014, 01:02 AM   |  #417  
renton82's Avatar
Senior Member
Thanks Meter: 8
 
184 posts
Join Date:Joined: Jan 2011
Help!!!
While i was trying to change some bios setting the tablet (Teclast X98 Air II with windows 8.1) is died! I think it's some c state setting i choose! Now the talbet won't turn on! Is there a way to reset bios??? I've just tried to desold the battery, but it doesn't works! Is there any combination to reset the bios???
17th December 2014, 10:40 PM   |  #418  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Mar 2012
Please help!!!
Hello my dear geniuses of XDA, First off im a newb when it comes to tablets, phones and such, I do know quite a fair but about PC's hardware and software, but its hardly the same ^^ So heres my problem: I got an Teclast X98 Air 3G tablet for my mum for the holidays, bought it off aliexpress, good price, awesome hardware. But, google play store isn't working, tried all fixes, none helped or wasn't even able to apply them, cannot update software via the built-in manufacturer updater, says: "Unknown error.", Skype doesn't work, says "Cannot connect to your network at the moment, try again later." Even though browser works, and wi-fi is connected, so I used SRSroot, rooted my device and tried to install 2 different ROMS, using Manufacturing Flash Tool, each ROM I tried to install ends up the same: at 10% it fails, in the tablet last seen messages are:
RECIEVE DATA...
FLASH osloader...
E: unknown volume /osloader to flash!
FLASH FAILED!
RECIEVE DATA...
boot command stubbed on this platform!
could not open /sys/devices/virtual/backlight

And the Flash tool gives me this:
12/17/14 23:22:01.126 INFO : Manufacturing Flash Tool V 6.0.43 (build on Sun May 18 12:29:29 PDT 2014)
12/17/14 23:22:01.131 INFO : Loading settings from C:/ProgramData/INTEL/Manufacturing Flash Tool.ini
12/17/14 23:22:01.150 INFO : Using Qt version: 4.8.1
12/17/14 23:22:01.150 INFO : Using XFSTK version: 1.5.5.
12/17/14 23:22:01.156 WARNING: Please select a flash file...
12/17/14 23:22:28.821 INFO : Loading Flash file (C:/Users/Poffke/Desktop/TAblet ****/X98 Air3G C6J6 (JCEspi2005)/flash.xml)
12/17/14 23:22:28.821 INFO : GP_Flag is set to 0x80000045
12/17/14 23:22:28.821 INFO : Ready to flash!
12/17/14 23:23:42.727 INFO : do_new_medfield_device STARTING TO FLASH
12/17/14 23:23:42.737 INFO : Port 0/1/1 #0: DNX/droidboot phase - SN : Baytrail00003E19
12/17/14 23:24:24.732 INFO : Port 0/1/1 #0: Booting to droidboot.img success - SN : Baytrail00003E19
12/17/14 23:26:46.556 ERROR : Port 0/1/1 #0: Device on port 0/1/1 #0 timeout to enum adb (TIMEOUT = 180)

Please help me guys, I know there's some insanely cool guys here who know a lot of **** about tablets and such, help a bro out would ya!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes