Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[RUU][Firmware]Sprint HTC One | 5.05.651.2 | Encrypted | Decrypted |

OP O.M.J

17th December 2014, 10:11 PM   |  #271  
Member
Thanks Meter: 3
 
78 posts
Join Date:Joined: Jun 2010
Hi everyone, I'm trying to update my firmware so I can install the newer version of Viper software on my ONE. I'm trying to follow the steps in this thread but run into problems everywhere.

Here is the info from my phone:
version: 0.5
version-bootloader: 1.44.0000
version-baseband: 1.00.20.0315
version-cpld: None
version-microp: None
version-main: 1.29.651.10
version-misc: PVT SHIP S-ON

I ran the fastboot oem lock command, and my bootloader says RELOCKED at the top

I tried updating the firmware, and get:
C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash zip firmware.zip
sending 'zip' (25541 KB)...
OKAY [ 2.107s]
writing 'zip'...
(bootloader) signature checking...
FAILED (remote: 12 signature verify fail)
finished. total time: 6.255s

So I tried updating the RUU using both the executable and ARUWizard. It tells me I'm going from 1.29.651.10 to 5.05.651.2, starts the process, then errors out quickly and says Error 158, Image Error, please use the correct ROM update utility.

Now my phone is stuck in the boot loader. Help

(edit: I also tried going to the 4.06 version but ran into the same error)

EDIT: Got the RUU back to stock working, so now I can go from there. Thanks!
Last edited by lordtigger; 18th December 2014 at 01:53 AM.
18th December 2014, 05:28 PM   |  #272  
Junior Member
Flag NYC
Thanks Meter: 2
 
24 posts
Join Date:Joined: Dec 2007
More
Ok everyone,

After 2 days of trial and error, I just got a replacement phone and decide to go all the way and upgrade it before I put back all my settings. Here is my recap.

I had the HBoot 1.44 and S-on I decide to run the RUU.exe and it was going to be done nice and easy. WRONG!!! I went ahead and did the following:
-Unlock using the HTC DEV method with the .bin file
-install custom recovery I use the latest TWRP
-install the revone file in order to obtain S-OFF (This method was done from inside the phone, no computer needed)
-You are then S-OFF and now you must relock the bootloader again in order to flash the update software
(I tought I was done and all I had to do was install the RUU.exe) Again WRONG!!! I was getting a 158 image error
-I then use the command fastboot oem rebootRUU
-Now you are in a black HTC screen and here you can flash the udpate zip
-so now you can use fastboot flash zip RUU.zip Make sure you type the name of the update RUU and also move that zip into your adb folder
-the first time I try I disconnected and reconnected the phone after I hit the step before this one then I got a flush screen
-second time I try and bam!!! my system was update but the cmd screen stayed in black so I type fastboot reboot boot-loader
- My phone went into boot loader and I began to unlock again using the .bin file
-once again install custom recovery
---Once I did this I notice I had no files and no ROM and my phone was booting to a black screen with no letters or anything
-Went into recovery once again and use the adb sideload to upload a zip file containing a ROM and problem fix!!


I hope this helps people and just hit the Thanks button.
Yesterday, 08:56 AM   |  #273  
Junior Member
Thanks Meter: 2
 
27 posts
Join Date:Joined: Jun 2008
Sprint_HTC_One_m7wls_5.05.651.2_OTA_only.zip

link is down, would appreciate another if possible please!
Yesterday, 09:25 AM   |  #274  
BD619's Avatar
Forum Moderator
Flag Xda-Dev,NV
Thanks Meter: 8,188
 
8,546 posts
Join Date:Joined: Apr 2012
Donate to Me
More
Quote:
Originally Posted by lordyamis

Sprint_HTC_One_m7wls_5.05.651.2_OTA_only.zip

link is down, would appreciate another if possible please!

Why are you trying to use the OTA zip?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes