Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] [PLEASE HELP] HTC One M7 not charging when on.

OP AnubhavSaxena

4th June 2014, 05:14 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
1 posts
Join Date:Joined: Jun 2014
Device: HTC One (M7) Stock ROM

A few days ago, my never rooted, stock firmware, no unlocked boot loader, no custom ROM, never dropped HTC One (M7)'s battery died. Plugging in the charger had no effect, absolutely NOTHING. Tried 6 different cables and 9 different locations to charge it, nothing. Waited a while, dying in desperation. Then after so much of panic, I plugged it again, and randomly it started charging. But the charging had a loop - showed a bright orange LED with the power symbol on a battery for about 5 seconds, then a dim orange LED with the green battery charging, and a number, for about 10 seconds. The loop kept repeating. Eventually I could turn it on till the (incredibly low capacity) battery could live. So I did about 10 resets to it, and the situation would not improve.

Since my phone just decided to do this to me just before a long journey of mine, I was quite upset, and eventually infuriated to the limits. I decided to take it along and try different things to it - tried, tried, cleaned the ports, searched the net, nothing.

One fine day it decided to break the loop - now it charged, but only when off.

And today again its started the loop.

And here I am, begging for some help. I'm starting to hate this device now. Please help me..

P.S. : I played a lot of Clash of Clans on the phone - it heated up a lot. Hope the info helps (Possible corrupted overheating charge instructions of the phone,etc.)
Last edited by AnubhavSaxena; 5th June 2014 at 07:26 AM. Reason: Additional information added
The Following User Says Thank You to AnubhavSaxena For This Useful Post: [ View ]
Today, 05:12 AM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2014
please help i love this phone cant lose this at all
Quote:
Originally Posted by AnubhavSaxena

Device: HTC One (M7) Stock ROM

A few days ago, my never rooted, stock firmware, no unlocked boot loader, no custom ROM, never dropped HTC One (M7)'s battery died. Plugging in the charger had no effect, absolutely NOTHING. Tried 6 different cables and 9 different locations to charge it, nothing. Waited a while, dying in desperation. Then after so much of panic, I plugged it again, and randomly it started charging. But the charging had a loop - showed a bright orange LED with the power symbol on a battery for about 5 seconds, then a dim orange LED with the green battery charging, and a number, for about 10 seconds. The loop kept repeating. Eventually I could turn it on till the (incredibly low capacity) battery could live. So I did about 10 resets to it, and the situation would not improve.

Since my phone just decided to do this to me just before a long journey of mine, I was quite upset, and eventually infuriated to the limits. I decided to take it along and try different things to it - tried, tried, cleaned the ports, searched the net, nothing.

One fine day it decided to break the loop - now it charged, but only when off.

And today again its started the loop.

And here I am, begging for some help. I'm starting to hate this device now. Please help me..

P.S. : I played a lot of Clash of Clans on the phone - it heated up a lot. Hope the info helps (Possible corrupted overheating charge instructions of the phone,etc.)

I am having the same exact problem right now. its very annoying. I have to drain the whole battery to charge it again. and its in that loop that you mentioned. plus it does not charge when you put it on charge when its on. it doesnt even have that charging light. it only charges itself if its off and if there is no battery left, i have to put it on charge by draining the whole battery by using apps and stuff and i am so pissed right now i cant find a solution to this. Did you find a solution on how to get this fixed?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes