FORUMS

Top Forum Discussions

Touchscreen problems

5 posts
Thanks Meter: 0
 
By BelfastGonzo, Junior Member on 1st June 2014, 01:51 PM
Post Reply Subscribe to Thread Email Thread
I have a UK Advent Vega Tetra Note 7 (the Currys /PC World version) with a slide cover. Lately the touchscreen has been exhibiting a few intermittent problems. The most annoying is that when I hit a soft key or type a letter, the screen registers multiple touches. This is extremely frustrating when I hit the back button, only to close the entire application.

The pinch and zoom sometimes plays up to. I thought that might be related to the already-identified issue over the black area to the sides of the screen being touch sensitive when they really should not be. It means that your palm often inadvertently acts as a second finger when scrolling, and zooms the screen. However the problem seems deeper, as it can happen even when being careful not to touch the bezel. And if you hold the black area off to the side of the screen, it brings up a menu.

When browsing, occasionally the touch and hold works a bit randomly, for example, when you hold a link that you want to bring up in a new tab.

I have factory reset the tablet and the problem disappears, only to reappear later. And it isn't constant either - it comes and goes.

I wonder if the issue has something to do with the magnetic slide case? Or do users without the case also experience problems? It really is a pity, as this is a great tablet otherwise.
 
 
1st June 2014, 04:14 PM |#2  
Junior Member
Thanks Meter: 3
 
More
I've had issues similar. After going back to 4.3 they seemed to go away (battery life was better too). Now back on 4.4.2 and OTA 2.3 the problems are there again. It must be a software issue, hopefully it'll be fixed along with the battery life issues.

Roll on 4.5 and let's hope nvidia give us it.
2nd June 2014, 01:23 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
downgrade?
Quote:
Originally Posted by BuToNz

I've had issues similar. After going back to 4.3 they seemed to go away (battery life was better too). Now back on 4.4.2 and OTA 2.3 the problems are there again. It must be a software issue, hopefully it'll be fixed along with the battery life issues.

Roll on 4.5 and let's hope nvidia give us it.

How did you downgrade? Is it just a case of a factory reset, then declining any upgrades?

I do hope Nvidia are aware of this problem. It really takes the shine of a good tablet.
2nd June 2014, 05:28 PM |#4  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by BelfastGonzo

How did you downgrade? Is it just a case of a factory reset, then declining any upgrades?

I do hope Nvidia are aware of this problem. It really takes the shine of a good tablet.

Look here for an Advent guide to reflashing the 4.3 ROM:
http://www.adventcomputers.co.uk/pro...oad-select/296

You can ignore the updates afterwards. By no means though is 4.3 perfect, there is problems with the GPS and various other things that have been fixed in the latest versions.

Personally I found the latest to be best overall - Minus the battery life issues and some minor stylus/touchscreen issues.
The Following User Says Thank You to BuToNz For This Useful Post: [ View ]
9th June 2014, 11:47 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Thank you BuToNz. I developed touchscreen problems when using the stylus after updating to 4.4.2, sensitivity was lost in an area the size of a large coin, if it registered anything in this zone it was just a messed up line. I downgraded as per the link details to 4.3 and the touchscreen with stylus is fine again.. Left feedback with Nvidia, hopefully they can repair this.
19th June 2014, 12:32 AM |#6  
Shaky156's Avatar
Senior Member
Thanks Meter: 2,015
 
Donate to Me
More
Quote:
Originally Posted by BelfastGonzo

I have a UK Advent Vega Tetra Note 7 (the Currys /PC World version) with a slide cover. Lately the touchscreen has been exhibiting a few intermittent problems. The most annoying is that when I hit a soft key or type a letter, the screen registers multiple touches. This is extremely frustrating when I hit the back button, only to close the entire application.

The pinch and zoom sometimes plays up to. I thought that might be related to the already-identified issue over the black area to the sides of the screen being touch sensitive when they really should not be. It means that your palm often inadvertently acts as a second finger when scrolling, and zooms the screen. However the problem seems deeper, as it can happen even when being careful not to touch the bezel. And if you hold the black area off to the side of the screen, it brings up a menu.

When browsing, occasionally the touch and hold works a bit randomly, for example, when you hold a link that you want to bring up in a new tab.

I have factory reset the tablet and the problem disappears, only to reappear later. And it isn't constant either - it comes and goes.

I wonder if the issue has something to do with the magnetic slide case? Or do users without the case also experience problems? It really is a pity, as this is a great tablet otherwise.

Quote:
Originally Posted by BuToNz

I've had issues similar. After going back to 4.3 they seemed to go away (battery life was better too). Now back on 4.4.2 and OTA 2.3 the problems are there again. It must be a software issue, hopefully it'll be fixed along with the battery life issues.

Roll on 4.5 and let's hope nvidia give us it.

Quote:
Originally Posted by jbartle

Thank you BuToNz. I developed touchscreen problems when using the stylus after updating to 4.4.2, sensitivity was lost in an area the size of a large coin, if it registered anything in this zone it was just a messed up line. I downgraded as per the link details to 4.3 and the touchscreen with stylus is fine again.. Left feedback with Nvidia, hopefully they can repair this.

http://forum.xda-developers.com/show....php?t=2787574
28th November 2014, 03:24 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Unhappy tegra note touch faulty
me 2 facing the same problem pls help..
28th November 2014, 11:05 PM |#8  
rchrdcrg's Avatar
Senior Member
Flag Branson, MO
Thanks Meter: 32
 
More
There is a known issue that has existed since the tablet was launched where sometimes if you wake the screen by opening the cover, the touchscreen can become erratic or unresponsive. If you do a quick sleep/wake with the power button, it usually fixes it. Why Nvidia hasn't been able to fix this after a year is baffling and part of why I held off on getting a Shield Tab (among other reasons).
23rd December 2014, 07:43 PM |#9  
IM0001's Avatar
Senior Member
Thanks Meter: 92
 
More
Quote:
Originally Posted by rchrdcrg

There is a known issue that has existed since the tablet was launched where sometimes if you wake the screen by opening the cover, the touchscreen can become erratic or unresponsive. If you do a quick sleep/wake with the power button, it usually fixes it. Why Nvidia hasn't been able to fix this after a year is baffling and part of why I held off on getting a Shield Tab (among other reasons).

This has been consistent with mine and I can live with it, however recently randomly after a day or two of use, if I turn off the tab with the power button and have it charging, when I go to use it again after a random time, I get a completely unresponsive touchscreen after powering it back up with the button. No response from the screen at all. Buttons work fine, and a hard power down fixes the issue just fine, but no amount of play with either the power button or screen cover or even stylus fixes the non responsive screen. Very strange.

Still love every bit of this tab, but do hope for a Android 5.0 update soon for both it and my Shield Portable.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes