Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[VRTHEME][TEMPLATE] EVilTheme

OP aureljared

26th December 2014, 03:02 PM   |  #71  
Spannaa's Avatar
Recognized Themer
Flag Cardiff
Thanks Meter: 11,816
 
3,476 posts
Join Date:Joined: Sep 2010
Donate to Me
More
Quote:
Originally Posted by Raymond Ebertt

Here's a flow chart on the folder bases that you need. You will need to make a folder for each box that you see. As well, the bottom flow chart explains what is needed in each folder. Hope this helps and Merry Christmas.

And be aware that everything is case-sensitive and all paths & folder names must be named EXACTLY as they are in your rom.
The Following 2 Users Say Thank You to Spannaa For This Useful Post: [ View ]
26th December 2014, 11:16 PM   |  #72  
asdfasdfvful's Avatar
Recognized Themer
Vancouver
Thanks Meter: 1,260
 
1,797 posts
Join Date:Joined: Apr 2013
Donate to Me
More
Well, tried it again and it didn't work. Same result as before (systemui was basically gone). Had to clean flash the rom again to get it working. I decompiled all the apps again and basically copied the different files through winmerge, so I'm sure I'm not missing anything.

Here was my test zip and here is my recovery log.

Unfortunately, I seem to get errors with the regular zips sometimes as well, so I'm not completely sure what the issue it. I build and sign the apps with a debug key, and don't sign the zip afterwards, as I believe it is not necessary.

P.S. This is built for Terminus. If anyone can get this working on their phone, I'd love to get some feedback on how to fix it.
The Following User Says Thank You to asdfasdfvful For This Useful Post: [ View ]
27th December 2014, 02:08 AM   |  #73  
Raymond Ebertt's Avatar
Recognized Contributor / Themer
Flag Machachai
Thanks Meter: 2,944
 
2,799 posts
Join Date:Joined: Dec 2011
Donate to Me
More
Quote:
Originally Posted by asdfasdfvful

Well, tried it again and it didn't work. Same result as before (systemui was basically gone). Had to clean flash the rom again to get it working. I decompiled all the apps again and basically copied the different files through winmerge, so I'm sure I'm not missing anything.

Here was my test zip and here is my recovery log.

Unfortunately, I seem to get errors with the regular zips sometimes as well, so I'm not completely sure what the issue it. I build and sign the apps with a debug key, and don't sign the zip afterwards, as I believe it is not necessary.

P.S. This is built for Terminus. If anyone can get this working on their phone, I'd love to get some feedback on how to fix it.

Send me your theme zip by PM, please.

Sent from my HTC One_M8 using XDA Free mobile app

---------- Post added at 02:08 AM ---------- Previous post was at 01:23 AM ----------

Quote:
Originally Posted by asdfasdfvful

Well, tried it again and it didn't work. Same result as before (systemui was basically gone). Had to clean flash the rom again to get it working. I decompiled all the apps again and basically copied the different files through winmerge, so I'm sure I'm not missing anything.

Here was my test zip and here is my recovery log.

Unfortunately, I seem to get errors with the regular zips sometimes as well, so I'm not completely sure what the issue it. I build and sign the apps with a debug key, and don't sign the zip afterwards, as I believe it is not necessary.

P.S. This is built for Terminus. If anyone can get this working on their phone, I'd love to get some feedback on how to fix it.

Ok, I see your issue.

First of all, you packed your theme in the new folder of the vrtheme. All of your theme needs to go into the correspondent folders inside the vrtheme folder. As well, I noticed some 9.png that still have patches. You'll need to patch those before making your theme. I'll send you a sample of your theme by zip in a few minutes. You can have a look at it and complete it accordingly.
The Following 3 Users Say Thank You to Raymond Ebertt For This Useful Post: [ View ]
27th December 2014, 07:38 AM   |  #74  
asdfasdfvful's Avatar
Recognized Themer
Vancouver
Thanks Meter: 1,260
 
1,797 posts
Join Date:Joined: Apr 2013
Donate to Me
More
Thanks to all who have helped me! This is what I've learned in case other beginners need it
  • On top of creating individual folders for each app (ie SystemUI under priv-app), you also need to create a folder for the apk itself (SystemUI.apk) before adding your files
  • Only add changed files, and add the compiled ones (so build the apk, then unzip, then copy over)
  • The values folder is not needed as it is already in resources.arsc
  • If you modified smali, copy over the classes.dex as well

@Spannaa, if possible, could you give more details on how the backup zip works? Thanks!
The Following User Says Thank You to asdfasdfvful For This Useful Post: [ View ]
27th December 2014, 09:53 AM   |  #75  
Spannaa's Avatar
Recognized Themer
Flag Cardiff
Thanks Meter: 11,816
 
3,476 posts
Join Date:Joined: Sep 2010
Donate to Me
More
Quote:
Originally Posted by asdfasdfvful


@Spannaa, if possible, could you give more details on how the backup zip works? Thanks!

As part of the script, the original apks are copied into a flashable zip file before being injected with the theme files.

This zip file will restore your files to their pre-themed versions if you flash it.


Sent by bacon...
The Following 2 Users Say Thank You to Spannaa For This Useful Post: [ View ]
Yesterday, 04:10 AM   |  #76  
asdfasdfvful's Avatar
Recognized Themer
Vancouver
Thanks Meter: 1,260
 
1,797 posts
Join Date:Joined: Apr 2013
Donate to Me
More
Is anyone seeing an issue with png s being copied over? They don't seem to be modified

Sent from my Nexus 5 using Tapatalk
Yesterday, 09:45 AM   |  #77  
Spannaa's Avatar
Recognized Themer
Flag Cardiff
Thanks Meter: 11,816
 
3,476 posts
Join Date:Joined: Sep 2010
Donate to Me
More
Quote:
Originally Posted by asdfasdfvful

Is anyone seeing an issue with png s being copied over? They don't seem to be modified

Sent from my Nexus 5 using Tapatalk

If the recovery log doesn't show any errors then are you sure you're modifying pngs in the correct folder or apk?

Check by pulling the themed apk from your device and looking inside.

Sent by bacon...
The Following User Says Thank You to Spannaa For This Useful Post: [ View ]
Yesterday, 12:12 PM   |  #78  
Ryo Kun(Momo)'s Avatar
Senior Member
Thanks Meter: 53
 
206 posts
Join Date:Joined: May 2012
More
Please help, what wrong with my theme, here the log https://db.tt/ql0rtGxp and the zip ->> https://db.tt/K3JfLxlQ it did nothing, I'm going to change the icons
Yesterday, 10:37 PM   |  #79  
asdfasdfvful's Avatar
Recognized Themer
Vancouver
Thanks Meter: 1,260
 
1,797 posts
Join Date:Joined: Apr 2013
Donate to Me
More
Quote:
Originally Posted by Ryo Kun(Momo)

Please help, what wrong with my theme, here the log https://db.tt/ql0rtGxp and the zip ->> https://db.tt/K3JfLxlQ it did nothing, I'm going to change the icons

You made the same mistake as me (something spannaa just answered too haha).
Make sure you are taking the images from the compiled app, and look at the folder names. Apart from "drawables", the other drawable folders tend to have a "-v4" after it. Just make sure you add that.
Today, 07:08 AM   |  #80  
Raymond Ebertt's Avatar
Recognized Contributor / Themer
Flag Machachai
Thanks Meter: 2,944
 
2,799 posts
Join Date:Joined: Dec 2011
Donate to Me
More
I'll make a video over the next day or two on how to pack a vrtheme and all the business that goes along with it.

Sent from my HTC One_M8 using XDA Free mobile app

The Following User Says Thank You to Raymond Ebertt For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
eviltheme, flash, recovery, theme, vrtheme
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes