FORUMS
Post Reply Subscribe to Thread Email Thread

troubleshooting choppy xvid playback in gotham xbmc

27th June 2014, 01:49 AM |#1  
OP Junior Member
Flag Palm Desert, CA
Thanks Meter: 6
 
More
xbmc gotham 13.1 release - I have been trying to eliminate choppy playback with xvid encoded files. ( jitter stutter whatever you want to call it ) The file I am looking at is not using packed bitstream and does not matter whether it is in avi or mkv container. A good measure of this symptom is the opening studio logos or scenes which have panning or gliding objects. In my limited test divx encoded videos did not have this problem.

If you have hardware acceleration applied, go into settings, video settings, acceleration, disable libstagefright, disable mediacodec, and try and see if that works, otherwise choose software acceleration without choosing multi-threaded decoding.

the key to get this to work is to not have libstagefright or medicodec applied in hardware decoding. If you have to, then apply software decoding without multi-threaded decoding. It might take a reboot for this to work, or simply play a file with hardware decoding and then choose the above settings.

Let me know if that works for you. This also works on the xbmc for ouya application.

after turning off hardware acceleration you will need to re-enable it when playing anything larger than 720p.

I was looking at advancesettings.xml options to see if I could disable hardware for xvid only but I don't see that option, and trying to enable it only for avc, etc did not work. If I could figure out a way to play said files with xbmc for ouya automatically from gotham then I would do that.
Last edited by hmagoo; 27th June 2014 at 06:38 AM.
 
 
29th December 2014, 12:57 AM |#2  
Member
Thanks Meter: 10
 
More
Quote:
Originally Posted by hmagoo

xbmc gotham 13.1 release - I have been trying to eliminate choppy playback with xvid encoded files. ( jitter stutter whatever you want to call it ) The file I am looking at is not using packed bitstream and does not matter whether it is in avi or mkv container. A good measure of this symptom is the opening studio logos or scenes which have panning or gliding objects. In my limited test divx encoded videos did not have this problem.

If you have hardware acceleration applied, go into settings, video settings, acceleration, disable libstagefright, disable mediacodec, and try and see if that works, otherwise choose software acceleration without choosing multi-threaded decoding.

the key to get this to work is to not have libstagefright or medicodec applied in hardware decoding. If you have to, then apply software decoding without multi-threaded decoding. It might take a reboot for this to work, or simply play a file with hardware decoding and then choose the above settings.

Let me know if that works for you. This also works on the xbmc for ouya application.

after turning off hardware acceleration you will need to re-enable it when playing anything larger than 720p.

I was looking at advancesettings.xml options to see if I could disable hardware for xvid only but I don't see that option, and trying to enable it only for avc, etc did not work. If I could figure out a way to play said files with xbmc for ouya automatically from gotham then I would do that.

I know this is a pretty old thread, but wanted to just chime in here. I'm having these exact issues in my Ouya, but my AFTV plays the xvid/dvix (at 480p) files just fine (no stutter). I have my hardware decoding turned ON when i see the stuttering. As you mentioned, if/when I disable hardware decoding, the xvid/divx SD files play smoother (as smooth as i'd want). Wondering if ANYONE here knows anything about a way to disable hardware decoding on xvid/divx files, leaving it on for all else, without having to manually disable/re-enable it for each file? That is super wife-unfriendly (though it's fine for me).

I've been searching for over an hour so far, so if anyone has a quick link for me on how to do it, don't flame me for not finding it on my own please
1st January 2015, 10:19 PM |#3  
OP Junior Member
Flag Palm Desert, CA
Thanks Meter: 6
 
More
Use spmc problem solved. Changes decode settings automatically.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes