Post Reply

[Q] Gionee Elife S5.5 - how to root or install play store

OP coolerkiller

16th November 2014, 12:17 AM   |  #71  
Junior Member
Thanks Meter: 3
13 posts
Join Date:Joined: Oct 2008
Info 2
did any one know about these dial codes


Originally Posted on:
In the dial-up interface, enter the following password:

"* # 8702 #" - detect phone hardware (select "hardware test" can determine the phone fault is a hardware problem or a software problem, not a hardware problem if detected, the phone can be upgraded or Brush)
"* # 837500 #" - detect mobile version number, installation date, and phone support network standard
"* # 7552 #" - Check whether the phone is ROOT
(Show begins with N not cracked, L beginning was cracked)
"* # * # 4636 # * # *" - check the phone information and battery information
* # * # 7780 # * # * reset to factory settings, do not delete the preset programs, and SD card files.
* 2767 * 3855 # reset to factory settings, SD card will delete all files.
* # * # 34971539 # * # * Display camera firmware version of the camera, or to update the camera firmware
* # * # 7594 # * # * When long press the shutdown button, there will be a window to switch the phone mode include: silent mode, flight mode and shut down, you can use the above code directly into the off button.
* # * # 273283 * 255 * 663282 * # * # * to open a place that you can make backup media files, such as photos, sounds and videos, etc.
* # * # 197328640 # * # * Start service mode, you can test the phone part of the setting and change the setting WLAN, GPS and Bluetooth test code
* # * # 232338 # * # * Display WiFi MAC address
* # * # 1472365 # * # * GPS Test
* # * # 1575 # * # * Other GPS test
* # * # 232331 # * # * Bluetooth Test
* # * # 232337 # * # Display the Bluetooth device address
* # * # 8255 # * # * Start GTalk Service Monitor displays phone software version of the code:
* # * # 0 * # * # * LCD test
* # * # * # * # 0842 test device, such as a vibration, the brightness
* # * # 2663 # * # * touch screen version
* # * # 2664 # * # * Touch screen test
* # * # 0588 # * # * proximity sensor test
* # * # 3264 # * # * memory version
* # 06 # to display phone original factory serial number (International Mobile Identification Number)

25th November 2014, 10:29 PM   |  #72  
Junior Member
Thanks Meter: 1
3 posts
Join Date:Joined: Nov 2014
Thumbs up Install Google Play on Gionee S5.5L (and S5.5) NO CWM required
Hi folks,

Steps described earlier for S5.5 using MTKTools won't work to root and install Google Play Store on Gionee S5.5L (TD-LTE versions) cause it runs on a Qualcomm Snapdragon chipset instead of a Mediatek.

Yet, Mediatek S5.5 user may find interesting this tutorial as it provides the same result, it can be done without PC and without generating a recovery.img for MTKTools.
Here is what I did.

WHAT YOU GET: Google Play Store running and installing APPs on Gionee S5.5L (TD-LTE version) with Chinese Stock ROM.

WHAT YOU NEED: You'll need the highest compatible version of the following APKs for your phone. In my case, the S5.5L runs an Android JellyBean 4.3 based ROM.
- Towerlroot (avail. at towelroot dot com)
- Google Services Framework APK (avail. at apkmirror dot com or any other source of your preference)
- Google Play Store APK (avail. at apkmirror dot com)
- SuperSU and ES File Manager (I download them from Amazon App Store. You can install Amazon App Store from www dot amazon dot com foreslash getappstore)

Disclaimer: Doing these steps is at your own risk. The process will root your phone. No CWM recovery will be installed.

If you have already installed Google Play Store on an Amazon Kindle Fire Table 1st Generation you'll be familiar with these steps.

1.- Go to System Update and upgrade your S5.5L to the latest Amigo version (tested on 2.2.2).

2.- Download Towelroot and run it.
This should root your device right away. Reboot your device.
(OPTIONAL) If you want to check that your device is properly rooted, reboot it, before the ELIFE sign shows up press the Volume Up Key. You'll enter the recovery menu. Use the Volume keys to get to the 'Is Rooted?' entry and press the power key. At the bottom of the screen you'll get a prompt that tells you whether your device is rooted or not.

3.- After rebooting your device install SuperSU and ES File Manager.
Your can do this by either downloading and installing the stand alone APKs, or if you are lazy like me, download and install the Amazon App Store and install SuperSU and ES File Manager directly from it. The drawback, you need an Amazon Account.
(NOTICE) I tried with Root Explorer instead of ES File Explorer without any lack. It was crashing as I was trying to change ownership and permissions to the APK files. No clue why.

4.- Go to Settings->Apps and stop any process related to Google Services that is currently running in your phone. Clear the cache date of these processes.

5.- Go to the folder /system/app and rename GmsCore.apk to GmsCore.apk.bak .
You may need to reestablish this file is something goes wrong. Check also the ownership and permissions of the file as you'll have to apply them to the replacement apk.

6.- Go to your Downloads folder. Rename the Google Play Services APK to GmsCore.apk. Change its ownership and permissions to the same that you found in the original file. Move GmsCore.apk to /system/app and reboot your phone.
(NOTE) If everything went fine, you should have now a 'Google Settings' app icon in your desktop.

7.- After rebooting, go again to your download folder. Rename the Google Play apk file to 'Vending.apk'. Set ownership to user=root group=root. Set permissions as 0644 (owner can read/write/exec, group and others read only). Move the Vending.apk file to /system/app . Reboot.

And TA DA!! You should have now along with your Google Settings, your Google Play Store app icon.

So far I only encountered and error install the Swiftkey Keyboard app (not even sure the failure is related to the Store app). Other apps downloaded from the Play Store app in your mobile, as well as apps installed by entering in your Desktop PC (and selecting your Gionee GN9000L device as destination) are installing correctly, so far.


Here a short list of apps I've got installed, updated and working,

- Gmail
- Maps + Nav (updated without problems)
- Google Keyboard
- Youtube
- Flipboard
- Netflix
- Express VPN
- Spotify
- Djay2
- CS Scanner PDF
- BBC Apps
- Shazham
- Passwallet
- Yatse
- Hangping Pro
- Dropbox
The Following User Says Thank You to JMCamacho For This Useful Post: [ View ]
26th November 2014, 07:48 PM   |  #73  
Junior Member
Thanks Meter: 3
13 posts
Join Date:Joined: Oct 2008
If you have s5.5 with amingo 2.0.10 (Chinese Stock ROM) you cant use towelroot, it simply says "This phone isn't currently supported"
28th November 2014, 10:58 AM   |  #74  
Junior Member
Thanks Meter: 1
3 posts
Join Date:Joined: Nov 2014
Originally Posted by XPAction

If you have s5.5 with amingo 2.0.10 (Chinese Stock ROM) you cant use towelroot, it simply says "This phone isn't currently supported"

Try to upgrade to Amigo 2.2.2 first.

Anyways, if towelroot doesn't work, you still have a bunch of alternatives to get root in a s5.5 as it runs on MTK processor (towelroot would do if you had an S5.5L snapdragon 400) .

Once you get root, you may want to just replace the Google Services and Google Play Store apk's in system/app folder instead of installing CWM.
5th December 2014, 06:41 AM   |  #75  
Tech.Nik's Avatar
Flag New Delhi
Thanks Meter: 3
37 posts
Join Date:Joined: Feb 2013

I'm on version 4.4.2, I'm planning to root so as I can use xposed module.
Could someone tell me if we can use the modules?
18th December 2014, 08:26 AM   |  #76  
Junior Member
Thanks Meter: 0
2 posts
Join Date:Joined: Dec 2014
I have rooted my gionee s5.5 and unrooted again successfully using kingo root software working 100percent make sure your PC is connected to internet. Be aware after rooting the phone make a backup of ROM before making any changes to your phone.
Good luck :thumbup:
Last edited by T$$; 18th December 2014 at 08:31 AM.
18th December 2014, 10:05 AM   |  #77  
Junior Member
Thanks Meter: 1
18 posts
Join Date:Joined: Nov 2014
or just go get another phone. why need to force yourself
29th December 2014, 10:44 AM   |  #78  
Kanth's's Avatar
Flag India
Thanks Meter: 1
69 posts
Join Date:Joined: Oct 2014
Is Gionee after sale service good???
Originally Posted by coolerkiller

Dear all

I bought the new gionee elife s5.5

Unfortunately it has no play store installed and adding the apk and running it after installation always results in a forced close.

Does anybody know how to root the phone? Will Vroot also work (it is supposed to work on the elife e7 which has the same custom rom, amigo 2.0, I think).

Really struggling because many dialogs are in Chinese although I set the language to english...

Btw. one chinese guy told me the phone can be rooted using a chinese application named 大师 - however I have no clue where to even start with this...

Is Gionee after sale service good???
30th December 2014, 05:56 AM   |  #79  
Indian Devil's Avatar
Senior Member
Thanks Meter: 83
399 posts
Join Date:Joined: Sep 2012
Originally Posted by Kanth's

Is Gionee after sale service good???

My experience have been good, better than Samsung I have to say.
3rd January 2015, 06:16 PM   |  #80  
Senior Member
Thanks Meter: 24
142 posts
Join Date:Joined: Nov 2010
Has anyone tried Google Now launcher after rooting this device? Does the "OK Google" hotword detection work fine?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes