Post Reply

Knock On Not Working

OP Anthony_xdl

13th October 2014, 03:27 AM   |  #61  
Junior Member
Thanks Meter: 0
1 posts
Join Date:Joined: Oct 2014
Originally Posted by djpeesh

Go to the hidden menu.

Then click on hw device test

Then click on touch test

Then click on touch firmware update

Click OK and your knock on issues will be sorted (hopefully)

Sent from my LG-D802 using Tapatalk

Thank you this method work for me.
After I tried all the method in this thread and Knock On still doesn't work. I accidentally found out that you have to knock at a SLOWER pace for KnockON. I can still knock OFF at quick speed.
If you're still looking for a solution after the steps above, try tapping at a slightly slower pace
13th October 2014, 04:14 AM   |  #62  
rootlinux's Avatar
Senior Member
Flag Cleveland
Thanks Meter: 2,976
3,841 posts
Join Date:Joined: Jul 2009
Donate to Me
Try flashing a knock enabled kernel like Dori.
My knock on wasn't working after Autorec on zvd. Dori kernel fixed it.
It isn't zvd that makes knock on not work. The problem is the kernel in Autorec. It worked fine after OTA then stopped after Autorec. Did it three times to verify. Fourth tot, OTA and then AUTOREC I then rebooted to recovery and flashed Dori.
Boom... All knock works perfectly.
The Following User Says Thank You to rootlinux For This Useful Post: [ View ]
5th November 2014, 01:38 PM   |  #63  
Junior Member
Thanks Meter: 0
2 posts
Join Date:Joined: Feb 2010
Finally someone who found my problem. Exactly what happened to me.
Did the OTA, rooted whit ioroot and run autorec. And then the knock on/knock code stopped working.
Did the hidden menu thingy and knock on works again. But knock code does not. Have tried to reboot and activate/unactivate knock code. But it still works like a knock on.

So do anyone know about a better way to install custom recovery whitout using autorec? Does the autorec people know about this?

22nd November 2014, 07:58 PM   |  #64  
Thanks Meter: 3
43 posts
Join Date:Joined: Feb 2010
Originally Posted by mcapocas

Is it normal that knock on isn't working when knock code is used to unlock the phone ?

Just put cloudy g3 2.1 on D802 with Dorimanx kernel. I thought I also had knock on issue. But found that rather than tap the screen to get home screen to show, the knocks have to be in the same position as your code. I hope this might help someone.
26th November 2014, 07:18 PM   |  #65  
Junior Member
Thanks Meter: 0
3 posts
Join Date:Joined: Oct 2008
Prompt knock unlocking - proximity sensor
Hello to everyone,

after getting all this helpful info through this forum I've decided to contribute something myself.

I had the same issue after replacing my LG g2 screen. It worked fine before.
The problem in my case was the proximity sensor. It sits behind an oval window between the front facing camera and the light sensor. It has two small lenses, a bigger or the left and a smaller on the right.
If that sensor sits slightly wrong or the front rubber case is missing (I didn't noticed it the first time) or the required pressure from a small rubber behind (it is on the upper black secondary housing with the 7 screws) is not enough to hold it in a fixed certain place, it doesn't work correctly or at all.

When this happens the sensors detects near (meaning you have the device close to your face) and Knock unlocking is blocked. Also when you are making a call the screen goes off for the same reason, so it is easy to notice.

After I noticed and placed the front rubber case from the old screen, it was working, but slowly. It detected quickly the "near" position but it takes several seconds to re detect "far" position.

The final solution was reinforcing the small rectangular rubber which pushes the light sensor and the proximity sensor from behind, with two small pieces of sticker and the problem disappeared.

You can check that through the hidden menu (for my case 3845#*802#), HW Device test, ALC Proximity Test.
It should change rapidly from NEAR to FAR then waving your hand over the sensor.
If not, push firmly with one finger behind the sensor and see then if it is working
17th December 2014, 10:05 PM   |  #66  
alexsoin's Avatar
Senior Member
Flag San Carlos, CA
Thanks Meter: 10
118 posts
Join Date:Joined: Jan 2014
I have another type of issue.
I don't see this screen by selecting "update touch firmware".
Do I have to be on wi-fi coz I don't have any, only 4G by TMobile
I had to update my 4.3 PA ROM for LG G2 D801 Claro PR (which worked great btw, only dynamic was tiny) to stock Claro KK since I "bricked" it.
Claro KK is fine with lots of bloat dynamic is superloud but issues with knock on, knock off works perfect.
Attached Thumbnails
Click image for larger version

Name:	zunasaqe.jpg
Views:	98
Size:	20.1 KB
ID:	3069217  
20th January 2015, 05:40 AM   |  #67  
Junior Member
Thanks Meter: 0
5 posts
Join Date:Joined: Jan 2015
lg g2 knook on code
Hello everyone i seem to not be able to get my knook on to work. The phone will knook off but not on. This phone was rooted before i owned it but the guy set it back to stock and took the root off for me. I have done the hidden menu but that dont work i have verizon and i have 4.4.2 right now

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes