Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[kernel]First kernel for 3D built by the 3D

OP jcfunk

17th January 2015, 09:51 PM   |  #31  
bigsupersquid's Avatar
Senior Member
Flag BFE, MO
Thanks Meter: 441
 
712 posts
Join Date:Joined: Sep 2010
Donate to Me
More
by the way, if you hadn't seen, xserver xsdl on play (open source) for slick gui chrooting.
17th January 2015, 10:02 PM   |  #32  
jcfunk's Avatar
OP Senior Member
Thanks Meter: 272
 
469 posts
Join Date:Joined: Mar 2008
More
Really just use terminal chroot, will checkout the app. I truely believe a native build is better then cross compiled
18th January 2015, 03:16 AM   |  #33  
bigsupersquid's Avatar
Senior Member
Flag BFE, MO
Thanks Meter: 441
 
712 posts
Join Date:Joined: Sep 2010
Donate to Me
More
Quote:
Originally Posted by jcfunk

Really just use terminal chroot, will checkout the app. I truely believe a native build is better then cross compiled

i get a charge from building on device. plus it's a lot more useful than setting up my old Toshiba laptop with comparable specs to the evo.

that x server is pretty sick, once i got everything set up right in the chroot i can watch YouTube in chromium-browser even.
never had smooth streaming with a vnc.
Last edited by bigsupersquid; 18th January 2015 at 03:20 AM.
19th January 2015, 03:30 AM   |  #34  
jcfunk's Avatar
OP Senior Member
Thanks Meter: 272
 
469 posts
Join Date:Joined: Mar 2008
More
Quote:
Originally Posted by bigsupersquid

i get a charge from building on device. plus it's a lot more useful than setting up my old Toshiba laptop with comparable specs to the evo.

that x server is pretty sick, once i got everything set up right in the chroot i can watch YouTube in chromium-browser even.
never had smooth streaming with a vnc.

Maybe you can post image or guide how to setup. I don't have time to figure it out. [emoji3]
19th January 2015, 06:23 AM   |  #35  
bigsupersquid's Avatar
Senior Member
Flag BFE, MO
Thanks Meter: 441
 
712 posts
Join Date:Joined: Sep 2010
Donate to Me
More
Quote:
Originally Posted by jcfunk

Maybe you can post image or guide how to setup. I don't have time to figure it out. [emoji3]

basically open the xserver app, then in chroot
Code:
env DISPLAY=$(ifconfig | sed -En 's/127.0.0.1//;s/.*inet (addr:)?(([0-9]*\.){3}[0-9]*).*/\2/p'):0 startxfce4&
to start xfce4 .
substitute other GUI startup at will for startxfce4. the rest of the mess is just to grab the local ip so you don't hafta type it in. //server doesn't like 127.0.0.1 #actually it's cool but was a buttwumpus to find simple directions for local X port forwarding from a non-running system (chroot)

u7se this for forwarding localhost:6000 over ssh:
kind of working but inconsistent, wifi most consistent
Code:
ssh -X -L 6000:localhost:6000 you@localhost "startxfce4 &"
in chroot terminal.
you is your user/root, startxfce4 can be swapped for your personal choice.
gotta add shmem lib from xserver github and tmpfs at /dev/shm for chromium.
devtmpfs on in kernel or find a usable way around udev.

easier to use terminal but i like gimp and stuff too.
shouldn't derail your thread too much....
should mention whatever arm-linux-gnueabihf- came with 14.04 compiled johnnyslt's kitkat mirage shooter kernel all friendly-like and no issues running it.
Last edited by bigsupersquid; 22nd January 2015 at 04:53 PM.
20th January 2015, 04:39 AM   |  #36  
jcfunk's Avatar
OP Senior Member
Thanks Meter: 272
 
469 posts
Join Date:Joined: Mar 2008
More
Not a derail good info for people to build on phone.
21st January 2015, 04:27 PM   |  #37  
bigsupersquid's Avatar
Senior Member
Flag BFE, MO
Thanks Meter: 441
 
712 posts
Join Date:Joined: Sep 2010
Donate to Me
More
added ssh forwarding instructions for xserver above. no network connection needed.
21st January 2015, 07:30 PM   |  #38  
jcfunk's Avatar
OP Senior Member
Thanks Meter: 272
 
469 posts
Join Date:Joined: Mar 2008
More
Had problems, I'm using core Ubuntu img which didn't have xfce4 installed. Install and run your command, I get xserver running already.
22nd January 2015, 03:35 AM   |  #39  
bigsupersquid's Avatar
Senior Member
Flag BFE, MO
Thanks Meter: 441
 
712 posts
Join Date:Joined: Sep 2010
Donate to Me
More
Quote:
Originally Posted by jcfunk

Had problems, I'm using core Ubuntu img which didn't have xfce4 installed. Install and run your command, I get xserver running already.

it's the x server app running, mine says that when it connects anyway.
instead of xce4, dwm is ultra light, but you have to use key shortcuts to open anything. lxde seems to want bigger screen. gnome is heavy but i may try it anyway.... maybe compiz, it's open gl.
xfce works decent, that's why i installed it.
//whoops, had extra & at end of ssh line that broke it. ssh tunnel better'n net tunnel anyway.
today only wifi working, wtf.
Last edited by bigsupersquid; 22nd January 2015 at 04:54 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes