FORUMS

Do You Use 4:3 or 16:9 in the Camera App?

Every person has their own method of taking the best photos on their devices, but which aspect … more

LG G4 XDA Forum Opened

LG’s latest & greatest is just a few hours away from launching, and with so many power users that are … more

Android Wear Close to Running on Samsung Gear 2

Android is an OS that can sometimes be ported to run on devices not designed to … more

The Curious Case Of The Flash Sale

What do the horses in the Xiaomi stable, notably the Mi 3, Mi 4, Redmi 1S, Redmi 2 & Redmi Note … more
Post Reply Subscribe to Thread Email Thread

[Q] Odd battery behavior, possibly faulty reporting. (CM11)

17th June 2014, 07:13 AM |#1  
OP Junior Member
Thanks Meter: 1
 
More
Recently updated from CM9 to jcsullin's CM11 (11-20140409). Most everything seems to be ok aside from an unusual battery issue, and I don't know what it's coming from. I've attached a screenshot with some battery stats to help out, but I can describe what was going on in this particular instance.

I've had my touchpad sitting on the touchstone nearly 100% of this time (only time it was not was when I picked it up and immediately returned it). At some point, loaded up and was playing Breach & Clear for a while. Finally stopped playing, and upon exiting, battery was reported at 1%. Now, I get that some things can drain the battery even while on a charger, but we're talking a span of maybe 60-90 minutes. At this point, I picked the pad up and the battery immediately went up to 100%, and I dropped it back onto the touchstone.

This is the second time I've had this happen. Yesterday, it actually shut itself off due to low battery when I picked it up. I turned it right back on, and it was reporting 100% (recovery also reports 100%). This morning, I reflashed the A6 firmware in case that was the issue, but it does not seem to have had any impact.

Really could use some advice here. I suspect the battery is more or less staying charged while on the touchstone, and that this is something related to bad reporting or (worst case) a defective tablet.

Thanks for any help.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-06-16-22-31-59.png
Views:	48
Size:	86.0 KB
ID:	2802833  
 
 
18th June 2014, 05:51 AM |#2  
OP Junior Member
Thanks Meter: 1
 
More
Just a quick update. Shutting off the touchpad before leaving work, during the shutdown process, I saw the battery % drop from 100 to 0. As I was getting out the touchpad at work and turning it on, I got the battery-with-question mark symbol. Placed it on the touchstone and it booted itself. I decided to take it to recovery, and pulled it off the touchstone. Now, as I watch, the battery is changing % wildly. 100%, 29%, 0%, 67%, back to 100%, 0% again...


Really don't know what's going on. Did not have this happen on CM9. Could really use some help.

Edit: I just threw on a random game while off the touchstone to see what happened. Everything seemed normal, battery ran down to 93%. Exited the game, turned off the screen, and two seconds later it was shutting itself off with 0% battery. Immediately turned it back on, and it shows 93% again.
Last edited by dethzord; 18th June 2014 at 06:31 AM.
21st June 2014, 02:46 PM |#3  
seboj's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 51
 
More
Did you do a clean install? Does the issue persist after reflashing?
21st June 2014, 04:32 PM |#4  
OP Junior Member
Thanks Meter: 1
 
More
Fresh install, used tptools to wipe and repartition the tablet, no WebOS, CM11 only. Reflashing A6 didn't help.
23rd June 2014, 03:10 AM |#5  
OP Junior Member
Thanks Meter: 1
 
More
Still unresolved, possible more problematic.

I rotated my tablet from landscape to portrait and back (while on the touchstone) and it decided to shut itself off.

If anyone knows of/has similar issues (fixable or note), I'd really like to hear about it. Will be disappointed if it's dead, but it's better than spinning my wheels on it for something I can't resolve. If I have to buy a new tablet, I'd like to get it over with.

Edit:

Been a bit since I posted this, but I let the tablet sit for a bit. The battery stats are pretty crazy. Note that I've left it on the touchstone this entire time. I don't get why it's doing what it's doing at all. See newly attached screenshot.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-06-22-23-53-07.png
Views:	33
Size:	136.0 KB
ID:	2813059  
Last edited by dethzord; 23rd June 2014 at 07:57 AM.
24th June 2014, 12:43 AM |#6  
Senior Member
Thanks Meter: 12
 
More
there are 2 possibilities
1. your battery is ****ed, hardware issue, you cant fix unless you replace the battery
2. software issue, but from what you described, seems like you installed properly, so i would suggest to boot into webos (u gonna have to reinstall it), and use it for a few days to see if you get the same problem
- if you do get the same problem, then it's 100% ur battery is ****ed
- if no, then ur cm11 is messed up, try another rom
24th June 2014, 02:51 AM |#7  
OP Junior Member
Thanks Meter: 1
 
More
Ah well. Was hoping I might be able to fix it without any wipes.

I would think if the ROM itself was the issue, others with jcsullins' CM11 would have problems as well. Looks like that's not the case at this point. Perhaps I'll just retired the tablet and get a laptop.

Thanks for the input.
27th January 2015, 08:51 AM |#8  
Member
Thanks Meter: 8
 
More
Hi, did you get anywhere with this?

I've got occasional battery percentage glitches on Jcsullins CM11 that I didn't get with the previous WebOS/CM9 setup. See attachment.

Sadly I don't have the time or motivation to launch a huge investigation by flashing ROMs, etc... Looking like I'll just restore WebOS and sell.
Attached Thumbnails
Click image for larger version

Name:	Touchpad-Battery-Glitch-01.png
Views:	18
Size:	27.1 KB
ID:	3136074  
27th January 2015, 09:14 AM |#9  
OP Junior Member
Thanks Meter: 1
 
More
At this point, I can't get the thing to boot. I've had it on a charger for a month or two now. I've got the blinking home button. It booted once, but I wasn't in a position to hook it up to a computer and try to wipe it. I've not really put any energy into fixing it since.

I plan on getting it back on the touchstone at some point, and setting it next to my PC. If I ever get it to boot, I'm going to try to get webos back on it first thing, and go from there.
27th January 2015, 11:13 AM |#10  
Member
Thanks Meter: 8
 
More
Thanks for the reply. I'm questioning the amount of time I'm spending tinkering with this 3.5 year old device when new tablets are so cheap.

Touchpads are still making a reasonable amount on eBay so sadly I think it's time to just restore webOS and move on. Shame because it runs 4.4 pretty well, at least as good as my Galaxy S3.
Post Reply Subscribe to Thread

Tags
android, battery, touchpad
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes