FORUMS
Remove All Ads from XDA

[Soluition][New][First in XDA Latest Camera Fix By Ajeesh.C.R

58 posts
Thanks Meter: 35
 
Post Reply Email Thread
8th December 2014, 09:39 PM |#51  
Senior Member
Thanks Meter: 46
 
More
I replaced the zimage of the ported rom boot.img with my stock zimage from my stock boot.img

i added the lines like u said with notpad++ and repacked the port boot.img with the added lines and my stock zimage
i changed the libs files like you mentioned
after flashing the rom .... bootloap
i tryed to just add that lines on my stock boot.img and changed the lib files
it booted but the camera still dont work
any help plz ???
 
 
13th January 2015, 11:34 AM |#52  
Member
Flag Pune
Thanks Meter: 13
 
More
@op kash kernel solves the issue of camera on jellybean but on discovery rom and on cm11 nexgen it does not.
Can you please confirm that this works on kitkat roms with new kernel?
29th January 2015, 09:21 AM |#53  
Junior Member
Thanks Meter: 0
 
More
Unhappy Plz Fix this boot img
M using CM 11 rom on my a116i. And the camera isnt working . Plz fix this boot img
29th January 2015, 05:07 PM |#54  
Senior Member
Flag Pune
Thanks Meter: 748
 
Donate to Me
More
Quote:
Originally Posted by KvTheGamer

M using CM 11 rom on my a116i. And the camera isnt working . Plz fix this boot img

This Guide will work only on JB based ROMS.... Camera Hardware in A116 is old and A116i uses new one.... So Wait for the Fix........ No Guides or Patches for it!

Regards
Andy
21st August 2016, 10:11 AM |#55  
Junior Member
Thanks Meter: 0
 
More
Need sol for Ios9 ROM
Hello, Felix here,, right now I'm using the ios 9 ROM on chd I, let me know the directory for boot .IMG....
12th September 2016, 04:21 AM |#56  
Senior Member
Flag Erode
Thanks Meter: 16
 
More
Quote:
Originally Posted by ajeeshcr20

Hai dear frndz this is my first post in XDA

My Name is Ajeesh From Kerala

This solution Found by me (its My 2 weekz work) and i wl give diz solution for XDA users Good luck

if you faced new roms camera problem

Plz follow this steps i am 1000 times sure this guide Fix your NEW CAMERA PROBLEM

First edit your boot.img

1, extract the boot.img from Port ROM. Copy n past zimage file stock to port boot extracted folder

2, open ramdisk folder in boot extracted folder and find "init.project.rc" file

3, Open "init.project.rc" file in notepad++

4, Add this lines under the 'chown system system /dev/wmtWifi' (Very Important view attached image b4 editing)



#Camera
chmod 0660 /dev/OV8825AF
chown system camera /dev/OV8825AF

chmod 0660 /dev/OV8825TRULYAF
chown system camera /dev/OV8825TRULYAF

chmod 0660 /dev/OV8826AF
chown system camera /dev/OV8826AF

5, save and repack ur boot.img

6, Open stock system\lib\ folder

6, Copy this lib files stock to port

libcamalgo.so
libcamera_client.so
libcamera_metadata.so
libcameracustom.so
libcameraservice.so

Done itz 100000000% Fix your new camera problem i port a116 roms to a116i but camera not working. after i try diz solution camera working properly

Thankz Fendz Happy Porting
If i helpd u plz say juz a thankz

Sir this method used to camera fix it after my phone port ROM booted but not in os only show [oppologo]
Post Reply Subscribe to Thread

Tags
camera, camera not working, dark camera, fix

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes