Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Canadian/Claro PR D801/803] Development

OP omegajester

9th January 2015, 09:38 PM   |  #671  
Dene_Bluesman's Avatar
Senior Member
Flag Northwest Territories, Canada
Thanks Meter: 100
 
301 posts
Join Date:Joined: Nov 2013
More
Quote:
Originally Posted by tak.japan

Just got my G2, and am kinda confused to see that Canada got its own variant.
Looks like I have to take an extra step when installing a new rom? Will it work with Rom from any variant as long as I install the Kernel? If so, which variant is the hottest??

I would be careful there, if you plan on porting roms, try and stick with D802 and yes you need a kernel, however thats for ports
Most custom roms support our beloved D803 now anyway so really no need to port. So find a rom you like and most like a D803 variant will be available.

the hottest atm are lollipop roms. Currently running AICP nightlies. There is an extra step as lollipop roms are based on JB sources and require a JB baseband(radio, modem) for rotation to work. Be sure to bavk up efs when missing with basebands and stick with D803. Good luck. cheers

Sent from my LG-D803 using Tapatalk
9th January 2015, 10:35 PM   |  #672  
Senior Member
Thanks Meter: 2
 
317 posts
Join Date:Joined: Oct 2007
Quote:
Originally Posted by Dene_Bluesman

I would be careful there, if you plan on porting roms, try and stick with D802 and yes you need a kernel, however thats for ports
Most custom roms support our beloved D803 now anyway so really no need to port. So find a rom you like and most like a D803 variant will be available.

the hottest atm are lollipop roms. Currently running AICP nightlies. There is an extra step as lollipop roms are based on JB sources and require a JB baseband(radio, modem) for rotation to work. Be sure to bavk up efs when missing with basebands and stick with D803. Good luck. cheers

Sent from my LG-D803 using Tapatalk

oh so, if they list D803 as supporting device, I don't have to flash the Kernel? good to know!
11th January 2015, 11:31 PM   |  #673  
Senior Member
Flag Ottawa
Thanks Meter: 113
 
320 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by tak.japan

oh so, if they list D803 as supporting device, I don't have to flash the Kernel? good to know!

Generally if there's a d803 specific download for the rom you don't need to flash a separate kernel. If not you can sometimes flash the d802 version of the rom then flash a d803 compatible kernel.

Sent from my LG-D803 using XDA Free mobile app
19th January 2015, 09:21 PM   |  #674  
gaganmohal's Avatar
Senior Member
Flag TORONTO
Thanks Meter: 63
 
242 posts
Join Date:Joined: Aug 2013
More
Whenever i try to restore my stock g2 firmware backup all partitions including boot, system, efs,modem using twrp, phone gets stuck at LG logo and doesnt boot. What could be wrong? Is it because autorec downgrage my bootloader to jb?
How can i upgrade my bootloader to kitkat without flashing stock firmware?

Currently running AICP 5.0.2 rom on but wants to go back to stock.

Thanks
Last edited by gaganmohal; 20th January 2015 at 11:52 AM. Reason: 9
20th January 2015, 06:27 PM   |  #675  
Senior Member
Thanks Meter: 90
 
431 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by gaganmohal

Whenever i try to restore my stock g2 firmware backup all partitions including boot, system, efs,modem using twrp, phone gets stuck at LG logo and doesnt boot. What could be wrong? Is it because autorec downgrage my bootloader to jb?
How can i upgrade my bootloader to kitkat without flashing stock firmware?

Currently running AICP 5.0.2 rom on but wants to go back to stock.

Thanks

Do not upgrade bootloader - you can install any ROM you want by installing the correct radio/modem/baseband. Some ROMs need kitkat,while others need job baseband....but you don't need to upgrade the bootloader to so that.

It is a useless effort,with no benefits.
The Following User Says Thank You to sandys1 For This Useful Post: [ View ]
22nd January 2015, 12:10 PM   |  #676  
gaganmohal's Avatar
Senior Member
Flag TORONTO
Thanks Meter: 63
 
242 posts
Join Date:Joined: Aug 2013
More
Quote:
Originally Posted by sandys1

Do not upgrade bootloader - you can install any ROM you want by installing the correct radio/modem/baseband. Some ROMs need kitkat,while others need job baseband....but you don't need to upgrade the bootloader to so that.

It is a useless effort,with no benefits.

Well i tried flashing kk baseband and then restoring my stock backup from twrp but my phone doesnt boot. So i ended up flashing stock firmware .kdz file via LG flashtools.
Yesterday, 05:18 AM   |  #677  
Member
Thanks Meter: 24
 
73 posts
Join Date:Joined: Nov 2011
More
For anyone running Dorimanx's kernel, the OTA app now supports Videotron/Wind phones and their wonky naming.

Post Reply Subscribe to Thread

Tags
bell, claro pr, d801, d803, lg g2
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes