Post Reply

Does the Samsung LAN/USB Hub ET-UP900 work?

OP burningstep

16th October 2014, 11:44 AM   |  #11  
DeBoX's Avatar
Senior Member
Thanks Meter: 27
 
334 posts
Join Date:Joined: Jul 2010
thanks mate!

Really hope the info is legit

considering on ordering one now

Will let you know form firsthand exp when I get it

D
23rd October 2014, 10:23 AM   |  #12  
DeBoX's Avatar
Senior Member
Thanks Meter: 27
 
334 posts
Join Date:Joined: Jul 2010
Just got my brand new official Samsung USB lan/Hub. And..... it doesn't work. The usb part of it seems to wok ok, but it doesn't detect ethernet. The user manual wants me to go into the settings --> more networks-- Ethernet connections... BUT I have no such setting

planing on playing around for a little while longer, but sorry to say lads, it doesn't seem to work.

suggestions?
Last edited by DeBoX; 23rd October 2014 at 10:39 AM.
27th October 2014, 03:14 AM   |  #13  
DeBoX's Avatar
Senior Member
Thanks Meter: 27
 
334 posts
Join Date:Joined: Jul 2010
Seems that I atleast have hit a wall with regards to getting this to work. Anyone have any bright ideas? or dark ideas for that mater??

Anyone actually managed to get this to work?
22nd November 2014, 12:22 PM   |  #14  
atonal's Avatar
Senior Member
Thanks Meter: 102
 
336 posts
Join Date:Joined: May 2012
Ok, guys.....i think, you mean the adapter for Note pro? I got it, and it works. .... first, i bought this, cause it was the only USB adapter, that charge and using usb at the same time with p600........... and then i try to get Ethernet work. ...... the thing is, you have to know some things about ip4 connections, this is a kind different to wifi connections. ...... but i can offer you good news, the adapter works. The thing is, the firmware of p600/605 isn't modified to say the apps, they can connect to Internet with ethernet. ..
With the Adapter, the connection works, if you look to your router, you will find your device in Lan network. ......
What you need, are two things. ..... first, the app "ethernet" from play store (need root), that gives your device the right ip address, subnet mask and the gateway. .... (you don't have to do anything, just start the app, and press "enable")...... and the second one ist xposed framework and the module "hack connectivity", this little tool will say all apps to listen also to Ethernet Routing, not only wifi....... for me, this ,works like a charm, if i come to office, i plug the adapter in, with a wireless keyboard usb plug, Lan connected and also a cable to charge my note 3........ than i just enable the ethernet app, and change keyboard to my own for external keys (external keyboard helper), and that's all, so i have Lan Internet (4 times faster than wifi), have connection to my pc, and a external keyboard and mouse. ..... that's perfect. ....
If I'm finished, i plug the adapter off, and disable ethernet app, it changes automatically to wifi. ........

For generally information : Android already have ethernet drivers enabled from source, also in Samsung firmware, eth0 is working, the thing is, the apps are just programmed to listen to Wifi only. ....... don't know why, cause it's just one simple parser line to get this working.....
OK, on a mobile, it's not so interesting to havea Lan connection, but on a tablet, this will really good and fast. ....
Try this and habe fun. ... but i don't understand, why Samsung have the pins of the 10.1 204 so stupid organized, that all docking stations and usb adapters don't work with charging and usb at same time. .... the note 3 Multimedia Dock will not be detected as a dock. ....... that's so stupid. ....... shame on Samsung. ... if this was my company, i will fire the engineers at the same day if they make such a ****..........

Gesendet von meinem SM-P600 mit Tapatalk
The Following User Says Thank You to atonal For This Useful Post: [ View ]
13th December 2014, 05:47 AM   |  #15  
Jaytronics's Avatar
Senior Member
Flag Never thought this one was a good idea
Thanks Meter: 62
 
398 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by atonal

Ok, guys.....i think, you mean the adapter for Note pro? I got it, and it works. .... first, i bought this, cause it was the only USB adapter, that charge and using usb at the same time with p600........... and then i try to get Ethernet work. ...... the thing is, you have to know some things about ip4 connections, this is a kind different to wifi connections. ...... but i can offer you good news, the adapter works. The thing is, the firmware of p600/605 isn't modified to say the apps, they can connect to Internet with ethernet. ..
With the Adapter, the connection works, if you look to your router, you will find your device in Lan network. ......
What you need, are two things. ..... first, the app "ethernet" from play store (need root), that gives your device the right ip address, subnet mask and the gateway. .... (you don't have to do anything, just start the app, and press "enable")...... and the second one ist xposed framework and the module "hack connectivity", this little tool will say all apps to listen also to Ethernet Routing, not only wifi....... for me, this ,works like a charm, if i come to office, i plug the adapter in, with a wireless keyboard usb plug, Lan connected and also a cable to charge my note 3........ than i just enable the ethernet app, and change keyboard to my own for external keys (external keyboard helper), and that's all, so i have Lan Internet (4 times faster than wifi), have connection to my pc, and a external keyboard and mouse. ..... that's perfect. ....
If I'm finished, i plug the adapter off, and disable ethernet app, it changes automatically to wifi. ........

For generally information : Android already have ethernet drivers enabled from source, also in Samsung firmware, eth0 is working, the thing is, the apps are just programmed to listen to Wifi only. ....... don't know why, cause it's just one simple parser line to get this working.....
OK, on a mobile, it's not so interesting to havea Lan connection, but on a tablet, this will really good and fast. ....
Try this and habe fun. ... but i don't understand, why Samsung have the pins of the 10.1 204 so stupid organized, that all docking stations and usb adapters don't work with charging and usb at same time. .... the note 3 Multimedia Dock will not be detected as a dock. ....... that's so stupid. ....... shame on Samsung. ... if this was my company, i will fire the engineers at the same day if they make such a ****..........

Gesendet von meinem SM-P600 mit Tapatalk

Could you post a model number for the Note Pro adapter? I have been looking through Google and went to the Samsung site. I can not find it.

Sent from my SM-N900V
19th December 2014, 11:26 AM   |  #16  
Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Aug 2011
It is calles LAN/USB Hub ET-UP900.....
4th February 2015, 10:50 PM   |  #17  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2015
where can I find the module: hack connectivity?
Hallo Jaytronics
Quote:

What you need, are two things. ..... first, the app "ethernet" from play store (need root), that gives your device the right ip address, subnet mask and the gateway. .... (you don't have to do anything, just start the app, and press "enable")...... and the second one ist xposed framework and the module "hack connectivity", this little tool will say all apps to listen also to Ethernet Routing, not only wifi.......

I was wondering, where I can find the modul: hack connectivity? I was locking on the modules... I did not found it.... Can you tell me where it is...? and its exact name?

Thanks
5th February 2015, 12:32 PM   |  #18  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Oct 2014
I got this ET-UP900 adapter working with a SM-C115 by compiling a custom kernel. If you add the right drivers you can probably run use it with most devices.

During the build process of the kernel you run "make menuconfig". Here you select "Device Drivers" > "Network Device Support" > "USB Network Adapters". Include the "Multi-purpose USB Networking Framework" and "SMSC LAN95XX base USB 2.0 10/100 ethernet devices". If you add those as module you got to load them with "insmod mii.ko; insmod usbnet.ko; insmod smsc95xx.ko" in this order.

My current problem with this is that the device is not carging through the adapater. I guess there is another driver or option missing but I am still looking into this.
Last edited by pi_dev; 5th February 2015 at 12:35 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes