Post Reply

[Fix][N9005][ExtSdCard Write Issue][Kitkat 4.4.2][NA6] - Rooted

OP mateenf

8th December 2014, 07:19 AM   |  #161  
Senior Member
Thanks Meter: 9
 
337 posts
Join Date:Joined: Jul 2009
Quote:
Originally Posted by emad.ibrahim

after doing this fix ; it works only with ES Explorer; my Q. is for the original Note3 File manager " My File " will not have the permission to copy and paste on SD Card ? is that means i have to use 3rd party application only but the original file manager for note 3 will not have this permission??

My File can update the SD card without root or fix. Only third party applications need a fix.
8th December 2014, 02:22 PM   |  #162  
Senior Member
Thanks Meter: 53
 
101 posts
Join Date:Joined: Dec 2013
Question This fix doesnīt work on my device. Why?
I am trying to use the sdcard-fix on my Note 4, but still canīt get my ext. SD-card to be writable. I followed the instructions neatly, no typo, rooted, etc. but to no avail. Many months ago I already applied the same SD-card-fix on my previous phone (LG G2) - at that time it worked perfectly.

This is the setting how the platform.xml looks on my device:
<permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
<group gid="sdcard_r" />
<group gid="sdcard_rw" />
<group gid="media_rw" />
</permission>

Here is some further info that I gathered from Root Explorer . Maybe there is something not correct with those settings.
The owner of the "storage/extSdCard"-Folder is: Owner: 0 - root; Group 0 - root
The permissions of the "storage/extSdCard"-Folder are set to: 0771
The permissions for mnt/media_rw are set to: 0700

I tried to set the permissions for mnt/media_rw to 0744, which immediately after input gets displayed on the Root Explorer properly. But after a reboot it automatically goes back to 0700.

Any ideas what could be wrong here?
I just noticed that in the Note 4, storage/external_SD is called storage/extSdCard instead. Could that be causing the problem?
10th December 2014, 03:26 PM   |  #163  
Senior Member
Thanks Meter: 53
 
101 posts
Join Date:Joined: Dec 2013
Problem solved. My sd-card itself was faulty.
22nd December 2014, 03:03 AM   |  #164  
Senior Member
Thanks Meter: 73
 
615 posts
Join Date:Joined: Jun 2008
Donate to Me
More
I have answered this a long while ago in the S3 forums, but here is the TLR...

Boot to recovery.
Mount /storage/sdcard1

adb shell
cd /storage/sdcard1
chown -R 1023:1023 .


Problem solved.

You can also do it on any Linux machine or VM, probably the ext filesystem driver for Windows too.
1st February 2015, 05:27 PM   |  #165  
Junior Member
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jul 2013
More
Service No Bluetooth, not notification
Hello after I did, there is no Bluetooth and some other issue, like downloading from web... I reversed and I got back all.... but I still having the problem with the sdcard... I pass a video from my s4..play it ok... if I restart the tablet. .. is gone also with some other music carpet and per docs... please I need to fix it... I have only a week wit these sm-p607t and I haven't enjoy it.. I'm getting upset...

I have 4.4.2 rooted

Thanks and all the best

H
6th February 2015, 04:54 PM   |  #166  
Senior Member
Thanks Meter: 20
 
221 posts
Join Date:Joined: Mar 2011
guys I added this see enclosed.

I still cannot protect a specific backup on titanium back up.

Any idea how to solve this?

Thanks


Attached Thumbnails
Attached Thumbnails
Click image for larger version

Name:	Screenshots_2015-02-06-10-43-02.jpg
Views:	156
Size:	195.7 KB
ID:	3152865  
Post Reply Subscribe to Thread

Tags
externalsdcard, fix sdcard, kitkat, sdcard
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes