FORUMS

CloudPlayer: DIY HiFi Music Streaming Solution

In our Helpful Guide to Music Streaming Services, we mentioned several different services … more

Optimize Battery Life with This Useful App

Battery life is an important aspect of your smartphone, especially if you use it for more … more

The OnePlus 2 & The Year of Smartphone Compromises

We are very close to entering the last third of 2015, and we have now seen many of … more

OnePlus 2 Teardown, Major Android Vulnerability – XDA TV

The OnePlus 2 has been officially released. That and much more news is … more

[Q] {SOLVED} SIM Not read after flashing any Custom ROM

21 posts
Thanks Meter: 4
 
By danhughes1961, Junior Member on 21st January 2014, 01:58 PM
Post Reply Subscribe to Thread Email Thread
Hi All,

I've seen a few similar threads to this, but i can't find a clear cut answer so had to start a new one. The problem is whenever i try and flash a custom ROM, my SIM card is not able to be detected, no IMEI number or anything network related except Wireless.

It's not the SIM card, or the connection etc as i have tried a few different SIM cards and all with the same result. Whenever i revert back to stock ROM, the problem is resolved, so i think it's something to do with the custom ROM having some incorrect files for my phone region.

After digging through a few of the similar posts, i decided to take backups of the efs/modemefs directories from when my phone is working, then copied then into the system folder after i flashed the custom ROM (using Root Browser). However, this didn't make any difference.

Does anyone have any idea if there are some other files i need to copy, or if my method of copying is the issue ?

I'm back on stock ROM, so no problems with my phone, but it's really annoying i can't try new ones.

Many Thanks,

Dan
Last edited by danhughes1961; 27th January 2014 at 08:03 AM. Reason: solved
 
 
21st January 2014, 07:28 PM |#2  
AntaresOne's Avatar
Recognized Developer / Recognized Contributor
Flag Chieti
Thanks Meter: 14,651
 
Donate to Me
More
Do you have the model with NFC? GT-I9070P

Inviato dal mio GT-I9070
22nd January 2014, 02:25 AM |#3  
OP Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by Tesla-MADAL93

Do you have the model with NFC? GT-I9070P

Inviato dal mio GT-I9070

No, its the standard GT-I9070 -it's originally HK firmware and i've seen a few other threads knocking around on this so i'm not sure if it's specific to handsets in this region. It's very annoying though, the phone is not locked or anything, so i can't work out what the problem is
22nd January 2014, 01:41 PM |#4  
spleen1981's Avatar
Member
Thanks Meter: 13
 
More
Did you set right permission after restoring the efs backup folder?

Inviato dal mio GT-I9070 utilizzando Tapatalk

---------- Post added at 02:41 PM ---------- Previous post was at 02:38 PM ----------

Also take a look here:

http://forum.xda-developers.com/show....php?t=2317776

Inviato dal mio GT-I9070 utilizzando Tapatalk
The Following User Says Thank You to spleen1981 For This Useful Post: [ View ]
22nd January 2014, 03:14 PM |#5  
OP Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by spleen1981

Did you set right permission after restoring the efs backup folder?

Inviato dal mio GT-I9070 utilizzando Tapatalk

---------- Post added at 02:41 PM ---------- Previous post was at 02:38 PM ----------

Also take a look here:

http://forum.xda-developers.com/show....php?t=2317776

Inviato dal mio GT-I9070 utilizzando Tapatalk

Yes, i did set the correct permissions, in the end i followed another guide that had a nice little ADB script that copied the whole partition, directory structure and permissions - rather than using rootbrowser. Anyway, that made no difference but i've just read the guide in the link you posted and it sounds promising, i will try it out in a couple of days when i get a chance ad report back - thanks very much for that - it does seem like HK phones have this problem all the time. Cheers
23rd January 2014, 10:25 AM |#6  
OP Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by spleen1981

Did you set right permission after restoring the efs backup folder?

Inviato dal mio GT-I9070 utilizzando Tapatalk

---------- Post added at 02:41 PM ---------- Previous post was at 02:38 PM ----------

Also take a look here:

http://forum.xda-developers.com/show....php?t=2317776

Inviato dal mio GT-I9070 utilizzando Tapatalk

You are a saviour ! Sorted the problem, thanks given !!
23rd January 2014, 10:26 AM |#7  
spleen1981's Avatar
Member
Thanks Meter: 13
 
More
Good to hear that!

Inviato dal mio GT-I9070 utilizzando Tapatalk
23rd January 2014, 11:09 AM |#8  
OP Junior Member
Thanks Meter: 4
 
More
Yes, it was nothing to do with the EFS etc folders, it was all down to the tee folder as mentioned in the link you posted, something funny about handsets in this region. Anyway - thanks !
17th February 2015, 03:29 AM |#9  
Junior Member
Thanks Meter: 0
 
More
need urgent
Quote:
Originally Posted by danhughes1961

Hi All,

I've seen a few similar threads to this, but i can't find a clear cut answer so had to start a new one. The problem is whenever i try and flash a custom ROM, my SIM card is not able to be detected, no IMEI number or anything network related except Wireless.

It's not the SIM card, or the connection etc as i have tried a few different SIM cards and all with the same result. Whenever i revert back to stock ROM, the problem is resolved, so i think it's something to do with the custom ROM having some incorrect files for my phone region.

After digging through a few of the similar posts, i decided to take backups of the efs/modemefs directories from when my phone is working, then copied then into the system folder after i flashed the custom ROM (using Root Browser). However, this didn't make any difference.

Does anyone have any idea if there are some other files i need to copy, or if my method of copying is the issue ?

I'm back on stock ROM, so no problems with my phone, but it's really annoying i can't try new ones.

Many Thanks,

Dan



do you have HK firmware? can upload it in mediafire or 4shared or d-h.st or any downloadable sites ... please i really need it.. have same prob here.. cant fixed it cause cant download any ROM :3

---------- Post added at 03:29 AM ---------- Previous post was at 02:45 AM ----------

Quote:
Originally Posted by danhughes1961

No, its the standard GT-I9070 -it's originally HK firmware and i've seen a few other threads knocking around on this so i'm not sure if it's specific to handsets in this region. It's very annoying though, the phone is not locked or anything, so i can't work out what the problem is

can i have DL link for HK firmware?? samsung galaxy s adv. gt-i9070 ? downloadable link plss..

if posible in mediafire/4shared/d-h.st please
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes