FORUMS

[Q] Problems with Sprint HTC One On GSM

27 posts
Thanks Meter: 3
 
By relic626, Junior Member on 14th May 2014, 06:03 PM
Post Reply Subscribe to Thread Email Thread
Hi, I'd like to understand what's causing my current problems on my Sprint HTC One.
To make things clear I'm a noob.
Thing is i live in Trinidad and our carriers(Bmobile & Digicel) are both GSM, so i bought a Sprint HTC One android version 4.3 hboot 1.55.
I followed the procedures to Sim Unlock.
http://forum.xda-developers.com/show....php?t=2586704
I'm not entirely sure which step i used but it was either step 1 of step 2 that I used before using step 3. Keep in mind that I never downgraded the rom yet but went ahead with the first 2 steps anyway.(Not sure if it cause the problem)

When I make a phone call it lasts around 30 - 50 secs
Then I get a No Sim card sim error, I believe.(It flashes very quickly)
I lose signal and when i get it back i get the SuperSU root access prompt.

"Phone(1001)"
"com.android.phone"

When I grant or deny it, I get.
"chmod 666 /sys/subsystem_restart_properties/subsystem_restart_reason_nonblock"


I've followed the post from xerxes1987 on this guide with hopes to fix the dropping issue but it didn't work, i'm not 100% sure I did the correct thing though.
http://forum.xda-developers.com/show....php?t=2647305

I'm currently S-on hboot 1.56
Running the stock rom Sprint_HTC_One_m7wls_4.06.651.4_RUU with equivalent firmware.

Can any one help, its a pain not being able to hold a conversation.
I haven't made a nandroid backup i only heard about it after doing the sim unlock. Yes, a noob i am.
Would gladly make a donation for a proper fix.
Desperation is kicking in.
 
 
19th February 2015, 08:50 AM |#2  
Junior Member
Flag Shanghai
Thanks Meter: 2
 
More
Looks like it is a kind of way to check if your device is rooted or not.
Try "chmod 644 /sys/subsystem_restart_properties/subsystem_restart_reason_nonblock"
I bought a hTC 801e recently, and I rooted it few days ago. After I rooted it, the Phone app began to ask for the root clearance. I denied it because I thought it was quite weird, why the Phone app needs root? Then I searched about that file and I saw lots of people said when they give the Phone app root clearance, they all got a "no signal" error.
Sorry for my bad English, and hope that command will help.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes