Post Reply Subscribe to Thread

Boot/Recovery repack utils for WINDOWS

12th January 2015, 04:04 PM   |  #81  
michfood's Avatar
OP Senior Member
Thanks Meter: 272
 
194 posts
Join Date:Joined: Oct 2009
Donate to Me
2 all:
1. my scripts are free of charge and can be distributed without my prompt (only my scripts - there are another free utilities which I used)
2.. it will not be supported - they are "as is" - i`ve no time to improve it or to make changes for your needs
3. you are free to make all necessary changes for your own

goodluck ))
Last edited by michfood; 12th January 2015 at 04:06 PM.
The Following User Says Thank You to michfood For This Useful Post: [ View ]
12th January 2015, 10:51 PM   |  #82  
Tech N You's Avatar
Senior Member
Unknown Land
Thanks Meter: 328
 
587 posts
Join Date:Joined: Jul 2014
More
Quote:
Originally Posted by michfood

2 all:
1. my scripts are free of charge and can be distributed without my prompt (only my scripts - there are another free utilities which I used)
2.. it will not be supported - they are "as is" - i`ve no time to improve it or to make changes for your needs
3. you are free to make all necessary changes for your own

goodluck ))

Thanks a lot michfood
The Following User Says Thank You to Tech N You For This Useful Post: [ View ]
16th February 2015, 03:25 PM   |  #83  
exodius48's Avatar
Senior Member
Flag Hatinya Nabilah
Thanks Meter: 123
 
910 posts
Join Date:Joined: Apr 2013
Donate to Me
More
@michfood can you help me, I get this error message while unpacking



MTK6592 phone.
19th February 2015, 06:11 AM   |  #84  
michfood's Avatar
OP Senior Member
Thanks Meter: 272
 
194 posts
Join Date:Joined: Oct 2009
Donate to Me
try v4 from 1st post - it new one - win8 x64 support added
Last edited by michfood; 19th February 2015 at 06:13 AM.
19th February 2015, 09:20 AM   |  #85  
Senior Member
Thanks Meter: 152
 
776 posts
Join Date:Joined: Oct 2007
Can I propose an update about the file included in v4 of your utils?

Cygwin 1.7.34-6 DLL: http://www75.zippyshare.com/v/sc6RpabP/file.html
Swiss File Knife 2.7.4: http://sourceforge.net/projects/swis...4.exe/download

Cygwin can fix some strange eeror in recent PC with high speed processor.
Swiss File Knife include in the batch (1.6.6) is quite old.

If you can please rename in your batch sfkxxx.exe (xxx=version) to sfk.exe.
In this way is possible to update Swiss File Knife without touching the batch.
19th February 2015, 09:26 AM   |  #86  
michfood's Avatar
OP Senior Member
Thanks Meter: 272
 
194 posts
Join Date:Joined: Oct 2009
Donate to Me
What kind of error?
Swiss file knife does its work good so i don't think it needs updates.
19th February 2015, 09:34 AM   |  #87  
Senior Member
Thanks Meter: 152
 
776 posts
Join Date:Joined: Oct 2007
I had some error running previous version of your kit (v2) on same recent processor (ex. i7).
For that I updated the cygwin library. I believe that if the author of

Cygwin
Swiss File Knife
Mkbootimg

released an update I think that can be some problems that we didn't test in some conditions, but it can be present in some other conditions. For this reason I believe that if there are some updates (because the author think that was necessary) should be right to use it.
I checked also that mkbootimg included in the package was of 15.01.2015 and on Bruno Martins GitHub repository is available 15.02.2015 version (and I believe that if we released it it mean that was necessary).
19th February 2015, 01:15 PM   |  #88  
michfood's Avatar
OP Senior Member
Thanks Meter: 272
 
194 posts
Join Date:Joined: Oct 2009
Donate to Me
may be You are right
but sometimes updates do not fix bugs - only bring us new functionality...
anyway - I do not trace this software for updates, so everybody can upgrade scripts if needed on their own - it`s very simple to do
19th February 2015, 02:18 PM   |  #89  
Senior Member
Thanks Meter: 152
 
776 posts
Join Date:Joined: Oct 2007
Just an info for you.
cpio works fien with Cygwin 1.7.33 (provided with your kit).
cpio didn't work wityh cygwin 1.7.34-6 (newest).

I replaced mkboot.img with new version and it worked.
I replaced sfk with new version (1.7.4) and it worked.

I have question about use of ">>NUL" in some batches. Why that's it (and not >NUL)?
19th February 2015, 02:41 PM   |  #90  
michfood's Avatar
OP Senior Member
Thanks Meter: 272
 
194 posts
Join Date:Joined: Oct 2009
Donate to Me
Quote:
Originally Posted by bovirus

Just an info for you.
cpio works fien with Cygwin 1.7.33 (provided with your kit).
cpio didn't work wityh cygwin 1.7.34-6 (newest).

I replaced mkboot.img with new version and it worked.
I replaced sfk with new version (1.7.4) and it worked.

I have question about use of ">>NUL" in some batches. Why that's it (and not >NUL)?

ok if You want....
cpio and few other *.exe are just a part of cygwin - so if You replace *.dll to upgrade cygwin version - You also need to replace these files with newer.
mkbootimg.exe in v4 is compiled by Bruno, in previous versions - I do not remember where I got it. all of them - work fine - I don`t see any reasons why they don`t
as well as SFK - I guess all it`s versions would work - so there is no reason to update it. mkbootimg and sfk do not depend on cygwin.
>> or > - whatever

ps - sorry - need to add - "null" NOT equal "nul" (!) - if NULL is written - where would be created file named "null". and "nul" - will redirect output to null device (wil not show text result of command execution)
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	60
Size:	40.0 KB
ID:	3173507  
Last edited by michfood; 19th February 2015 at 02:55 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes