Post Reply Subscribe to Thread Email Thread

Serioux HD TAB S805TAB

15th June 2014, 02:28 PM |#1  
MadK9's Avatar
OP Senior Member
Thanks Meter: 27
Hello everyone!

I'm new arround and I came here hoping to solve some stuff regarding this tablet.
It is sold in Romania under SERIOUX brand:

I have a model with A10 ALLWINER, not ROCKCHIP. They had problems with the chinese manufacturer and decided to build it with rockchip.
I'm stuck at original ROM, I have no CWM, tablet is rooted, default browser is horrible, even with opera or any other browsers... I have this big lag when loadind web pages and this should not be normal... There is no such problem as low wifi signal or any other hardware stuff, no, it is just imossible to surf the web...
It has Android 4.0.4.
I made a request to this vendor, importer, SERIOUX, for another firmware but they only provided me the stock rom last year... which I already mention it, it is HORRIBLE!!! I never heard from them since then so I'm stuck with this rubbish stock ROM.
Tried to find a simmilar product on the web, I even made some attempts to install some ROMs but without a succes... either camera not working, or touch or wifi and so on... I don't know what to do.

Don't want to buy another product because the tablet belong to my daughter and is in the learning process so... I am gonna still hold on to it, but I need some help getting it better!!!

The site which sell a tablet simmilar to mine is KOCASO from USA... tried their ROM but no luck.
I even sent them an email but no answer from them more than six months or so...

Thank you in advance for anyone who can lend a hand in this matter!

Attached Thumbnails
Click image for larger version

Name:	Specification.jpg
Views:	65
Size:	226.1 KB
ID:	2799609  
Attached Files
File Type: zip - [Click for QR Code] (1.5 KB, 23 views)
Last edited by MadK9; 15th June 2014 at 07:36 PM. Reason: misspelling...
22nd February 2015, 02:21 PM |#2  
Junior Member
Thanks Meter: 0
Same tablet here... same problems as him... but... i have one special one ... HOW DO U HARD RESET THIS &%&%&% Tablet?
A neighbor of mine has the same one and used a patern lock on it.... dosen't remember the password of the Gmail account...
That RESET button dosen;t work... it;s just as a restart button... nasty one thow... and i donlt have a CWM installed on it to reset it from recovery ( Volume + and Power buttons)

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes