FORUMS

What Do You Think About Fingerprint Scanners?

More and more phones are featuring fingerprint scanners, and with many promising … more

What’s Next for Samsung and Its Flagships?

If we were to say that the Galaxy S6 was a leap of faith made by Samsung, we … more

The Ultimate Showcase of dBrand Skins

In the search for ways to protect, accessorize, and personalize; a user has many options. One … more

Huawei’s Rapid Rise to Third Place in the Smartphone Race

Huawei has quickly grown to become one of the world’s biggest … more

[Q] Black screen but charging led lights up

6 posts
Thanks Meter: 1
 
By snooze1973, Junior Member on 20th May 2014, 10:31 AM
Post Reply Subscribe to Thread Email Thread
20th February 2015, 04:10 AM |#11  
Member
Flag Noida
Thanks Meter: 31
 
More
Unhappy Black screen but charging led lights up
I am experiencing the same issue.
I bought a dead moto g for part replacement with my current moto g. Just out of curiosity, I plugged in the charger to the newly arrived moto g and observed the similar behavior.

To go further, I swapped the battery and tried to turn it on, and voila, it boots!! It has C-ROM. But it won't charge the battery any how. Its again back to
original behavior : No Screen, No Battery Charging, Only notification LED glows. I kept it on charger for whole night, but no luck.

The notification LED turns on even if I the battery is removed and charger is plugged in. What does that really mean?

Is there a probability that the charging circuit is broken? or it has something to do with bootloader, C-ROM and custom kernel? Does any one thinks reverting back to Stock ROM will help out in any way?
 
 
27th February 2015, 08:32 PM |#12  
Member
Thanks Meter: 3
 
More
Unhappy Same here...
Exactly the same with my little brother his Moto G 4G (1st gen) (stock rom, BL unlocked & rooted).
Solid white LED when plugged in, no other response.

The most advertised trick does not work (step 6: flashboot screen doesn't show up)
Quote:

Q28: Moto G will not power up (addition to Q16 and Q25)

  1. Plug it into the charger
  2. Hold the VOL DOWN key
  3. While still holding the VOL DOWN key, press and hold the POWER key
  4. Hold both keys down for over 120 seconds. This is more than two minutes and will seem like a long time. You might want to time yourself to make sure you hold it longer than two minutes.
  5. After holding the keys down for more than two minutes, release them.
  6. The Flash Boot screen will display, and the Normal Reboot option will be highlighted
  7. Press the VOL UP key and the device will start a normal reboot.
If you have tried the above and it didn't work, try this:
  • Plug in the phone for 15 minutes.
  • Proceed to Step 2 above.

(source: http://forum.xda-developers.com/show....php?t=2537119)

It has been an hour on the charger of my Asus T100 Tablet (5V, 2A). Still no luck...

Due to the lack of other solutions, I guess all our phones are ready for RMA...

Update: an overnight charge on a 5V 1A charger did the trick. White led was gone this morning, booted normally.
Last edited by JoWannes; 28th February 2015 at 07:57 PM. Reason: Update
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes