FORUMS

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

CleanSlate Brings Fingerprint Scanner Mod to HTC One M9+

Work of XDA Recognized Developer tbalden, CleanSlate custom kernel for the HTC … more

Galaxy S5 USB3 - or not!

106 posts
Thanks Meter: 19
 
By markymarkis, Senior Member on 19th April 2014, 04:37 AM
Post Reply Subscribe to Thread Email Thread
Hi,
I've tried using a USB3.0 cable but my system still says its only running at high speed (usb 2) not super speed (usb3)
same results with mac os and windows 8.1

windows: using usbview on windows as documented here :
http://blogs.msdn.com/b/usbcoreblog/...uperspeed.aspx

mac: using system information.

is this a firmware limitation or is it happening with every unit?
 
 
19th April 2014, 04:01 PM |#2  
altimax98's Avatar
Senior Member
Flag Mulberry, Florida
Thanks Meter: 571
 
More
There should be a setting in the storage area to enable USB 3.0. By default it will always initially connect at 2.0 unless that toggle is flipped

Sent from my Nexus 10 using Tapatalk
20th April 2014, 12:08 AM |#3  
OP Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by altimax98

There should be a setting in the storage area to enable USB 3.0. By default it will always initially connect at 2.0 unless that toggle is flipped

Sent from my Nexus 10 using Tapatalk

does anyone know where to find that toggle?
20th April 2014, 12:25 AM |#4  
altimax98's Avatar
Senior Member
Flag Mulberry, Florida
Thanks Meter: 571
 
More
Quote:
Originally Posted by markymarkis

does anyone know where to find that toggle?

Itll be on the USB PC connection screen. Plug your S5 into the PC and tap the notification that should say Connected as MTP. Itll bring you to the screen with the selection. Itll have to be enabled each time you connect the cable from what I know
20th April 2014, 12:31 AM |#5  
OP Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by altimax98

Itll be on the USB PC connection screen. Plug your S5 into the PC and tap the notification that should say Connected as MTP. Itll bring you to the screen with the selection. Itll have to be enabled each time you connect the cable from what I know

I've never seen that option, if i plug in the usb cable then go to notifications and click "connected as a media device"
when i tap it i get the option to connect as a media device (mtp) or camera (ptp)
and nothing else.
no other option, no menu.
20th April 2014, 12:47 AM |#6  
altimax98's Avatar
Senior Member
Flag Mulberry, Florida
Thanks Meter: 571
 
More
You are using a USB 3.0 cable and port with USB 3.0 drivers installed?

Especially the driver part

Sent from my HTC One_M8 using Tapatalk
20th April 2014, 12:51 AM |#7  
OP Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by altimax98

You are using a USB 3.0 cable and port with USB 3.0 drivers installed?

Especially the driver part

Sent from my HTC One_M8 using Tapatalk

of course.
22nd April 2014, 02:51 AM |#8  
OP Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by markymarkis

of course.

ok i have found the reason.
the Australian firmware (straight from samsung, not carrier related) is severely crippled.
it has usb 3 disabled completely.

i flashed the taiwanese firmware on my device and now under windows when i plug it in i get the usb3 option on the phone, when activated it works perfectly. mac osx doesn't work.

i can't believe how crippled the Australian firmware is, no auto rotate in gallery, not able to turn off shutter sound in camera, can't modify the dock. no camera on lock screen, no usb3 support, and probably more...
The Following User Says Thank You to markymarkis For This Useful Post: [ View ]
28th February 2015, 01:38 PM |#9  
Nightlight's Avatar
Senior Member
Flag Babylon 5
Thanks Meter: 69
 
More
Quote:
Originally Posted by markymarkis

ok i have found the reason.
the Australian firmware (straight from samsung, not carrier related) is severely crippled.
it has usb 3 disabled completely.

i flashed the taiwanese firmware on my device and now under windows when i plug it in i get the usb3 option on the phone, when activated it works perfectly. mac osx doesn't work.

i can't believe how crippled the Australian firmware is, no auto rotate in gallery, not able to turn off shutter sound in camera, can't modify the dock. no camera on lock screen, no usb3 support, and probably more...


I know this is an old thread but at least you managed to find a firmware that worked. I have a G900F with a USB3 port that I cannot use
cheers all!
Night...
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes