3G doesn't work on my HTC 8X!

7 posts
Thanks Meter: 0
By altinselimi, Junior Member on 14th June 2014, 09:49 PM
Post Reply Subscribe to Thread Email Thread
Hi all,

Im experiencing a problem where I'm not being able to connect to 3g using my mobile service even though it's activated.
With the same sim card, I get fast 3G internet on my other Samsung Omnia W wp7.8 handset.

I'm trying to find a setting to toggle fastest internet mode to 3G from 2G on my Windows phone 8x but there doesn't seem to be any.

Here are some screenshots of my Cellular+Sim option of my settings

Any help is geatly appreciated.

P.s : I'm running Windows Phone 8.1 Previews for developers latest update.
Attached Thumbnails
Click image for larger version

Name:	wp_ss_20140614_0004.png
Views:	231
Size:	53.9 KB
ID:	2798417   Click image for larger version

Name:	wp_ss_20140614_0003.png
Views:	215
Size:	109.6 KB
ID:	2798418  
17th June 2014, 04:31 PM |#2  
Senior Member
Thanks Meter: 268
Check your model info. I am guessing the 8X you have doesn't support the 3G bands you need for your country. On my T-Mobile US Branded device with 8.1 on it, the 1st screenshot you posted on my 8X has an option called "Highest Connection Speed" and on mine it is set to 4G.
3rd March 2015, 02:44 PM |#3  
Junior Member
Thanks Meter: 0
hey dude
Hey dude I've got same problem
This is my mail address lets find a way together for solve that problem
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes