CyanogenMod 12.1 for Android One

Android One devices once again got a pretty stable release of Android 5.1. XDA Recognized … more

DexPatcher: Patch Android APKs Using Java

You’ve probably seen or installed modified applications, be it a patched dialer for your … more

Is Cloud Storage Ready to Replace External Storage?

With more and more OEMs ditching SD cards on their flagships, cloud storage is … more

Customized Ultra Stamina for Xperia

XDA Senior Member androidexpert35 has provided us a customized Ultra Stamine Mode from the … more
Post Reply Subscribe to Thread Email Thread

Is my phone gone? Doesn't turn on, but vibrates

16th June 2014, 01:55 AM |#1  
OP Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Feb 2010
Hello all,

I have an S3, T-Mobile (T999). Yesterday while I was using it, it turned off by itself and now refuses to turn on. I have tried two different batteries and all it does is vibrates when I take the battery out and put it back in. I cannot get into recovery.

It was rooted and I had the PacMan ROM on it. To make things worse, the mcro-USB port is not functioning so plugging in into the computer doesn't do anything (I was using Anker wall-charging batteries to charge the phone).

Is my phone bricked somehow? Any troubleshooting tips?
16th June 2014, 05:12 AM |#2  
DocHoliday77's Avatar
Recognized Contributor
Flag HuntsVegas!!!
Thanks Meter: 6,561
 
9,195 posts
Join Date:Joined: May 2011
Donate to Me
More
Does it do anything other than vibrate? Does it sound like it comes on but the screen is just dead? Do you see anything happen on the screen? Unfortunately, without a functioning usb jack, theres not a lot you can do. Cant even flash the stock firmware....Only other thing you can try that I can think of is to find another S3 and swap the motherboards to test on a known good device.
16th June 2014, 05:15 AM |#3  
OP Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Feb 2010
Quote:
Originally Posted by DocHoliday77

Does it do anything other than vibrate? Does it sound like it comes on but the screen is just dead? Do you see anything happen on the screen? Unfortunately, without a functioning usb jack, theres not a lot you can do. Cant even flash the stock firmware....Only other thing you can try that I can think of is to find another S3 and swap the motherboards to test on a known good device.

Thanks for the reply DocHoliday. Today, after charging my Anker battery, it vibrated as usual but then I saw the Galaxy logo appear on the screen, but then it went away and the phone died again, so the screen is functioning.

I wonder if it is a battery problem; however, I have tried two different Anker batteries. I might try to find a stock S3 battery and try again. Will keep this thread updated.
16th June 2014, 04:08 PM |#4  
DocHoliday77's Avatar
Recognized Contributor
Flag HuntsVegas!!!
Thanks Meter: 6,561
 
9,195 posts
Join Date:Joined: May 2011
Donate to Me
More
Quote:
Originally Posted by M3GAPL3X

Thanks for the reply DocHoliday. Today, after charging my Anker battery, it vibrated as usual but then I saw the Galaxy logo appear on the screen, but then it went away and the phone died again, so the screen is functioning.

I wonder if it is a battery problem; however, I have tried two different Anker batteries. I might try to find a stock S3 battery and try again. Will keep this thread updated.

Does it try to turn on on its own when you put the battery in? If so it may be a power button issue. Either way, you might want to take it apart and make sure the button appears ok, and also check/reseat all ribbon connectors. Kinda doubtful its a battery issue, but I guess it is possible.
17th June 2014, 05:15 PM |#5  
alek889's Avatar
Senior Member
Flag San Juan
Thanks Meter: 209
 
319 posts
Join Date:Joined: Apr 2014
Wink
Did you try to go download mode or to the recovery (What ever u have)????...Just to know the reaction of the phone.If u can then is not hardware related
17th June 2014, 09:45 PM |#6  
OP Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Feb 2010
Quote:
Originally Posted by DocHoliday77

Does it try to turn on on its own when you put the battery in? If so it may be a power button issue. Either way, you might want to take it apart and make sure the button appears ok, and also check/reseat all ribbon connectors. Kinda doubtful its a battery issue, but I guess it is possible.

DocHoliday77,

I opened up the phone yesterday. The power button has no ribbon on it. It's connected to a simple surface mount push button. I tried pushing the button with the screw driver to rule out the actual button not making the proper contact, but it still wouldn't turn on. It still vibrates when I put in the Anker battery though.I think what I'll do today is test the voltage on the battery before putting it into the phone to make sure its not dead. Unfortunately, I could not find the stock battery that came with the phone.
18th June 2014, 07:35 AM |#7  
DocHoliday77's Avatar
Recognized Contributor
Flag HuntsVegas!!!
Thanks Meter: 6,561
 
9,195 posts
Join Date:Joined: May 2011
Donate to Me
More
Quote:
Originally Posted by M3GAPL3X

DocHoliday77,

I opened up the phone yesterday. The power button has no ribbon on it. It's connected to a simple surface mount push button. I tried pushing the button with the screw driver to rule out the actual button not making the proper contact, but it still wouldn't turn on. It still vibrates when I put in the Anker battery though.I think what I'll do today is test the voltage on the battery before putting it into the phone to make sure its not dead. Unfortunately, I could not find the stock battery that came with the phone.

I know the button has no cable attached, I meant for you to unplug and reseat all ribbon cables that are there. I think there are 3 or 4....maybe 5. There are disassembly vids you can reference though. As for the power button, it has been known to go bad. We've had it reported quite a few times around here in the past several months. Sometimes just jiggling it, or messing with it a little seems to help, otherwise itd have to be replaced. If you put the battery in, and the phone tries to power on without you pressing power, this is most likely the problem. From what you have said though, I doubt this is your issue. It could simply be memory going bad as well. I have seen a few reports of this. Unfortunately, short of replacing the motherboard, there is no fix for this.
Im, not saying that is the problem btw. Just a possibility.
The Following User Says Thank You to DocHoliday77 For This Useful Post: [ View ]
18th June 2014, 09:24 PM |#8  
OP Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Feb 2010
Thumbs up
Quote:
Originally Posted by DocHoliday77

I know the button has no cable attached, I meant for you to unplug and reseat all ribbon cables that are there. I think there are 3 or 4....maybe 5. There are disassembly vids you can reference though. As for the power button, it has been known to go bad. We've had it reported quite a few times around here in the past several months. Sometimes just jiggling it, or messing with it a little seems to help, otherwise itd have to be replaced. If you put the battery in, and the phone tries to power on without you pressing power, this is most likely the problem. From what you have said though, I doubt this is your issue. It could simply be memory going bad as well. I have seen a few reports of this. Unfortunately, short of replacing the motherboard, there is no fix for this.
Im, not saying that is the problem btw. Just a possibility.

I ordered a replacement button today. It would be another 'low-hanging fruit' possibility and it was only $3 for the button on eBay. I'll de-solder the old one off and solder the new one on. Will update this thread after doing so. It is a mechanical button, so I agree, it could have messed up some how.
9th March 2015, 03:10 PM |#9  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Mar 2015
hey even i have nokia x it doent on doesnt vibrate just like total dead what should i do batery is ok some problem while flashing it with me

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes