Post Reply Subscribe to Thread Email Thread

Battery drain in airplane mode (> 1%/hr)

15th February 2014, 12:36 PM   |  #91  
Senior Member
Thanks Meter: 127
 
487 posts
Join Date:Joined: Dec 2013
More
I gave it a try with wifi and location set to off tonight, dropped from 18 to 17% in 8.5h. Satisfied.
19th February 2014, 09:49 PM   |  #92  
OP Senior Member
Thanks Meter: 14
 
106 posts
Join Date:Joined: Jul 2011
See this: http://forum.xda-developers.com/show...php?p=50467389

Quote:

I turned airplane mode on, and left location services on. Battery drain was 2.8%/hr (measured over a 5% battery drain interval) with the phone only being awake for 7min 28sec when the screen was off. There were around 5min of NLP wakelocks, and some other miscelaneous ones. I don't think that explains the battery drain fully.

Then, I turned off location services, and the battery drain has been 1.7%/hr (measured over an 8% battery drain interval) with a total awake time of 5 mins, and of that only 1 min of awake time when the screen was off. Very few to no wakelocks.

What is wrong? Why is the battery draining at ~2%/hr with airplane mode on, location services off, and the phone being in deep sleep pretty much the whole time!?

4th March 2014, 04:01 PM   |  #93  
Junior Member
Thanks Meter: 2
 
8 posts
Join Date:Joined: Apr 2013
Dear iforgot and others,

This workaround helps you get rid of the drain:

Step 1. Disable location and reboot.

Step 2. Use your phone normally: you won't have a drain.

If you want to use location again, the drain will start. Regardless of whether you turn location off. You will need to perform step 1 again in order to get rid of the drain.
Last edited by Wizzie86; 7th March 2014 at 07:10 PM.
7th March 2015, 05:34 AM   |  #94  
Member
Thanks Meter: 2
 
34 posts
Join Date:Joined: Feb 2011
More
Any news after the update to Lollipop ??? Or is the location battery drain not software related at all ?
11th March 2015, 03:51 PM   |  #95  
Member
Thanks Meter: 2
 
34 posts
Join Date:Joined: Feb 2011
More
OK so I'm trying to keep my expectations low but there might be a chance the bug has gone away in lollipop.
Moto G 1st gen from amazon UK Dec 13
Did the lollipop update today and then I activated location high accuracy and opened google maps and ingress.
And the drain never happened.
Could be luck since the bug was intermittent.
More tests tommorow .

PS noticed very low battery usage on google services around 2%
11th March 2015, 09:14 PM   |  #96  
Junior Member
Thanks Meter: 2
 
8 posts
Join Date:Joined: Sep 2013
Quote:
Originally Posted by snowboard

OK so I'm trying to keep my expectations low but there might be a chance the bug has gone away in lollipop.
Moto G 1st gen from amazon UK Dec 13
Did the lollipop update today and then I activated location high accuracy and opened google maps and ingress.
And the drain never happened.
Could be luck since the bug was intermittent.
More tests tommorow .

PS noticed very low battery usage on google services around 2%

Could you post your battery stats?
11th March 2015, 09:27 PM   |  #97  
Senior Member
Thanks Meter: 68
 
324 posts
Join Date:Joined: Dec 2013
More
I still have drain but when I don't have it, I'm using around 10% less a day.
12th March 2015, 04:33 PM   |  #98  
Member
Thanks Meter: 2
 
34 posts
Join Date:Joined: Feb 2011
More
Here it is
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2015-03-12-17-30-02.png
Views:	46
Size:	81.9 KB
ID:	3207167  
16th March 2015, 09:29 PM   |  #99  
Member
Thanks Meter: 2
 
34 posts
Join Date:Joined: Feb 2011
More
So I think the drain happened again.
Probably will try to sell it and go for an lg.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes