FORUMS

HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

SystemUpdateService always on

61 posts
Thanks Meter: 4
 
By keeekeeess, Member on 29th June 2014, 02:57 PM
Post Reply Subscribe to Thread Email Thread
3rd July 2014, 06:49 PM |#21  
Junior Member
Thanks Meter: 13
 
More
For me only SystemUpdateService$SecretCodeReceiver had to be disabled. All other activities, receivers and services with a name starting with "SystemUpdate" were already disabled. I used ADB + "pm disable" to disable this one component.

Here is a list of commands to disable all SystemUpdate "stuff" via ADB (of course it requires a rooted phone with some sort of "su" installed):
Code:
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateActivity
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService$ActiveReceiver
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService$Receiver
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService$SecretCodeReceiver
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateActivity
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdatePanoActivity
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateService
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateService$Receiver
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateService$SecretCodeReceiver
Each of the above commands should print something like this:
Code:
Component {com.google.android.gms/com.google.android.gms.update.SystemUpdateActivity} new state: disabled
If it doesn't, it didn't work. Either because the command couldn't get root access (eg. you don't have any "su" installed) or your "Google Play services" or "Google Services Framework" doesn't have the given component (yet).
Last edited by bit2; 3rd July 2014 at 07:11 PM. Reason: added ADB commands
The Following 4 Users Say Thank You to bit2 For This Useful Post: [ View ]
 
 
4th July 2014, 06:03 AM |#22  
Senior Member
Thanks Meter: 653
 
More
Quote:
Originally Posted by mrfree2ita

I've the same issue here since 2/3 days on my 9001 running CyanogenMod 11.0 by ADC-Team - Release 8, maybe it was some app update occurred recently... I didn't have any issue with the same rom before.

---------- Post added at 10:29 AM ---------- Previous post was at 10:00 AM ----------

I can confirm that downgrading Google Play Services to version 4.3.25 is a working workaround.

http://forum.xda-developers.com/show...postcount=3026

Thanks. going to try this.

---------- Post added at 01:03 AM ---------- Previous post was at 12:59 AM ----------

Quote:
Originally Posted by Durocks

Best workaround I've found:

"Finally I was able to block the SystemUpdateService wakelock, using this app:
https://play.google.com/store/apps/d...com.rs.autorun
go to settings, enable the option to show system entries
find google play services and disable:
SystemUpdateService$Receiver
SystemUpdateService$ActiveReceiver
SystemUpdateService$SecretCodeReceiver
done... no more wakelock and it didn't break anything, syncs all work ok
I know this app doesn't look the best, but I tried others like "Android Tuner Free", "Disable Services", "Gemini App Manager", etc, but they allowed me to only disable the main service and didn't show the other receivers that had to be disabled."

As the other user said, this is all caused by the Google Play Services update that has being rolling out this last week. The solution above is reboot proof (At least for me). Thanks to the user who posted it.

This seems to be the most effective workaround short of downgrading Google Play Services however in my case it does not survive reboot and once today I had to toggle those three services on/off after deleting/recreating a Google account on the phone.
Last edited by IronTechmonkey; 4th July 2014 at 07:51 AM.
The Following User Says Thank You to IronTechmonkey For This Useful Post: [ View ]
9th July 2014, 09:56 AM |#23  
MarvinFS's Avatar
Recognized Developer
Flag Ekaterinburg
Thanks Meter: 10
 
More
Thumbs up
Quote:
Originally Posted by bit2

For me only SystemUpdateService$SecretCodeReceiver had to be disabled. All other activities, receivers and services with a name starting with "SystemUpdate" were already disabled. I used ADB + "pm disable" to disable this one component.

Here is a list of commands to disable all SystemUpdate "stuff" via ADB (of course it requires a rooted phone with some sort of "su" installed):

Code:
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateActivity
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService$ActiveReceiver
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService$Receiver
adb shell su -c pm disable com.google.android.gms/.update.SystemUpdateService$SecretCodeReceiver
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateActivity
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdatePanoActivity
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateService
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateService$Receiver
adb shell su -c pm disable com.google.android.gsf/.update.SystemUpdateService$SecretCodeReceiver
Each of the above commands should print something like this:
Code:
Component {com.google.android.gms/com.google.android.gms.update.SystemUpdateActivity} new state: disabled
If it doesn't, it didn't work. Either because the command couldn't get root access (eg. you don't have any "su" installed) or your "Google Play services" or "Google Services Framework" doesn't have the given component (yet).

I can confirm - working fine for me! Thank you for a solution
OnePlus One 64GB
CM11S - H25R
franco kernel r3
cracked market v4.8.20

had a constant wakelock of SystemUpdateServices
it was already disabled in DisableServices
haven't tied to downgrade the market - some say it also helps!
But your solution did the trick - no more wakelocks!

Is it possible it'll return somehow, i mean i wonder if those "pm disable" commands are consistent and can't be reversed by some other google service when needed!

PS CM's updater working fine!
The Following User Says Thank You to MarvinFS For This Useful Post: [ View ]
20th August 2014, 03:39 PM |#24  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Silkeyway

So just trying stuff without any deeper thoughts, I just did two things, locked the phone afterwards and now the wakelock seems to be gone:

1. I enabled SystemUpdateService using Disable Service App, which had already been disabled when we first looked.
2. I looked into the CM update function, where - having selected all stable releases - nothing was showing and refreshing didn't work. Got the idea to look into Disable Service App again, and found that UpdateCheckService of CyanogenMod-Updater was disabled. Enabled it, refreshed CM updater, got a list of stable releases.

My beginner's guess would be #1 did it - but why was #2 even an issue in the first place?

Thank you so much for this! I was getting 0% deep sleep for no apparent reason, and your #1 solved the problem.
9th March 2015, 06:53 PM |#25  
DanD911Phx's Avatar
Member
Flag Overland Park KS
Thanks Meter: 20
 
More
Info 2
Quote:
Originally Posted by Silkeyway

So just trying stuff without any deeper thoughts, I just did two things, locked the phone afterwards and now the wakelock seems to be gone:

1. I enabled SystemUpdateService using Disable Service App, which had already been disabled when we first looked.
2. I looked into the CM update function, where - having selected all stable releases - nothing was showing and refreshing didn't work. Got the idea to look into Disable Service App again, and found that UpdateCheckService of CyanogenMod-Updater was disabled. Enabled it, refreshed CM updater, got a list of stable releases.

My beginner's guess would be #1 did it - but why was #2 even an issue in the first place?

Found the same thing on PA5.0.alpha.2 on Nexus7 (flo) and pagapps from 03082015 .. catlog showed that package manager disabled SystemUpdateService early on in the boot process. My wakelocks went away after using DisableService app to enable SystemUpdateService manually.

On my SGH-1747 running PA4.6.beta5 and pagapps from 03072015, I chose to back down from the pagapps to get a GooglePlayServices without the bug, and played hell because the data for many of the gapps had entries that confused the older gapps. Sure wish I had a nand backup to go to, but I stupidly didn't create one. After manually flushing data for the apps that did FC, I think I'm okay until Google fixes the problem.
25th March 2015, 08:44 AM |#26  
Junior Member
Thanks Meter: 0
 
More
I found a solution for myself, that also stays over an reboot:
http://forum.xda-developers.com/gene...elock-t3060548

I just used Autorun Manager instead of Autoruns, because you can get the Manager as a free version that does the trick for this case.
10th April 2015, 03:10 PM |#27  
Senior Member
Thanks Meter: 29
 
More
to me, ever since I started playing around with disabling all services, I started suffering from RILJ constantly, all the time!
Any suggestions? Did it happen to anyone else?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes