[GUIDE] Root ASUS MemoPad FHD 10 Model ME302C US version 5.0.16

46 posts
Thanks Meter: 16
By intrepid24, Member on 13th April 2014, 07:37 PM
Post Reply Subscribe to Thread Email Thread
14th November 2014, 12:39 PM |#11  
Thanks Meter: 0
I just wanted to say:
I got the Memo Pad FHD 10: It lagged in slowness a bit in a few well known apps. Also when browsing the internet. Also the kicker for knowing I had to 'Root' was certain apps use the 'System font' for Chinese-Pinyin display. Asus-Memo Factory-font does not display accented characters well. But the standard setting do not allow adjustment to the System-font.

Your Easy instructions under: 'For those who are not rooted'... Were simple. I downloaded the two files... 5.0.16 (Although: Note I needed to rename, the 5.016, to exactly match what you said. The filename was slightly different.)

I was a little scared, even though I had already upgraded the firmware of my Tablet to 51.31, but another poster had that number as well, so I decided to boldly press-on.

Then I put the 5.017 and boom... and installed the SuperSU file as instructed... and a way I went! Thanx! Thankx! I put on HiFonts and found a font that was suitable for the system. The pad is also now so much snappier!!! I hope that doesn't mean the battery is now going to drain at an alarming rate. I haven't tested that yet. :
6th December 2014, 04:03 AM |#12  
Thanks Meter: 0
GPS Working 5017
Originally Posted by intrepid24

This post (#377 on page 38) was origina

Is anyone else having an issue with the GPS on the device on 5016 rooted with the 5017 using the 'intrepid' link above. A favorite app we use: 'Copilot', does not get past "determining position". I'm speaking of when the device does not have an internet connection.
The app I speak about is designed to work without only the GPS available. But since I'm on an odd build, instead of checking with the problems on those ends. I figured, I worry first about the build itself.
31st December 2014, 12:23 AM |#13  
Senior Member
Flag San Diego
Thanks Meter: 38
I know this may be quite an old thread, but I've stupidly updated my fathers tablet to 5.0.21, and in the process lost root. Is there any trouble with following this method to get back to 5.0.17 and rooting the tablet? After updating I saw no difference, and thus no need to lose root access.

Is there an alternative to getting root? I've tried towel root and framaroot but neither of these worked.
15th March 2015, 04:17 AM |#14  
Senior Member
Thanks Meter: 133
To this day this tablet has treated me well...Is there any kitkat roms floating around the web for this tablet?
13th April 2015, 03:31 PM |#15  
Junior Member
Thanks Meter: 0
asus memo pad me302c stuck on boot screen
Hi guys! I`m new on the forum so i don`t know if this is the right place to ask... I have this Tablet stuck on boot screen and i tried every solution i found on internet but nothing seems to make it work... Can someone give me a clue about what can i do? Thank you!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes