FORUMS

Analysis & Opinion

[Q] Slow charging on device

52 posts
Thanks Meter: 0
 
By ragingbull, Member on 13th March 2014, 09:23 PM
Post Reply Subscribe to Thread Email Thread
7th May 2014, 09:50 PM |#11  
daxdax89's Avatar
Senior Member
Flag Knjazevac
Thanks Meter: 25
 
More
1:30 to charge it fully for me,original sony adapter
 
 
8th May 2014, 07:51 PM |#12  
arcsuser's Avatar
Senior Member
Far Far Away
Thanks Meter: 25
 
More
Charges an hour and 30mns for me everything is original
Ps. This is a used phone got it from swappa

Sent from my C6906 using XDA Premium 4 mobile app
19th November 2014, 05:29 AM |#13  
Junior Member
Thanks Meter: 0
 
More
Unhappy uhuhuh
mine took 5 hours from 0% ~> 24%
19th November 2014, 08:04 PM |#14  
sucker for sony's's Avatar
Senior Member
Flag Sittingbourne
Thanks Meter: 178
 
More
My z1 charges fine if i dont let it get below 40%. If i let the battery drop down to around 10% it takes a long time to reach 40% and then charges normally. It doesn't matter what method i use for charging it still charges the same, one observation i did make though is that when charging from a low percentage up to around 30% the phone gets very hot so it might be a good idea if we don't cycle our phones batteries so low?
20th November 2014, 10:19 AM |#15  
Junior Member
Thanks Meter: 0
 
More
Unhappy
I bought this phone in september this year .. the first time I charge it only takes 3 hours to full from 18% ~ 100% .. but by now it takes 24 hours for the full amount of 8% ~ 100% (︶︹︺)
25th November 2014, 03:38 PM |#16  
Junior Member
Thanks Meter: 0
 
More
solution?
Quote:
Originally Posted by Spectre51

Not for me. I am having slow charging as well. Using official Sony magnetic cable I have tried a couple different power adapters from Sony including the EP880 and even over night it won't charge it completely. Last night I plugged it in with about 37% left...woke up this morning after about 7.5 hours and it was only at 78%. Have to plug it in via USB to get any decent charging speed.

Same problem here. Have you solved this problem? Thanks in advance.
25th November 2014, 05:02 PM |#17  
Spectre51's Avatar
Recognized Contributor
Thanks Meter: 1,361
 
Donate to Me
More
Quote:
Originally Posted by fmode68

Same problem here. Have you solved this problem? Thanks in advance.

Don't have the Z1 anymore but I never did figure it out. Was very sporadic when it happened.

Sent from my Xperia Z2
26th November 2014, 02:53 AM |#18  
Senior Member
Thanks Meter: 54
 
More
If you are really curious maybe grab one of these:
http://i1.minus.com/ibacLoylrDRNDe.jpg
Shows Volts and Ampere.
They are sold as "usb meter" in eBay/aliexpress for as low as $1.70 from China and actually work quite well.
Helps to easily spot a cheap cables(low ampere) or chargers(lots of varying voltage) that should go to the trash.
Last edited by user822; 26th November 2014 at 02:59 AM.
15th April 2015, 11:38 AM |#19  
ferbuffer's Avatar
Senior Member
Thanks Meter: 27
 
More
I updated to lollipop and this is happening to me now.
Before, I charge so fast, now on lollipop any charger I use is so slow even when turned off
it will take 7 hours to finish charging to 100%
Post Reply Subscribe to Thread

Tags
battery, faulty usb, repair, slow charging

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes