FORUMS

XDA Recap: This Week In Android (May 17 – 23)

Another week, another recap. The Sunday tradition marches on this week with a fresh … more

Huawei To Sell Honor Smartphones Via Indian Retail Outlets

World’s fourth largest smartphone maker Huawei plans to now sell its … more

Sunday Debate: Are Smaller Bezels Better or Worth It?

Bezels have been getting smaller and smaller as the years go by, and while devices … more

LG G4 First Impressions and Unboxing – XDA TV

The latest in LG’s signature line of “G phones” has been released. … more
Post Reply Subscribe to Thread Email Thread

Mega 6.3 won't charge!

13th May 2014, 08:55 PM |#11  
thering1975's Avatar
Senior Member
Thanks Meter: 1,669
 
Donate to Me
More
Samsung's charging ports are notoriously bad my old note had the same problem for a while a thicker charger worked then in the end it went off my repair a colleagues note did the same last month and his had to go for repairs it was a big prob with s2 s3 and notes

Sent from my GT-I9205 using XDA Premium 4 mobile app
 
 
14th April 2015, 05:09 AM |#12  
Junior Member
Thanks Meter: 0
 
More
Smile Hopsin444 Saved Me and My Phone.
Quote:
Originally Posted by hopsin4444

Its the charging port! I've had the same problem twice I guerente it!


Sent from my sgh-i527 with xda premium 4



HOPSIN-KAT KEYBOARDS IS NOW UP AND RUNNING CHECK EM OUT OVER AT THE CANDY SHOP!
http://forum.xda-developers.com/show...php?p=52221912

Okay, so I just this moment joined the forum JUST so I could thank Member hopsin444 for this advice. Just as he guaranteed, it was the charging port. After getting his advice, I downloaded the PDF User Manual for the Galaxy Mega (my phone). I did what another member suggested and unplugged the battery for 10 minutes (just to be safe). I plugged it back in, and used the brand new charger and cable that came with my phone. I had been using a different charger, so I wanted to get a brand new clean start. Sure enough, the battery started charging immediately, good as new. I must say that in order for this method to work, you must insure that all components are in working order: battery, charger, and cable connectors. Because, otherwise, it's hard to debug exactly which little part is the culprit for the problem.

Once again, thank you ever so much hospsin444. You saved me a lot of cash, trips to the repair shop, and untold headaches.`

Update: The phone charge from 66% to 70% and then stopped charging again. I'm thinking it's the little slot -- on the phone itself -- that the charger cable plugs into that is the problem. My only option now is to take the phone to get repaired. But my thanks to hopsin still applies. It was fun while it lasted.
Last edited by SoUthinkUcanText; 14th April 2015 at 06:01 AM. Reason: Needed to Update Orginal Post
16th April 2015, 06:17 PM |#13  
Junior Member
Thanks Meter: 0
 
More
Similar problem. . . . grey battery issue ( can get around by using reboot command either in download mode or stock recovery ) i have 2 batteries and one still has a charge, replaced usb port ( NEW BOARD - $15 on -ebay) but no love . . . . when i power off it sits there with the grey battery icon and kills the battery. it is NOT recognized by computer and does not recognize a charger ( i have lots and they are all good wires and blocks ) ordered a wall charger and can use it but no USB at all

Any help or ideas are welcome


fyi :
completely stock
never dropped, wet or abused just stopped working right!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes