FORUMS

HTC’s New Ad Campaign And What It Really Means

HTC has just released three new blind test adverts comparing app loading … more

XDA Picks: Best Apps of the Week (June 27 – July 4)

Apps are at the front and center of any smartphone experience, and with over a … more

HTC One M9 Developer Edition Android 5.1 OTA

The Developer Edition of the HTC One M9 is receiving an over-the-air update to Android 5.1. … more

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

[Q] "Allow USB Debugging?" Keeps Popping Up!

19 posts
Thanks Meter: 1
 
By pnuker, Junior Member on 25th January 2014, 03:26 PM
Post Reply Subscribe to Thread Email Thread
After upgrading to 4.3 on my i535 GS3, I'm now faced with a very annoying new problem. I use easytether pro to tether to my macbook, and now when I plug in the usb it pops up with "Allow USB Debugging?" followed by my computer's RSA key fingerprint, and then a checkbox for "Always allow from this computer".

It doesn't matter if I check the "always allow" because the next time I plug it in, it pops up with the same message again. For some reason it's not recognizing my computer, even though the RSA key fingerprint is exactly the same every time. Even worse, I have to go through this process twice every single time I plug in my usb - once for the usb connected as an installer, and twice when it switches from installer to media device.

I use tethering quite a bit, so this is kind of grinding my gears! Does anybody know what might be going on here? Is it possibly just a mac thing? Perhaps something wrong with my settings?
Last edited by pnuker; 25th January 2014 at 04:54 PM.
 
 
25th January 2014, 05:38 PM |#2  
buhohitr's Avatar
Senior Member
Thanks Meter: 1,649
 
More
Try this, In developer options ->root access - allow apps and adb also USB debugging notify is unchecked.

Sent from my Galaxy Nexus using xda premium
25th January 2014, 07:30 PM |#3  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by buhohitr

Try this, In developer options ->root access - allow apps and adb also USB debugging notify is unchecked.

Sent from my Galaxy Nexus using xda premium

I don't seem to have any "root access" options in my developer options. Is it hidden or something?
25th January 2014, 07:42 PM |#4  
buhohitr's Avatar
Senior Member
Thanks Meter: 1,649
 
More
Sorry I must be half sleeping and thinking about custom ROM. You don't have that option, anyway do you still have the messag after untick the notify option?

Sent from my Galaxy Nexus using Tapatalk
26th January 2014, 01:14 AM |#5  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by buhohitr

Sorry I must be half sleeping and thinking about custom ROM. You don't have that option, anyway do you still have the messag after untick the notify option?

Sent from my Galaxy Nexus using Tapatalk

You mean leave the "Always allow from this computer" unticked? I've tried both ways...it always comes back. It wouldn't be a big deal if it wasn't for the face that the connection is blocked until I hit the ok button, twice around.
6th February 2014, 03:15 AM |#6  
OP Junior Member
Thanks Meter: 1
 
More
Still having the issue. It's starting to grind my gears...

I nobody else having this issue?
14th May 2014, 07:36 PM |#7  
bmg002's Avatar
Senior Member
Thanks Meter: 193
 
More
Quote:
Originally Posted by pnuker

Still having the issue. It's starting to grind my gears...

I nobody else having this issue?

I just started having this issue and am investigating it. If I had to guess, I'd say the rsa key store is corrupt, but I'm just guessing. It was working fine this morning, and this afternoon it started yelling at me repeatedly.

I'm going to grab a logcat then will post back if/how I fixed it.

EDIT: turns out my issue was a bad USB cable. well, a bad USB cable connection. unplugged and reseated the cable and it seems to be working now.
19th November 2014, 01:21 PM |#8  
Junior Member
Thanks Meter: 2
 
More
I am also having this issue with two devices out of three I tried.

Samsung Note 10.1 (SM-P600) running Android 4.3 and ASUS K011 (ME181CX) running Android 4.4.2 always asks for permission. I tried everything including using different cables, different usb slots, different adb.exe. Even tried rooting K011, but no luck.

However, I am not having this issue with Sony Ericsson Xperia Arc (LT15i) running 4.0.4.

Edit: I came here from Google and now noticed that this is Galaxy S III section, but I think the reason to this issue and the solution will be the same. I will post the solution to here if I can do it.

---------- Post added at 03:21 PM ---------- Previous post was at 02:21 PM ----------

Yeah, solved it. I first killed adb.exe then simply deleted the folder C:\Users\Username\.android. After that I plugged my device in and typed "adb devices". This changed the RSA key etc. It asked for the permission again and "Always allow" option worked this time.

This method worked on both ASUS and Samsung. Hope this works for you too.

Note: I recommend you backup that folder before deleting it. Or just move it into another folder.
Last edited by nailgg; 19th November 2014 at 12:25 PM.
The Following User Says Thank You to nailgg For This Useful Post: [ View ]
30th April 2015, 03:20 AM |#9  
Junior Member
Thanks Meter: 0
 
More
Question Mac computer
I'm having this issue with easy tether 1.1.12 in a mac (currently running OS X Yosemite 10.10.3) the windows keeps showing everytime I plug the device. Does anyone experience this on a mac computer?

In a windows 7 PC it works perfectly, no messages at all after clicking the "remember" box.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes