FORUMS

[FTF] Sony Xperia Z Lollipop Release

Sony rolled out a Lollipop update for Xperia Z just yesterday. If you still haven’t gotten … more

Original Moto G Receives Lollipop, OTA Captured

The original Moto G was released almost two years ago. Motorola still continues to … more

Device Review: No.1 X1 Rugged Smartphone

We are almost at the end of Q2 for 2015, and we have seen most of the flagship phones for the … more

When a Friend or Family Member Asks for a Phone Recommendation, What Do You Tell Them?

The majority of us here at XDA would consider … more
Post Reply Subscribe to Thread Email Thread

TOWELROOT

14th April 2015, 12:41 PM |#151  
andu86's Avatar
OP Senior Member
Flag Bucharest
Thanks Meter: 63
 
More
Quote:
Originally Posted by iafko69

Hi,
This is my phone

So tell me what should I do to root it without trigger KNOX.
Towelroot dosn't work.

follow the steps from the first page
 
 
14th April 2015, 10:47 PM |#152  
MFaust's Avatar
Senior Member
Flag Oradea (Blaj)
Thanks Meter: 39
 
More
Info 2
Quote:
Originally Posted by MFaust

Hi, i just bought a S4 mini duos and i have android 4.2.2 the firmware is i9192XXUBNC1.

my question is... can i root it without trigger knox?

and... if it is possible i want to stay for a whille on 4.2.2 for some testing and after to update to 4.4.2

btw i tryed to update via OTA and it sayd that no update is available.

thanks!

i managet to root my S4 mini (android 4.2.2) without triggering Knox, this were the steps:

1 download and flash I9192XXUBMK4 (android 4.2.2) via ODIN
2 used Saferoot.zip (you can find it here on xda, dont remember the page right now)
3 because i got some force closed problems like weather and G search app i entered recovery wipe data and catche
4 reconfigurate device, open SuperSU and disable KNOX

Hope this helps someone!

(Dont forget to click thanks!)

P.S. System Status changed to CUSTOM!
20th May 2015, 04:24 PM |#153  
Member
Thanks Meter: 6
 
More
Info 2 Rooted I9195XXUCNK1
Quote:
Originally Posted by andu86

follow the steps from the first page

Hi to all !
- So, I would like to explain what happened in my case when I tried to root S4 mini International i9195 with towelroot.
- I was on original XXUCNK1 kernel from 3. november 2014. with KNOX on and I have downloaded this I9195XXUCNK1.zip kernel from this thread: http://forum.xda-developers.com/gala...ction-t2947372 and also I have downloaded old voulnerable kernel KERNEL_I9195XXUCNF7.zip and Odin 3.09 also but from an other thread here on the XDA.
- I have extracted ALL packages and I went in "Download mode" on the phone. (Swich off the phone and then keep holding all three buttons (1-Home button, 2-Volume Down and 3-Power button) on the phone until "Download mode" appeared on the screen and then pushed volume button UP (only once) to start download.
- Connected the phone with PC via USB cable and then I started Odin 3.09 by clicking right mouse button and "Run as Administrator".
- First I have choosen extracted old voulnerable kernel XXUCNF7.tar.md5 under AP in Odin and I didn't change anything under "Options" in the Odin (Auto Reboot and F. Reset Time was already checked) and I started the flashing. It took few seconds and I got green massage "PASS" on the Odin what means that it's done and it's O.K. Phone rebooted and started normaly but when I went to "Options" and "About the phone" to see changes in the kenel I have surprise to see that even everything in "Odin" was good during the flashing without any error I still had the same text and kernel which I had before the flashing.
- I thought, O.K. I have to change something in "Odin" and first I have uncheked in "Options" - "Auto reboot" and I have started the flashing process again.
Now it took much longer to flash (about one minute) and when i got green "PASS" message I took battery out and restarted the phone.
But after the phone was rebooted there was no changes in the options "About the phone". The kernel stated still XXUCKN1 and not XXUCNF7.
- Then I have uncheked and "F. Reset the time and Auto Reboot" in the "Odin" options and I started flashing again. It took some time and I got again green "PASS" in Odin.
- Again, I restarted the phone and it boot normaly and I wanted to see if now is something changed in "Options" and "About the phone".
But it was still unchanged with XXUCNK1 kernel.
- Fortunately I was not lazy to try to instal and run "Towelroot" again to see if it will maybe work because before I started all this flashing procedure I have already dowloaded and installed "Towelroot" but I got message that the phone is not supported.
And... When I clicked on "Make it rain" I got immediately message that my phone should have now have the root acces.
- I have rebooted the phone and installed "SuperSu_2.49" and updated SU binary via "Normal" way and disabled KNOX.
After that I flashed back (the new kernel with "Odin" and not checked any options in it) the new XXUCKN1 (when it is unpacked it has the name "boot.tar.md5") kernel even it already stated that it is on this kernel already, but anyway...
After that I have instaled BusyBox 28 Pro in the System and also Titanium Backup 7.1.2 and I checked if I got Samsung status: "Custom" but it was still "Original".
So ... I rebooted the phone thinking maybe after the reboot I will get the "Custom" status because of writing to the "System" but it was still "Original".
- Thus, everything worked good even it looks on the first hand that it will not work at all.
So, I hope that someone will have any benefits on this little help.

Cheers !!!
Last edited by Boombastical; 20th May 2015 at 04:53 PM. Reason: Syntax
The Following User Says Thank You to Boombastical For This Useful Post: [ View ]
20th May 2015, 06:56 PM |#154  
SilviuMik's Avatar
Senior Member
Thanks Meter: 975
 
Donate to Me
More
Quote:
Originally Posted by Boombastical

Cheers !!!

Just a small correction . U can`t see what kernel version u have . U see only 3.4.0 and some numbers and build date . NOTHING more related to what u flash that name XXUCNF7 or XXUCKN1
That is why u did not see different names there
In about phone there are 2 places which show XXUCKN1 for example : Baseband which is Modem and Build number which is system version ( build.prop file is responsible for that )
Cheers.
The Following 2 Users Say Thank You to SilviuMik For This Useful Post: [ View ]
Yesterday, 01:06 AM |#155  
RuffBuster's Avatar
Senior Member
Thanks Meter: 190
 
More
Quote:
Originally Posted by Boombastical

So, I hope that someone will have any benefits on this little help.

Cheers !!!

I always like to hear success stories. Thanks for reporting back. I'm about to take these same steps myself and root my new phone. I'm running the newer stock from March this year but I've got a good feeling things should proceed like yours.

Can you confirm that your system status is STILL showing "original" and is your knox still untripped?

Many thanks.

EDIT:

Worked a treat! No knox trip and fully rooted!

Now I just need to find and download my relevant stock firmware in case I need to flash for warranty purposes to remove root. But all good here very happy!

Also used Wanam to change device status to official I know it's only cosmetic but hey.
Last edited by RuffBuster; Yesterday at 12:23 PM.
Today, 05:43 AM |#156  
Member
Thanks Meter: 6
 
More
Hi RuffBuster,

Actually, I didn't check in „Download mode“ if the status is still „Official“, but in the options and „About the phone“ under „Secure boot status“ and there is still „Samsung“ so...
At the moment I don't have access to the phone but on the next monday I will check it.
I did check Knox immediatly after the root in „Download mode“ and it was 0x0. After that I have installed SuperSu, Busybox, Lucky patcher, Link2Sd, Xposed, Greenify... etc

Greetz !


Sent from my GT-N7000 using xda premium
The Following User Says Thank You to Boombastical For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S 4 Mini General by ThreadRank