FORUMS

Android M Preview Images – XDA TV

Android M preview images are available. That and much more news is covered by Jordan when he … more

I/O Summary: How Android M Handles Power And Charging

In the spirit of improving the core Android experience, Google is changing Android … more

I/O Summary: Google Photos App

At I/O 2015, Google tackled the information problem in mobile once more, this time through … more

I/O Summary: Development, Play Store, The Next Billion

VP of Engineering Jen Fitzpatrick began talking about what Google is doing to … more

DNScrypt proxy for Android install

Thanks Meter: 43
 
By Draygon, Senior Member on 24th June 2014, 10:10 AM
Post Reply Subscribe to Thread Email Thread
10th May 2015, 05:07 PM |#41  
Senior Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by Jasna.Grgurevic

Are you using windows or linux?

This is for Android (5.x)
 
 
19th May 2015, 01:00 PM |#42  
Teemoo's Avatar
Member
Thanks Meter: 25
 
More
I am getting "Unused dt entry" error by linker, with moffa~ 's pack. dnscrypt-proxy doesn't start. Any idea how can I solve this?

On 18/05/15 CM nightly. 5.1.1
Last edited by Teemoo; 19th May 2015 at 01:03 PM. Reason: more info
20th May 2015, 09:14 PM |#43  
Senior Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by Teemoo

I am getting "Unused dt entry" error by linker, with moffa~ 's pack. dnscrypt-proxy doesn't start. Any idea how can I solve this?

On 18/05/15 CM nightly. 5.1.1

Where are you seeing that error?
20th May 2015, 09:19 PM |#44  
Teemoo's Avatar
Member
Thanks Meter: 25
 
More
Quote:
Originally Posted by moffa~

Where are you seeing that error?


On terminal, when I type ""dnscrypt enable"
Enbling dnscrypt...
Segmentation fault
Killall: dnscrypt-proxy: no process killed
WARNING: linker: dnscrypt-proxy: unused DT entry: type 0x1d arg 0x5a8
Segmentation fault
Done

I also get unable to create a socket (UDP) error in logcat by dnscrypt-proxy when I search with dnscrypt

I don't use any firewalls
Last edited by Teemoo; 20th May 2015 at 09:23 PM. Reason: add quote
21st May 2015, 03:40 PM |#45  
Senior Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by Teemoo

On terminal, when I type ""dnscrypt enable"
Enbling dnscrypt...
Segmentation fault
Killall: dnscrypt-proxy: no process killed
WARNING: linker: dnscrypt-proxy: unused DT entry: type 0x1d arg 0x5a8
Segmentation fault
Done

I also get unable to create a socket (UDP) error in logcat by dnscrypt-proxy when I search with dnscrypt

I don't use any firewalls

I just updated to 5.1.1 and I see the same issue. Let me try recompiling with the new android ndk
22nd May 2015, 02:02 AM |#46  
Senior Member
Thanks Meter: 34
 
More
I am still getting the warning but I don't get the segmentation fault. It does work.

Which architecture are you running it on? It's compiled for armv7a. I can compile it for other architectures if you need it.

You can find out by running 'uname -m'
Last edited by moffa~; 22nd May 2015 at 02:51 AM.
22nd May 2015, 04:53 PM |#47  
Teemoo's Avatar
Member
Thanks Meter: 25
 
More
Quote:
Originally Posted by moffa~

Which architecture are you running it on? It's compiled for armv7a. I can compile it for other architectures if you need it.

You can find out by running 'uname -m'

Kernel Adiutor says it is armv7 rev 1 (v71)

uname -m says arm71

cpu's model is: msm8974pro-ac

So I belive it is armv7a?
22nd May 2015, 07:38 PM |#48  
Senior Member
Thanks Meter: 34
 
More
Same as mine. Can you try this file?
Attached Files
File Type: zip dnscrypt.zip - [Click for QR Code] (294.5 KB, 32 views)
22nd May 2015, 07:55 PM |#49  
Teemoo's Avatar
Member
Thanks Meter: 25
 
More
Quote:
Originally Posted by moffa~

Same as mine. Can you try this file?

Same error, Could it be because I am using SE Linux in Enforcing mode?

edit: Same error while se linux is in permissive mode.
Last edited by Teemoo; 22nd May 2015 at 07:58 PM.
22nd May 2015, 07:58 PM |#50  
Senior Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by Teemoo

Same error, Could it be because I am using SE Linux in Enforcing mode?

I'm also using SELinux in Enforcing mode. I'm not too worried about the warning as it still runs. Not sure what's causing the segmentation fault.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes