FORUMS

XPrivacy for Android Lollipop – XDA Xposed Tuesday

Have you ever been on the Google Play Store and saw an app that you wanted to … more

How a HTC Droid Eris Changed a Members Life

Rarely can a member say that Android development or XDA had a profound effect on … more

XDA Office Space: Frankenstein’s Perfect IM Client?

The portal’s decentralized XDA office lies in a Hangouts chatroom, where … more

Which IM Client on Android is best?

With so many different messengers to choose from, it can be tough to find the best one for you and … more

 View Poll Results: Is this guide helping you ?

Yes
 
66 Vote(s)
86.84%
No
 
10 Vote(s)
13.16%
Post Reply Subscribe to Thread Email Thread

[GUIDE]Porting Any Custom Roms[Fastest method][Update for porting MIUI Kitkat]

13th April 2015, 04:37 AM |#221  
Senior Member
Thanks Meter: 20
 
More
Quote:
Originally Posted by Trickster22

I tried porting many custom roms based on 4.4.4 by taking cm11 as base but every time after flashing rom and rebooting device, it boots back to recovery. Any solution for that?

There's something wrong with the kernel...

Sent from my Desire S using XDA Free mobile app
 
 
13th April 2015, 06:51 AM |#222  
Trickster22's Avatar
Member
Flag Faridabad
Thanks Meter: 92
 
More
Quote:
Originally Posted by antimage05

There's something wrong with the kernel...

Sent from my Desire S using XDA Free mobile app

I am using cm11 kernel

---------- Post added at 11:21 AM ---------- Previous post was at 11:15 AM ----------

I want to port custom roms based on 4.4.4 by taking cm11 as base but every time results in bootloop, so please explain steps to port hybrid roms, specially Carbon Rom.
16th April 2015, 07:16 AM |#223  
Member
The Land of Sportsmen, Bukit Jalil
Thanks Meter: 5
 
More
Can i port aosp as my base to mokee as port? the mokee spec for Xperia S and mine was Xperia Ion which have the same chipset..I've tried almost 10 times but it just stuck after the Sony logo..can someone help to read the logcat..what should i do to make the rom boot..thanks
Attached Files
File Type: txt LOGCAT(2015-04-16)(1345).TXT - [Click for QR Code] (204.6 KB, 4 views)
25th April 2015, 07:06 PM |#224  
shakim24's Avatar
Senior Member
Thanks Meter: 83
 
More
Getting a "error while flashing update binary" I'm porting AOSP s4 to my s3 using Omni ROM. I switched updater binary and still getting that error.
25th April 2015, 07:42 PM |#225  
Member
Flag tiaret
Thanks Meter: 12
 
More
Stuck in boot loop " port omni rom fron s7560m to s7562 ?
And thank for this guide
28th April 2015, 05:08 PM |#226  
TechUser01's Avatar
Member
Flag Mesola
Thanks Meter: 3
 
More
Problems with updater scripts
Hello to everyone who is reading this
I'm doing a porting of the FlyMe OS for the S3 Neo and I have some big problems with the updater-script of the ported rom... The kitchen made the port well but it says that there are parts that it can't do (and it put the ??? where it don't knows what to write). I tried to fix it but the original s3 neo updater-script is a way different from the ported script... So... If there is everyone who can resolve my problem... Please help me...
Here the link where you can download both updaters: https://mega.co.nz/#F!Zh1xTYIB!A6s6dpXv5UkcTRiBlpQycQ

Here things that the kitchen didn't wrote:
269-mount("mount("ext4", "EMMC", "???", "/data");
86-mount("ext4", "EMMC", "/dev/block/platform/mtk-msdc.0/by-name/custom", "0", "/custom", "???");
The Following User Says Thank You to TechUser01 For This Useful Post: [ View ]
24th May 2015, 05:59 AM |#227  
Member
Thanks Meter: 4
 
More
Hello
Thanks For this Great guide
there is something i need to understand
Base rom should be CM or AOSP
Port rom should be anything that can be compatible with the base rom ( same version and same ARM)

The question is , what if my device don't have a CM or an AOSP build ...
Is it Possible to port any rom in this case ?
My phone is Asus ZenFone 5 LTE (A500KL)
Using ARMv7
Post Reply Subscribe to Thread

Tags
porting miui, porting mokee open source project, porting pac slimkat sokp aokp aosb carbon aospa, porting rom
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes