FORUMS

Analysis & Opinion

Post Reply Subscribe to Thread Email Thread
3rd June 2015, 12:05 PM |#111  
Spannaa's Avatar
Recognized Contributor / Themer
Flag Cardiff
Thanks Meter: 12,846
 
Donate to Me
More
Quote:
Originally Posted by aureljared

I don't think so. I saw this line in your script:

Code:
dc_file=/data/dalvik-cache/system@app@$f@classes.dex
Correct me if I'm wrong, but I'm guessing you're checking only the existence of the already optimized dexfile, not the existence of a new dexfile in the theme.
Like what I did with mine:
Code:
checkdex() {
	if [ -e ./classes.dex ]; then
		if [ -e "/data/dalvik-cache/system@$1@$2@classes.dex" ]; then
			rm -f "/data/dalvik-cache/system@$1@$2@classes.dex"
		else
			rm -f "/cache/dalvik-cache/system@$1@$2@classes.dex"
		fi
	fi
}
# Refresh bytecode if necessary
cd /data/tmp/vrtheme/system/app/$f
checkdex "app" "$f"
cd ../

That's because I forgot to wrap the dalvik classes.dex file check inside an if included classes.dex check
Code:
if [ -f classes.dex ]; then

fi
Quote:
Originally Posted by aureljared

But it's okay if you don't want to test.

I've tested eviltheme-2.0.4.zip with a theme for my S2 on 4.1.2 and it fails on the preload partition theming. There's also no backup for the themed preload apks.

I've attached the recovery log.
Attached Files
File Type: log recovery.log - [Click for QR Code] (314.7 KB, 4 views)
The Following User Says Thank You to Spannaa For This Useful Post: [ View ]
 
 
3rd June 2015, 12:10 PM |#112  
anandisrocking007's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 96
 
More
Quote:
Originally Posted by Spannaa

You mean my version doesn't work either?

What device and rom did you try it on?

Pm me the zip you flashed & your recovery log and I'll take a look.



Sent via Bacon...

Sorry i got confused between the you and the eviltheme maker and posed to you the vrtheme works super don't worry about that
4th June 2015, 05:55 AM |#113  
aureljared's Avatar
OP Senior Member
Flag Quezon City
Thanks Meter: 495
 
Donate to Me
More
Quote:
Originally Posted by Spannaa

That's because I forgot to wrap the dalvik classes.dex file check inside an if included classes.dex check

Code:
if [ -f classes.dex ]; then

fi

I've tested eviltheme-2.0.4.zip with a theme for my S2 on 4.1.2 and it fails on the preload partition theming. There's also no backup for the themed preload apks.

I've attached the recovery log.

I fixed preload now, turns out I haven't even mounted the preload partition before theming.
Hope that fixes things now. Updated the 2.0.4 release.

Quote:
Originally Posted by anandisrocking007

Sorry i got confused between the you and the eviltheme maker and posed to you the vrtheme works super don't worry about that

Haha, no worries mate
Post Reply Subscribe to Thread

Tags
eviltheme, flash, recovery, theme, vrtheme
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes