FORUMS

Swappa’s New App Helps You Value Your Device

There comes a sad time in everyone’s life where you must part ways with your … more

Xiaomi Sold 34.7 Million Phones In 6 Months

2015 has been a phenomenal year for Xiaomi so far. With a stellar rise in 2014, 2015 saw … more

Sprint Reacts To Jab From T-Mobile

America’s cellular network space has always been a battle of the big four: Verizon, AT&T, … more

Floating Apps with Rovers – XDA App Review

There are a lot of great launchers to help customize your phone. Some Launchers allow … more

ZTE Open Firefox OS build thread (Mar25, updated for 3.0 build)

20 posts
Thanks Meter: 8
 
By hevangel, Junior Member on 21st June 2014, 09:52 PM
Post Reply Subscribe to Thread Email Thread
19th September 2014, 10:01 PM |#31  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by YemSalat

That probably wasn't me who helped you previously, but you're welcome anyway )
It's weird that you can't flash the 1.3, are you using the version which linr76 provided?

You can try flashing my 2.1 build (link), it should work for 1.1.


Thanks YemSalat!!! I finally could install your image so i am not in 1.1 anymore Your build is actually very cool, thanks for your images again. My next step will be triying to build it by myself, but my first attempts was also frustrating...we will see..
 
 
26th March 2015, 07:48 AM |#32  
OP Junior Member
Thanks Meter: 8
 
More
Somehow I found my old ZTE Open (1st gen) in a lost corner, so I decided to download the latest source from B2G, compile and flash the phone.
Now I have Firefox OS 3.0 running in the ZTE Open. 3.0 seems slightly faster than 2.2, but the radio app and video camera still do not work.
Other than that, I don't see any big difference between 3.0 and 2.2
Here is the link to the ROM image Enjoy.

https://drive.google.com/file/d/0B7H...zR0Y25DZmlkZm8
Attached Thumbnails
Click image for larger version

Name:	13516_10153118199105269_3267512846940999643_n.jpg
Views:	392
Size:	108.4 KB
ID:	3229785  
The Following User Says Thank You to hevangel For This Useful Post: [ View ]
26th March 2015, 06:51 PM |#33  
Saijin_Naib's Avatar
Member
Thanks Meter: 22
 
More
Quote:
Originally Posted by hevangel

Somehow I found my old ZTE Open (1st gen) in a lost corner, so I decided to download the latest source from B2G, compile and flash the phone.
Now I have Firefox OS 3.0 running in the ZTE Open. 3.0 seems slightly faster than 2.2, but the radio app and video camera still do not work.
Other than that, I don't see any big difference between 3.0 and 2.2
Here is the link to the ROM image Enjoy.

https://drive.google.com/file/d/0B7H...zR0Y25DZmlkZm8

Are GPS and the Home button light still broken?
27th March 2015, 06:24 AM |#34  
OP Junior Member
Thanks Meter: 8
 
More
Yeap. They are still broken.
The Following User Says Thank You to hevangel For This Useful Post: [ View ]
30th May 2015, 04:23 PM |#35  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by hevangel

Now I have Firefox OS 3.0 running in the ZTE Open. 3.0 seems slightly faster than 2.2, but the radio app and video camera still do not work.
Other than that, I don't see any big difference between 3.0 and 2.2.

How did you compile B2G 2.2 for inari at all? Every time I've tried I've run into bug 1121600 (can't link it because I'm a newbie here). The last time I tried to compile 3.0 it failed to flash the phone, so I figured that was the end of the line, but maybe that's been fixed. I wish they would branch to B2G 3.1 or something though, I don't want to use a pre-alpha on my phone (from what I've heard, they decided to only branch once a year because vendors complained about the frequency of updates).

Edit: I still get the same error trying to flash my phone with a local build of 3.0: "too many links". I need to try your build, but I have no idea why there would be a difference (and it's 2 months out of date at this point).

Edit2: I can flash the system.img you provided onto it without any problems! What the heck? I wonder if mine is too big: I noticed my system.img is 169.13MiB whereas yours is only 128.64MiB. The commandline I used was simply the following:
Code:
BRANCH=master VARIANT=user ./config.sh inari
BRANCH=master VARIANT=user ./build.sh
I think you omitted the 'VARIANT=user' part since the mochitest stuff is installed. I'll try omitting it too.

Edit3: Huh, so a 'VARIANT=eng' build using B2G tip and GCC 4.8 gives a system.img of 138.91MiB and a 'VARIANT=userdebug' build gives a system.img of 171.04MiB. I can flash the 'eng' variant onto my phone just fine! So that's that mystery at least partially solved - I wonder why it's bigger with the 'user' variants though.

Edit4: Except it doesn't detect my SIM card. Welp, back to the latest 2.1s it is.
Last edited by Ver Greeneyes; 30th May 2015 at 10:35 PM.
14th June 2015, 04:52 AM |#36  
Junior Member
Flag Pipersville
Thanks Meter: 3
 
More
Quote:
Originally Posted by Saijin_Naib

Are GPS and the Home button light still broken?

Downloaded TomTom app and after toggling location in settings a few times, GPS seems to be working!

Sent from my TouchPad using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes