FORUMS

[Q] [I9500] [4.3] GPSD Wakelock

48 posts
Thanks Meter: 6
 
By chinoquezada, Member on 24th January 2014, 07:06 PM
Post Reply Subscribe to Thread Email Thread
Hello all,

I'm having this recurring issue and I can't seem to solve it:
My I9500 S4 isn't going to deep sleep due to a GPSD Wakelock (as reported by BetterBatteryStats)

ROM: Wanamlite 3.9 JB 4.3
Kernel: Perseus

Things I've tried to solve it:

1. Froze (in Titanium Backup) most apps that uses network connectivity.
Haven't frozen Email (exchange corporate account from work) or gmail yet.

2. Deactivated all location settings.
No GPS, No Wirelss Network location, no location access to google apps, etc.

3. Wiped cache and dalvik cache
This solves the issue temporarily, but it returns within a few hours.

4. Factory Reset, Full Wipe and SD Card Wipe
Didn't solve a damn thing.

I'm attaching my BBS dumps.

If anyone has any idea about this, please help. I'm out of ideas

Thanks!
 
 
25th January 2014, 06:17 PM |#2  
OP Member
Flag Guayaquil
Thanks Meter: 6
 
More
bump
31st January 2014, 08:00 PM |#3  
OP Member
Flag Guayaquil
Thanks Meter: 6
 
More
Smile Solved!
Just a quick update, I managed to solve this problem by setting Network mode to WCDMA only.
After reading all over the net about GPSD battery drain, I concluded that my problem could be either caused by :
a. Misbehaving app (not my case) or
b. Radio interface problems (my case)

As it turns out, my local signal situation (Ecuador) is so "jumpy" that setting Network mode to Auto Connect, cause continuous GPSD wakelocks which didnt let my device go into deep sleep.
18th June 2015, 08:55 PM |#4  
Junior Member
Flag Caracas
Thanks Meter: 1
 
More
Ok i am going to write my experience, i hope it would be usefull for someone in the future.

Sympthoms exacly as described by op. I live in Venezuela. Bought a new S4, and updated it to LOLLIPOP. After that, I noticed the phone was not even warm but hot almost all the time. went to check battery stats and says this process (gpsd) is using a lot of power and also didint seem to go to deep sleep.

Tried everything. Set network mode in CDMA only, no good, if all made it worse because the radio searching for signal more often (i work on an area y suspect doesnt have good reception)
Set network mode for gsm only . This solved the battery and gpsd issue, but was no good to me because didnt like the idea of having a crippled phone.
Root and rename the GPSD file in android system. this worked but obliously lost gps capabilities. See last point.
Reflashed rom (stock), calibrate battery, changed fast dormancy, etc none of this worked. a time of lost hope i guess.

But then i thought of something else, what was the only variable I didnt mes with... the sim card. Mine was old because i like to take care for my phones and never lost any. In fact, it was a mini sim, and I exacto it to fit a S3 when I had one a year ago. Later sanded it a little to fit a LG G2 mini.

So i went and bought a replacement, same number. Put it in the phone, rename the gpsd file to original name and... same result.

As the last thing i did, i cleared cache and factory restored the phone AND VOILA. No more gpsd wakelock, no more other crazy wakelocks. No more heat. No more failoures. Actually, i unplugg it at 7:30 am and get home at 7:30 and STILL have 25% battery with GPS and WIFI on all day.

Conclussion: Check your sim card if you are having this problem, it may be the culprit.

Edit: sorry for my english, not my first languaje. I hope you understand
The Following User Says Thank You to rafaelsdmf For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
bbs, gpsd, wakelock

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes