FORUMS

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

Sunday Debate: How Can We Get a No-Compromise Phone?

Join us in a fun Sunday Debate on Compromises. Come with your opinions and … more

[T/V/TL/TX][TWRP][PhilZ Touch][CWM] XZDualRecovery Q&A

4,836 posts
Thanks Meter: 8,933
 
By [NUT], Recognized Contributor on 3rd April 2014, 10:01 AM
Post Reply Subscribe to Thread Email Thread
23rd June 2015, 10:15 AM |#81  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by [NUT]

Not really, it depends on the entry point (or boot hijack) of the other recovery package. If they are both replacing the same binary to introduce recovery boot, the chance is that it will work fine...

In your case, see if your previous package maintainer has a removal tool or instructions on how to remove that recovery.

I may managed to make a clean install, at least I have rebooted to Philz, but I can't mount sdcard1. This has happened at my first install, Philz can't mount sdcard1, Twrp can mount, backup, restore but gives error while flashing new Rom.

Can you please help me with mounting sdcard1 in Philz?

edit1:
Things are confusing here.
Good news: after "clean" installing xzdualrecovery I have now newer version of twrp and it solved all my problems.
Weird: I have booted to Twrp again instead of Philz(volume up). And philz mount problem is true.
Last edited by mkkyah; 23rd June 2015 at 10:28 AM. Reason: more information
 
 
23rd June 2015, 10:34 AM |#82  
[NUT]'s Avatar
OP Recognized Contributor
Flag Cyberspace and the Universe
Thanks Meter: 8,933
 
Donate to Me
More
Quote:
Originally Posted by mkkyah

I may managed to make a clean install, at least I have rebooted to Philz, but I can't mount sdcard1. This has happened at my first install, Philz can't mount sdcard1, Twrp can mount, backup, restore but gives error while flashing new Rom.

Can you please help me with mounting sdcard1 in Philz?

I actually wonder why that fails, because it is using a similar storage layout (if not 100% identical). Can you boot to philz and then try to mount sdcard1, then adb pull the log from /tmp/recovery.log ?

Then adb shell in and copy the output of these commands:
Code:
ls /dev/block/platform
ls /dev/block/platform/mmc_sdcc.1/
ls /dev/block/platform/mmc_sdcc.2/
ls /dev/block/platform/mmc_sdcc.3/
The Following User Says Thank You to [NUT] For This Useful Post: [ View ]
23rd June 2015, 12:17 PM |#83  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by [NUT]

I actually wonder why that fails, because it is using a similar storage layout (if not 100% identical). Can you boot to philz and then try to mount sdcard1, then adb pull the log from /tmp/recovery.log ?

Then adb shell in and copy the output of these commands:

Code:
ls /dev/block/platform
ls /dev/block/platform/mmc_sdcc.1/
ls /dev/block/platform/mmc_sdcc.2/
ls /dev/block/platform/mmc_sdcc.3/

I have ordered a Z3 Compact due to other several hardware problems on my V(and ironically Neo's Cm12.1 running incredibly smooth on my old V, everything's fine at the moment) So it seems that I won't need this on V, but I can do this steps if you need feedback. Just give me some time to play with my new toy, than I will be back to test.
Thanks so far
Last edited by mkkyah; 23rd June 2015 at 04:30 PM.
The Following User Says Thank You to mkkyah For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes